summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-12-21 16:24:27 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-22 09:53:10 -0200
commite45b4f86ae5b6ac8a5f422476c63d402683be003 (patch)
tree9daf263b9598bab85ced3571f78cba2196f66966
parent00c6716768c08803e99279c98f310c06237b1d21 (diff)
downloadmeta-fsl-arm-e45b4f86ae5b6ac8a5f422476c63d402683be003.tar.gz
linux-imx (2.6.35.3): Fix build errors when using make 3.82
This backports a fix from 2.6.36 to fix build failures when using make 3.82. ,---- | Author: Jan Beulich <JBeulich@novell.com> | Date: Mon Aug 16 11:58:58 2010 +0100 | | fixes for using make 3.82 | | It doesn't like pattern and explicit rules to be on the same line, | and it seems to be more picky when matching file (or really directory) | names with different numbers of trailing slashes. | | Signed-off-by: Jan Beulich <jbeulich@novell.com> | Acked-by: Sam Ravnborg <sam@ravnborg.org> | Andrew Benton <b3nton@gmail.com> | Cc: <stable@kernel.org> | Signed-off-by: Michal Marek <mmarek@suse.cz> `---- Change-Id: I7a56f54ad2bf6ab623705d8866d03f033a2e925e Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/fixes-for-using-make-3.82.patch51
-rw-r--r--recipes-kernel/linux/linux-imx_2.6.35.3.bb1
2 files changed, 52 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/fixes-for-using-make-3.82.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/fixes-for-using-make-3.82.patch
new file mode 100644
index 0000000..aa81fb2
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-2.6.35.3/fixes-for-using-make-3.82.patch
@@ -0,0 +1,51 @@
1From: Jan Beulich <JBeulich@novell.com>
2Date: Mon, 16 Aug 2010 11:58:58 +0100
3Subject: fixes for using make 3.82
4
5It doesn't like pattern and explicit rules to be on the same line,
6and it seems to be more picky when matching file (or really directory)
7names with different numbers of trailing slashes.
8
9Upstream-Status: Backport [2.6.36]
10
11Signed-off-by: Jan Beulich <jbeulich@novell.com>
12Acked-by: Sam Ravnborg <sam@ravnborg.org>
13Andrew Benton <b3nton@gmail.com>
14Cc: <stable@kernel.org>
15Signed-off-by: Michal Marek <mmarek@suse.cz>
16---
17 firmware/Makefile | 2 +-
18 scripts/mkmakefile | 4 +++-
19 2 files changed, 4 insertions(+), 2 deletions(-)
20
21diff --git a/firmware/Makefile b/firmware/Makefile
22index 2f1c370..bed7d05 100644
23--- a/firmware/Makefile
24+++ b/firmware/Makefile
25@@ -145,7 +145,7 @@ fw-shipped-$(CONFIG_FB_MXC_EINK_PANEL) += imx/epdc_E60_V110.fw \
26 fw-shipped-all := $(fw-shipped-y) $(fw-shipped-m) $(fw-shipped-)
27
28 # Directories which we _might_ need to create, so we have a rule for them.
29-firmware-dirs := $(sort $(patsubst %,$(objtree)/$(obj)/%/,$(dir $(fw-external-y) $(fw-shipped-all))))
30+firmware-dirs := $(sort $(addprefix $(objtree)/$(obj)/,$(dir $(fw-external-y) $(fw-shipped-all))))
31
32 quiet_cmd_mkdir = MKDIR $(patsubst $(objtree)/%,%,$@)
33 cmd_mkdir = mkdir -p $@
34diff --git a/scripts/mkmakefile b/scripts/mkmakefile
35index 67d59c7..5325423 100644
36--- a/scripts/mkmakefile
37+++ b/scripts/mkmakefile
38@@ -44,7 +44,9 @@ all:
39
40 Makefile:;
41
42-\$(all) %/: all
43+\$(all): all
44 @:
45
46+%/: all
47+ @:
48 EOF
49--
502.1.4
51
diff --git a/recipes-kernel/linux/linux-imx_2.6.35.3.bb b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
index df14c1c..1585e3b 100644
--- a/recipes-kernel/linux/linux-imx_2.6.35.3.bb
+++ b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
@@ -19,6 +19,7 @@ SRCBRANCH = "imx_2.6.35_maintain"
19SRC_URI += "file://NFS-Fix-nfsroot-support.patch \ 19SRC_URI += "file://NFS-Fix-nfsroot-support.patch \
20 file://NFS-allow-nfs-root-mount-to-use-alternate-rpc-ports.patch \ 20 file://NFS-allow-nfs-root-mount-to-use-alternate-rpc-ports.patch \
21 file://perf-avoid-use-sysroot-headers.patch \ 21 file://perf-avoid-use-sysroot-headers.patch \
22 file://fixes-for-using-make-3.82.patch \
22" 23"
23 24
24SRC_URI_append_mx28 = " \ 25SRC_URI_append_mx28 = " \