summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2015-01-15 12:29:47 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-16 15:45:59 -0200
commitb9d5eaa990b00cd3fa930a4163522c0ef47283db (patch)
tree6c8e5b4e20cec270efd1aa9ca8f66966853c6f41
parentb74e5e690d8d4e149ea9de3f0fcca37bad93935f (diff)
downloadmeta-fsl-arm-b9d5eaa990b00cd3fa930a4163522c0ef47283db.tar.gz
apptrk: add recipes for Layerscape1 support
Debug agent for Freescale CodeWarrior debugger Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch24
-rw-r--r--recipes-bsp/apptrk/apptrk/no-strip.patch20
-rw-r--r--recipes-bsp/apptrk/apptrk_git.bb24
3 files changed, 68 insertions, 0 deletions
diff --git a/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch b/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch
new file mode 100644
index 0000000..6b4a0e8
--- /dev/null
+++ b/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch
@@ -0,0 +1,24 @@
1Upstream-Status: Pending
2
3Signed-off-by: Chunrong Guo <B40290@freescale.com>
4
5
6 for fix the following error:
7 |install: cannot create regular file /usr/bin/apptrk
8 |No such file or directory
9
10
11--- a/Makefileold 2014-12-21 23:46:26.872329032 -0600
12+++ b/Makefile 2014-12-21 23:47:33.724326646 -0600
13@@ -89,9 +89,9 @@
14 # Other Targets
15 install: all
16 if [ -f $(DESTDIR)/usr/bin/apptrk ]; then rm -f $(DESTDIR)/usr/bin/apptrk ; fi
17- install $(OUTPUT) $(DESTDIR)/usr/bin/apptrk
18+ install -D $(OUTPUT) $(DESTDIR)/usr/bin/apptrk
19 if [ -f $(DESTDIR)/usr/bin/apptrk_debug ]; then rm -f $(DESTDIR)/usr/bin/apptrk_debug ; fi
20- install $(OUTPUT_DBG) $(DESTDIR)/usr/bin/apptrk_debug
21+ install -D $(OUTPUT_DBG) $(DESTDIR)/usr/bin/apptrk_debug
22
23 clean:
24 -$(RM) $(OBJS)$(OBJS_DBG)$(EXECUTABLES)$(C_DEPS)$(C_DEPS_DBG) $(OUTPUT) $(OUTPUT_DBG)
diff --git a/recipes-bsp/apptrk/apptrk/no-strip.patch b/recipes-bsp/apptrk/apptrk/no-strip.patch
new file mode 100644
index 0000000..a8cf620
--- /dev/null
+++ b/recipes-bsp/apptrk/apptrk/no-strip.patch
@@ -0,0 +1,20 @@
1Disable stripping of binaries
2
3We don't want to strip these as this is handled separately at package
4time.
5
6Upstream-Status: Inappropriate [configuration]
7
8Signed-off-by: Chunrong Guo <B40290@freescale.com>
9
10--- a/Makefileold 2015-01-07 03:45:32.786477574 -0600
11+++ b/Makefile 2015-01-07 03:46:28.426475588 -0600
12@@ -62,7 +62,7 @@
13 # CFLAGS += -DENABLE_64BIT_SUPPORT
14
15
16-LDFLAGS += -s
17+
18
19 # Add inputs and outputs from these tool invocations to the build variables
20
diff --git a/recipes-bsp/apptrk/apptrk_git.bb b/recipes-bsp/apptrk/apptrk_git.bb
new file mode 100644
index 0000000..4453cf8
--- /dev/null
+++ b/recipes-bsp/apptrk/apptrk_git.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Debug agent for Freescale CodeWarrior"
2SECTION = "apptrk"
3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://COPYING;md5=95560debfde180684364319811cc1421"
5
6DEPENDS = "elfutils"
7
8inherit kernel-arch
9
10SRC_URI = "git://git.freescale.com/ppc/sdk/apptrk.git;nobranch=1 \
11 file://apptrk-install-create-all-components-of-DEST.patch \
12 file://no-strip.patch \
13"
14SRCREV = "cbed10997c5e2a4aaa004fb0e1efec858bf1bbe1"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE = ""
19
20CFLAGS += " -I${STAGING_INCDIR}"
21
22do_install() {
23 oe_runmake install DESTDIR=${D}
24}