summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2014-09-04 12:33:15 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2014-09-15 09:35:13 -0300
commita7e9f553657957ec24e5df4ee499451703cd8297 (patch)
treea7ecf43e3d06fc5affd9d0418d6a3e84eb5f6fe6
parentda738059d3b1e9c82cc897624fbeeb22a9cd11b2 (diff)
downloadmeta-fsl-arm-a7e9f553657957ec24e5df4ee499451703cd8297.tar.gz
u-boot-ls1: Add recipe for Layerscape1 support
* u-boot-ls1-tools-native: provides the tcl script for endian swap * u-boot-ls1: the u-boot recipes for ls1021aqds and ls1021atwr support Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1-tools-native_2013.10.bb13
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1.inc14
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1_2013.10.bb24
3 files changed, 51 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ls1-tools-native_2013.10.bb b/recipes-bsp/u-boot/u-boot-ls1-tools-native_2013.10.bb
new file mode 100644
index 0000000..9d15bb6
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-ls1-tools-native_2013.10.bb
@@ -0,0 +1,13 @@
1require u-boot-ls1.inc
2
3RDEPENDS += "tcl-native"
4
5inherit native
6
7do_configure[noexec] = "1"
8do_compile[noexec] = "1"
9
10do_install () {
11 install -d ${D}/${bindir}
12 install -m 755 ${S}/byte_swap.tcl ${D}/${bindir}
13}
diff --git a/recipes-bsp/u-boot/u-boot-ls1.inc b/recipes-bsp/u-boot/u-boot-ls1.inc
new file mode 100644
index 0000000..ca84047
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-ls1.inc
@@ -0,0 +1,14 @@
1LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
2LIC_FILES_CHKSUM = " \
3 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
4 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
5 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
6 file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
7 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
8"
9
10SRCBRANCH = "LS1-dev"
11SRC_URI = "git://git.freescale.com/layerscape/ls1021a/u-boot.git;branch=${SRCBRANCH}"
12SRCREV = "48bfc6985a0524bc5c388bb9a9a6a6bc4a121ec5"
13
14S = "${WORKDIR}/git"
diff --git a/recipes-bsp/u-boot/u-boot-ls1_2013.10.bb b/recipes-bsp/u-boot/u-boot-ls1_2013.10.bb
new file mode 100644
index 0000000..f50c144
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-ls1_2013.10.bb
@@ -0,0 +1,24 @@
1require recipes-bsp/u-boot/u-boot.inc
2require u-boot-ls1.inc
3inherit fsl-u-boot-localversion
4
5LOCALVERSION ?= "+ls1"
6
7DEPENDS += "u-boot-ls1-tools-native"
8PROVIDES += "u-boot"
9
10do_compile_append () {
11 case "${UBOOT_MACHINE}" in
12 *spi*) tclsh byte_swap.tcl ${S}/u-boot.bin ${S}/u-boot.swap.bin 8
13 mv ${S}/u-boot.swap.bin ${S}/u-boot.bin;;
14 esac
15}
16
17PACKAGES += "${PN}-images"
18FILES_${PN}-images += "/boot"
19
20ALLOW_EMPTY_${PN} = "1"
21
22PACKAGE_ARCH = "${MACHINE_ARCH}"
23COMPATIBLE_MACHINE = "(ls102xa)"
24