summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2015-01-15 12:29:48 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-16 15:45:59 -0200
commita64487c13b1c2ad063baa7ba46db1fff5814b208 (patch)
treeb9a751e1f43eb4cb0d13035b6a7c5659f7097753
parentb9d5eaa990b00cd3fa930a4163522c0ef47283db (diff)
downloadmeta-fsl-arm-a64487c13b1c2ad063baa7ba46db1fff5814b208.tar.gz
asf : add recipes for Layerscape1 support
1. ASF depend on ipsec-tools in meta-openembeded. 2. ASF is Linux kernel implementation for accelerating the data pat processing on the Freescale family of processors Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--openembedded-layer/recipes-kernel/asf/asf_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/openembedded-layer/recipes-kernel/asf/asf_git.bb b/openembedded-layer/recipes-kernel/asf/asf_git.bb
new file mode 100644
index 0000000..038c09a
--- /dev/null
+++ b/openembedded-layer/recipes-kernel/asf/asf_git.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
2SECTION = "asf"
3LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=sdk-v1.7.x"
7SRCREV = "16eb472d6b2b34c8b605a86c469611bc8ddec1c9"
8
9inherit module
10
11S = "${WORKDIR}/git/asfmodule"
12
13EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
14export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
15
16INHIBIT_PACKAGE_STRIP = "1"
17
18do_install(){
19 mkdir -p ${D}/${libexecdir}
20 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/asf
21 cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
22 cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
23 cp -rf ${S}/scripts ${D}/${libexecdir}/
24}
25
26FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
27RDEPENDS_${PN} += "ipsec-tools"