summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2014-08-18 15:10:47 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2014-08-20 17:38:57 -0300
commit88ddd376e398c996ff0ac7a17920f86962f423a6 (patch)
tree8a332eaa2317b00347c96a50c8957942cb658807
parent22b6994fbf4dee3dc4ae2a16b414f5919f7454fc (diff)
downloadmeta-fsl-arm-88ddd376e398c996ff0ac7a17920f86962f423a6.tar.gz
mesa: Update mesa and mesa-demos to support Sololite.
SoloLite should use mesa software rendering GL since GPU for this machine does not have hardware accelerated GL. Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/mesa/mesa-demos_%.bbappend1
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend14
2 files changed, 13 insertions, 2 deletions
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend
index 989577d..221a3c0 100644
--- a/recipes-graphics/mesa/mesa-demos_%.bbappend
+++ b/recipes-graphics/mesa/mesa-demos_%.bbappend
@@ -2,3 +2,4 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI_append_mx6 = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch" 3SRC_URI_append_mx6 = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch"
4 4
5PACKAGECONFIG_remove_mx6sl = "gles1 gles2"
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 8e0a36b..adcf201 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -2,9 +2,19 @@ PACKAGECONFIG_remove_mx5 = "egl gles"
2PROVIDES_remove_mx5 = "virtual/libgles1 virtual/libgles2 virtual/egl" 2PROVIDES_remove_mx5 = "virtual/libgles1 virtual/libgles2 virtual/egl"
3 3
4PACKAGECONFIG_remove_mx6 = "egl gles" 4PACKAGECONFIG_remove_mx6 = "egl gles"
5PROVIDES_remove_mx6 = "virtual/libgl virtual/libgles1 virtual/libgles2 virtual/egl" 5
6# i.MX6SL uses mesa software rendering
7
8PROVIDES_remove_mx6 = "virtual/libgles1 virtual/libgles2 virtual/egl"
9PROVIDES_remove_mx6q = "virtual/libgl"
10PROVIDES_remove_mx6dl = "virtual/libgl"
11
12USE_VIV_LIBGL = "yes"
13USE_VIV_LIBGL_mx6sl = "no"
6 14
7# FIXME: Dirty hack to allow use of Vivante GPU libGL binary 15# FIXME: Dirty hack to allow use of Vivante GPU libGL binary
8do_install_append_mx6 () { 16do_install_append_mx6 () {
9 rm -f ${D}${libdir}/libGL.* 17 if [ "${USE_VIV_LIBGL}" = "yes" ]; then
18 rm -f ${D}${libdir}/libGL.*
19 fi
10} 20}