summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2014-12-30 15:11:06 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2014-12-31 17:13:06 -0200
commit7539a694f3d01f1ab5162bfee16b0327f827c4f7 (patch)
tree2181ee3bd37257e3aea18ac05ae5b9ea8de2b820
parent07bf218d3f29801320ec4c621a8f197394a83d16 (diff)
downloadmeta-fsl-arm-7539a694f3d01f1ab5162bfee16b0327f827c4f7.tar.gz
mqxboot: provide explicit do_install
mqxboot is a pure make project. Inheriting autotools provided an implicit do_install task, however with the change to seperate builddirs in dizzy (${B} != ${S}) do_install fails. Removing autotools and providing an explicit do_install task fixes this. Signed-off-by: Max Krummenacher <max.oss.09@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/mqxboot/mqxboot_1.0.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-bsp/mqxboot/mqxboot_1.0.bb b/recipes-bsp/mqxboot/mqxboot_1.0.bb
index 1293928..5009209 100644
--- a/recipes-bsp/mqxboot/mqxboot_1.0.bb
+++ b/recipes-bsp/mqxboot/mqxboot_1.0.bb
@@ -5,8 +5,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c49712341497d0b5f2e40c30dff2af9d"
5 5
6DEPENDS = "kernel-module-mcc" 6DEPENDS = "kernel-module-mcc"
7 7
8inherit autotools
9
10SRC_URI = "http://repository.timesys.com/buildsources/m/mqxboot/mqxboot-${PV}/mqxboot-${PV}.tar.bz2" 8SRC_URI = "http://repository.timesys.com/buildsources/m/mqxboot/mqxboot-${PV}/mqxboot-${PV}.tar.bz2"
11 9
12SRC_URI[md5sum] = "3de3c8b5f8cd6664870587d29c04c421" 10SRC_URI[md5sum] = "3de3c8b5f8cd6664870587d29c04c421"
@@ -19,3 +17,7 @@ CFLAGS += "-I${STAGING_KERNEL_DIR}/include"
19RDEPENDS_${PN} = "kernel-module-mcc" 17RDEPENDS_${PN} = "kernel-module-mcc"
20 18
21COMPATIBLE_MACHINE = "(vf60)" 19COMPATIBLE_MACHINE = "(vf60)"
20
21do_install() {
22 oe_runmake 'DESTDIR=${D}' install
23}