summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-01-06 13:43:35 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-12 10:23:45 -0200
commit61aeebb34b1eaf0b10674e27378dd1e012b79cba (patch)
tree6d386ba5c21490c9a05e53f288d57afc98c44723
parent7539a694f3d01f1ab5162bfee16b0327f827c4f7 (diff)
downloadmeta-fsl-arm-61aeebb34b1eaf0b10674e27378dd1e012b79cba.tar.gz
kernel-module-mcc: Only include mvf_sema4.h if building in kernel
When mcc_config.h is used to make application we shouldn't include mvf_sema4.h as it is an internal symbol of kernel and shouldn't be directly referenced by user space applications using the MCC interface. This allows for application developers to use the SDK without having to copy the 'mvf_sema4.h' header byhand. More detailed information at: https://lists.yoctoproject.org/pipermail/meta-freescale/2015-January/012144.html Change-Id: I39a519d10a15b951c573007d3cf689f32aac3f30 Reported-by: Petr Kubizňák <kubiznak.petr@elnico.cz> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-kernel/kernel-module-mcc/kernel-module-mcc/mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch51
-rw-r--r--recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.06.bb3
2 files changed, 53 insertions, 1 deletions
diff --git a/recipes-kernel/kernel-module-mcc/kernel-module-mcc/mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch b/recipes-kernel/kernel-module-mcc/kernel-module-mcc/mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch
new file mode 100644
index 0000000..570edaa
--- /dev/null
+++ b/recipes-kernel/kernel-module-mcc/kernel-module-mcc/mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch
@@ -0,0 +1,51 @@
1From 17e04c68557c4c9cb1a0112717019329a0cc3f96 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Tue, 6 Jan 2015 13:39:50 -0200
4Subject: [PATCH] mcc_config.h: Only include mvf_sema4.h if building in kernel
5Organization: O.S. Systems Software LTDA.
6
7When mcc_config.h is used to make application we shouldn't include
8mvf_sema4.h as it is an internal symbol of kernel and shouldn't be
9directly referenced by user space applications using the MCC
10interface.
11
12This patch puts a guard using __KERNEL__ define, avoiding the include
13and the definition of MCC_SHMEM_SEMAPHORE_NUMBER as
14MVF_SHMEM_SEMAPHORE_NUMBER would be undefined.
15
16Upstream-Status: Pending
17
18Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
19---
20 mcc_config.h | 8 +++++---
21 1 file changed, 5 insertions(+), 3 deletions(-)
22
23diff --git a/mcc_config.h b/mcc_config.h
24index 6a12c6d..3887aad 100644
25--- a/mcc_config.h
26+++ b/mcc_config.h
27@@ -18,8 +18,13 @@
28 #ifndef __MCC_CONFIG__
29 #define __MCC_CONFIG__
30
31+#ifdef __KERNEL__
32 #include <linux/mvf_sema4.h>
33
34+/* semaphore number */
35+#define MCC_SHMEM_SEMAPHORE_NUMBER (MVF_SHMEM_SEMAPHORE_NUMBER)
36+#endif
37+
38 /* used OS */
39 #define MCC_OS_USED (MCC_LINUX)
40
41@@ -47,7 +52,4 @@
42 /* other cores, besides this participating in mcc */
43 #define MCC_OTHER_CORES {1}
44
45-/* semaphore number */
46-#define MCC_SHMEM_SEMAPHORE_NUMBER (MVF_SHMEM_SEMAPHORE_NUMBER)
47-
48 #endif /* __MCC_CONFIG__ */
49--
502.1.4
51
diff --git a/recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.06.bb b/recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.06.bb
index b215d9c..3cd96bc 100644
--- a/recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.06.bb
+++ b/recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.06.bb
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c8959abcbbe4d6676c58eab9354019e6"
5 5
6inherit module 6inherit module
7 7
8SRC_URI = "http://repository.timesys.com/buildsources/m/mcc-kmod/mcc-kmod-${PV}/mcc-kmod-${PV}.tar.bz2" 8SRC_URI = "http://repository.timesys.com/buildsources/m/mcc-kmod/mcc-kmod-${PV}/mcc-kmod-${PV}.tar.bz2 \
9 file://mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch"
9 10
10SRC_URI[md5sum] = "d0507968592af5d8781e8bdbbb249e7d" 11SRC_URI[md5sum] = "d0507968592af5d8781e8bdbbb249e7d"
11SRC_URI[sha256sum] = "43f834ddf9845da843c7790a307a0dbc8b04a40deed06aed7c3c99ad3a273f6c" 12SRC_URI[sha256sum] = "43f834ddf9845da843c7790a307a0dbc8b04a40deed06aed7c3c99ad3a273f6c"