summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2015-01-15 12:29:55 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-16 15:46:00 -0200
commit52a239ea48a50b0628d9b667997558c7a4d120cf (patch)
tree2cd27174fb5673fe8d24106563226864c3043df8
parent73a74f7c33ad2303d7a2d80551c02cb27650282d (diff)
downloadmeta-fsl-arm-52a239ea48a50b0628d9b667997558c7a4d120cf.tar.gz
qemu-fsl: add recipes for Layerscape1 support
QEMU is a generic and open source machine emulator and virtualizer. Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-devtools/qemu/qemu-fsl_git.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu-fsl_git.bb b/recipes-devtools/qemu/qemu-fsl_git.bb
new file mode 100644
index 0000000..20386e2
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-fsl_git.bb
@@ -0,0 +1,50 @@
1require recipes-devtools/qemu/qemu.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
4 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
5
6# This means QEMU v1.7 with FSL specific patches applied
7PV = "1.7+${SRCPV}"
8
9# NOTE: these options are note available in qemu 1.7, but qemu.inc assumes
10# version 2.0+ where they are available. For now we unset them, but we should
11# remove the following lines when upgrading to qemu 2.0+:
12PACKAGECONFIG[quorum] = ""
13PACKAGECONFIG[lzo] = ""
14PACKAGECONFIG[numa] = ""
15PACKAGECONFIG[gtk+] = ""
16
17SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=sdk-v1.7.x \
18"
19SRCREV = "6ac4597c059d35e2737b234747243e56d340f4db"
20
21S = "${WORKDIR}/git"
22
23QEMU_TARGETS = "arm"
24
25inherit pkgconfig
26
27# Append build host pkg-config paths for native target since the host may provide sdl
28do_configure_prepend() {
29 export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config
30}
31
32do_configure_append () {
33 if ! grep 'CONFIG_FDT=y' config-host.mak; then
34 echo "CONFIG_RDMA=y" >> config_host_mak
35 fi
36}
37
38# gets around qemu.inc trying to install powerpc_rom.bin
39do_install_prepend() {
40 touch ${WORKDIR}/powerpc_rom.bin
41}
42
43do_install_append() {
44 rm ${WORKDIR}/powerpc_rom.bin
45
46 # Prevent QA warnings about installed ${localstatedir}/run
47 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
48}
49
50FILES_${PN} += "/usr/share/qemu/"