summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2015-01-15 12:29:50 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-16 15:45:59 -0200
commit3f1800cc2f67c7b101ca61aa86cf7d7f25fdbbd9 (patch)
tree4d34c4e93e29f23bdef061ea2af344a9ba749506
parent4832ecf8f46859ecd0a408707905843f3a5e6971 (diff)
downloadmeta-fsl-arm-3f1800cc2f67c7b101ca61aa86cf7d7f25fdbbd9.tar.gz
linux-ls1: update to sdk v1.7 release
This includes following changes: bdb722f arm: dts: ls1021a-twr: remove dspi1 node for cannot be verified fb3f709 arm: ls1: only call ls1_pm_iomap() when doing deep sleep c15b78f ls1021a/dts: Add eTSEC1 as wake-up event source 5f94f9f qspi: ls102xa: Adjust the size of QSPI AMBA Bus memory map Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--conf/machine/ls1021aqds.conf2
-rw-r--r--conf/machine/ls1021atwr.conf2
-rw-r--r--recipes-kernel/linux/linux-ls1.inc4
-rw-r--r--recipes-kernel/linux/linux-ls1_3.12.bb4
4 files changed, 6 insertions, 6 deletions
diff --git a/conf/machine/ls1021aqds.conf b/conf/machine/ls1021aqds.conf
index d659196..24ee6df 100644
--- a/conf/machine/ls1021aqds.conf
+++ b/conf/machine/ls1021aqds.conf
@@ -15,7 +15,7 @@ UBOOT_CONFIG[qspi] = "ls1021aqds_qspi_config"
15UBOOT_CONFIG[nor-secboot] = "ls1021aqds_nor_secboot_config" 15UBOOT_CONFIG[nor-secboot] = "ls1021aqds_nor_secboot_config"
16UBOOT_CONFIG[lpuart] = "ls1021aqds_lpuart_config" 16UBOOT_CONFIG[lpuart] = "ls1021aqds_lpuart_config"
17 17
18KERNEL_DEVICETREE = "ls1021aqds.dtb" 18KERNEL_DEVICETREE = "ls1021a-qds.dtb"
19 19
20SERIAL_CONSOLES ?= "115200;ttyS0 115200;ttyS1 115200;ttyEHV0 115200;ttyLP0" 20SERIAL_CONSOLES ?= "115200;ttyS0 115200;ttyS1 115200;ttyEHV0 115200;ttyLP0"
21SERIAL_CONSOLES_CHECK ?= "${SERIAL_CONSOLES}" 21SERIAL_CONSOLES_CHECK ?= "${SERIAL_CONSOLES}"
diff --git a/conf/machine/ls1021atwr.conf b/conf/machine/ls1021atwr.conf
index e549ac3..1d46f98 100644
--- a/conf/machine/ls1021atwr.conf
+++ b/conf/machine/ls1021atwr.conf
@@ -15,7 +15,7 @@ UBOOT_CONFIG[sdcard] = "ls1021atwr_sdcard_config,sdcard"
15UBOOT_CONFIG[lpuart] = "ls1021atwr_lpuart_config" 15UBOOT_CONFIG[lpuart] = "ls1021atwr_lpuart_config"
16 16
17 17
18KERNEL_DEVICETREE ?= "ls1021atwr.dtb" 18KERNEL_DEVICETREE ?= "ls1021a-twr.dtb"
19 19
20SERIAL_CONSOLES ?= "115200;ttyS0 115200;ttyS1 115200;ttyEHV0 115200;ttyLP0" 20SERIAL_CONSOLES ?= "115200;ttyS0 115200;ttyS1 115200;ttyEHV0 115200;ttyLP0"
21SERIAL_CONSOLES_CHECK ?= "${SERIAL_CONSOLES}" 21SERIAL_CONSOLES_CHECK ?= "${SERIAL_CONSOLES}"
diff --git a/recipes-kernel/linux/linux-ls1.inc b/recipes-kernel/linux/linux-ls1.inc
index 72be738..cd8398e 100644
--- a/recipes-kernel/linux/linux-ls1.inc
+++ b/recipes-kernel/linux/linux-ls1.inc
@@ -2,9 +2,9 @@ LICENSE = "GPLv2"
2LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" 2LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
3 3
4inherit kernel fsl-kernel-localversion 4inherit kernel fsl-kernel-localversion
5LOCALVERSION ?= "-${SRCBRANCH}" 5LOCALVERSION ?= "+ls1"
6 6
7SRC_URI = "git://git.freescale.com/layerscape/ls1021a/linux.git;branch=${SRCBRANCH} \ 7SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;branch=${SRCBRANCH} \
8 file://defconfig \ 8 file://defconfig \
9" 9"
10 10
diff --git a/recipes-kernel/linux/linux-ls1_3.12.bb b/recipes-kernel/linux/linux-ls1_3.12.bb
index 4e1e85b..c33485c 100644
--- a/recipes-kernel/linux/linux-ls1_3.12.bb
+++ b/recipes-kernel/linux/linux-ls1_3.12.bb
@@ -5,7 +5,7 @@ Layerscape1 Family Boards. "
5require recipes-kernel/linux/linux-ls1.inc 5require recipes-kernel/linux/linux-ls1.inc
6require recipes-kernel/linux/linux-dtb.inc 6require recipes-kernel/linux/linux-dtb.inc
7 7
8SRCBRANCH = "ls1-dev" 8SRCBRANCH = "sdk-v1.7.x"
9SRCREV = "3ced9e82f9f3f7b232bea0bd18c9a62572c06b44" 9SRCREV = "6619b8b55796cdf0cec04b66a71288edd3057229"
10 10
11COMPATIBLE_MACHINE = "(ls102xa)" 11COMPATIBLE_MACHINE = "(ls102xa)"