summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Dimitrov <picmaster@mail.bg>2015-02-15 15:24:06 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-02-15 17:19:37 -0200
commit3c1dfb7661cc527311da2af6003fa24b02e8636e (patch)
tree8ee7ea819a8710c71fc509f6e3a5841bd503a816
parent9709b9bbf171e83b7531a62ad73d3d5d04bda400 (diff)
downloadmeta-fsl-arm-3c1dfb7661cc527311da2af6003fa24b02e8636e.tar.gz
linux-imx: Disable imx6sl-specific code when imx6sl SOC support is disabled
Currently the build fails when CONFIG_SOC_IMX6SL is disabled, due to some hard-coded stuff. The patch purpose is to handle enabling/disabling this config option. Signed-off-by: Nikolay Dimitrov <picmaster@mail.bg> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-kernel/linux/linux-imx-3.10.17/0002-ARM-imx6sl-Disable-imx6sl-specific-code-when-imx6sl-.patch37
-rw-r--r--recipes-kernel/linux/linux-imx_3.10.17.bb4
2 files changed, 40 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-imx-3.10.17/0002-ARM-imx6sl-Disable-imx6sl-specific-code-when-imx6sl-.patch b/recipes-kernel/linux/linux-imx-3.10.17/0002-ARM-imx6sl-Disable-imx6sl-specific-code-when-imx6sl-.patch
new file mode 100644
index 0000000..81c2b2e
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-3.10.17/0002-ARM-imx6sl-Disable-imx6sl-specific-code-when-imx6sl-.patch
@@ -0,0 +1,37 @@
1From d677e1c37de1fe3b91f8ccfe92fc98bec437d10e Mon Sep 17 00:00:00 2001
2From: Nikolay Dimitrov <picmaster@mail.bg>
3Date: Sun, 15 Feb 2015 13:10:27 +0200
4Subject: [PATCH] ARM: imx6sl: Disable imx6sl-specific code when imx6sl SOC
5 support is disabled
6
7Currently the build fails when CONFIG_SOC_IMX6SL is disabled, due to some
8hard-coded stuff. The patch purpose is to handle enabling/disabling this
9config option.
10
11Signed-off-by: Nikolay Dimitrov <picmaster@mail.bg>
12---
13 arch/arm/mach-imx/mxc.h | 4 ++++
14 1 file changed, 4 insertions(+)
15
16diff --git a/arch/arm/mach-imx/mxc.h b/arch/arm/mach-imx/mxc.h
17index c78174d..de99050 100644
18--- a/arch/arm/mach-imx/mxc.h
19+++ b/arch/arm/mach-imx/mxc.h
20@@ -155,10 +155,14 @@ extern unsigned int __mxc_cpu_type;
21 #endif
22
23 #ifndef __ASSEMBLY__
24+# ifdef CONFIG_SOC_IMX6SL
25 static inline bool cpu_is_imx6sl(void)
26 {
27 return __mxc_cpu_type == MXC_CPU_IMX6SL;
28 }
29+# else
30+# define cpu_is_imx6sl() (0)
31+# endif
32
33 static inline bool cpu_is_imx6dl(void)
34 {
35--
361.7.10.4
37
diff --git a/recipes-kernel/linux/linux-imx_3.10.17.bb b/recipes-kernel/linux/linux-imx_3.10.17.bb
index 143eaab..17eb4fa 100644
--- a/recipes-kernel/linux/linux-imx_3.10.17.bb
+++ b/recipes-kernel/linux/linux-imx_3.10.17.bb
@@ -15,6 +15,8 @@ SRCBRANCH = "imx_3.10.17_1.0.0_ga"
15SRCREV = "33597e348b2d60dd5c71890ef7b7d3d3fd6e4e97" 15SRCREV = "33597e348b2d60dd5c71890ef7b7d3d3fd6e4e97"
16LOCALVERSION = "-1.0.2_ga" 16LOCALVERSION = "-1.0.2_ga"
17 17
18SRC_URI += "file://0001-ARM-clk-imx6q-fix-video-divider-for-revision-1.0-of-.patch" 18SRC_URI += "file://0001-ARM-clk-imx6q-fix-video-divider-for-revision-1.0-of-.patch \
19 file://0002-ARM-imx6sl-Disable-imx6sl-specific-code-when-imx6sl-.patch \
20"
19 21
20COMPATIBLE_MACHINE = "(mx6)" 22COMPATIBLE_MACHINE = "(mx6)"