summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2014-09-04 12:33:17 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2014-09-15 09:35:13 -0300
commit2d614c09d005799a228b0f99c8d325a573a36699 (patch)
tree021e2a9690dae0edc6e4b8ed3337f4b9352cd862
parentecde2869a4911f694d54869050089e3766bb5b0a (diff)
downloadmeta-fsl-arm-2d614c09d005799a228b0f99c8d325a573a36699.tar.gz
rcw: add recipes for Layerscape1 support
The reset configuration word (RCW) manages the hardware configuration info for QorIQ targets, rcw is used by the preboot loader to begin system configuration. Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch57
-rw-r--r--recipes-bsp/rcw/rcw_git.bb36
2 files changed, 93 insertions, 0 deletions
diff --git a/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch b/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch
new file mode 100644
index 0000000..51f6eeb
--- /dev/null
+++ b/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch
@@ -0,0 +1,57 @@
1From f2e796c903b2a3f81dbd38da3dc087cb7539d307 Mon Sep 17 00:00:00 2001
2From: Zhenhua Luo <zhenhua.luo@freescale.com>
3Date: Wed, 3 Sep 2014 03:03:42 -0500
4Subject: [PATCH] Makefile: make BOARDS/DESTDIR overidable and add endian
5 switch
6
71. For one specific board, no need to build the rcw for all supported
8 targets, make BOARDS and DESTDIR overridable to achieve this.
92. Add the endian swap for qspiboot rcw
10
11Upstream-Status: Pending
12
13Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
14---
15 Makefile | 4 ++--
16 Makefile.inc | 9 +++++++--
17 2 files changed, 9 insertions(+), 4 deletions(-)
18
19diff --git a/Makefile b/Makefile
20index 6ec1697..0f94293 100644
21--- a/Makefile
22+++ b/Makefile
23@@ -1,5 +1,5 @@
24-DESTDIR = .
25-BOARDS = b4420qds b4860qds \
26+DESTDIR ?= .
27+BOARDS ?= b4420qds b4860qds \
28 ls1021aqds ls1021atwr \
29 p2041rdb p3041ds p4080ds p5020ds p5040ds \
30 t1040rdb t1042rdb t1042rdb_pi t1040qds t2080rdb t2080qds t2081qds t4240qds t4240rdb
31diff --git a/Makefile.inc b/Makefile.inc
32index 4cadb2e..6e8b78f 100644
33--- a/Makefile.inc
34+++ b/Makefile.inc
35@@ -1,4 +1,4 @@
36-DESTDIR = .
37+DESTDIR ?= .
38 INSTALL = install
39 PYTHON ?= python2
40 RCW = $(PYTHON) ../rcw.py
41@@ -18,7 +18,12 @@ all: $(targets)
42 install: $(targets)
43 $(INSTALL) -d $(DESTDIR)
44 @for file in $^; do \
45- $(INSTALL) -m 644 -D $$file $(DESTDIR)/$$file; \
46+ case $$file in \
47+ *qspiboot*) file_swap="`echo $$file | sed -e 's/qspiboot/qspiboot_swap/'`"; \
48+ tclsh byte_swap.tcl $$file $$file_swap 8 ; \
49+ $(INSTALL) -m 644 -D $$file_swap $(DESTDIR)/$$file_swap ;; \
50+ *) $(INSTALL) -m 644 -D $$file $(DESTDIR)/$$file; \
51+ esac \
52 done
53 $(INSTALL) -m 644 -D README $(DESTDIR)
54
55--
561.7.9.7
57
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
new file mode 100644
index 0000000..5849a7c
--- /dev/null
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Reset Configuration Word"
2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e"
5
6DEPENDS += "u-boot-ls1-tools-native"
7
8inherit deploy
9
10SRCBRANCH = "LS1-SDK"
11SRCREV = "7b358441dfd35afbf01491649cc3f4396154a546"
12SRC_URI = "git://git.freescale.com/layerscape/ls1021a/rcw.git;branch=${SRCBRANCH} \
13 file://rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch \
14"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=${D}/boot/rcw/"
19
20do_install () {
21 oe_runmake install
22}
23
24do_deploy () {
25 install -d ${DEPLOYDIR}/rcw
26 cp -r ${D}/boot/rcw/* ${DEPLOYDIR}/rcw/
27}
28addtask deploy after do_install
29
30PACKAGES += "${PN}-image"
31FILES_${PN}-image += "/boot"
32
33ALLOW_EMPTY_${PN} = "1"
34
35PACKAGE_ARCH = "${MACHINE_ARCH}"
36COMPATIBLE_MACHINE = "(ls102xa)"