summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-01-22 09:10:22 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2013-01-22 22:03:34 -0200
commit61572aed9ea17c06dfe8d331b5e259663e19fed7 (patch)
tree7f2256fa2a391fea2511369b29b1105a68c5eeb5
parent63a94e5eb2d4f54b66313fdf8d67b4e440f46bc2 (diff)
downloadmeta-fsl-arm-61572aed9ea17c06dfe8d331b5e259663e19fed7.tar.gz
linux-imx (3.0.35): Fix imx6sabrelite patch to remove eGalax change
The eGalax change is now applied in all linux-imx-3.0.35 kernels so we need to remove this from the patch. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch50
-rw-r--r--recipes-kernel/linux/linux-imx_3.0.35.bb2
2 files changed, 1 insertions, 51 deletions
diff --git a/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch b/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch
index 5f22380..3e5ea68 100644
--- a/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch
+++ b/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch
@@ -4994,23 +4994,6 @@ new mode 100644
4994index 7cf975a..a2589e4 4994index 7cf975a..a2589e4
4995--- a/drivers/input/touchscreen/Kconfig 4995--- a/drivers/input/touchscreen/Kconfig
4996+++ b/drivers/input/touchscreen/Kconfig 4996+++ b/drivers/input/touchscreen/Kconfig
4997@@ -199,6 +199,16 @@ config TOUCHSCREEN_ELAN
4998 To compile this driver as a module, choose M here: the
4999 module will be called elan-touch.
5000
5001+config TOUCHSCREEN_EGALAX_SINGLE_TOUCH
5002+ bool "EETI eGalax touchscreen as single-touch"
5003+ default N
5004+ depends on TOUCHSCREEN_EGALAX
5005+ help
5006+ If you say yes here you get single-touch touchscreen support
5007+ on the eGalax I2C controller.
5008+ If you say "no", you'll get the normal multi-touch.
5009+
5010+
5011 config TOUCHSCREEN_FUJITSU
5012 tristate "Fujitsu serial touchscreen"
5013 select SERIO
5014@@ -282,6 +292,22 @@ config TOUCHSCREEN_MAX11801 4997@@ -282,6 +292,22 @@ config TOUCHSCREEN_MAX11801
5015 To compile this driver as a module, choose M here: the 4998 To compile this driver as a module, choose M here: the
5016 module will be called max11801_ts. 4999 module will be called max11801_ts.
@@ -5075,39 +5058,6 @@ index e614512..eac3453
5075diff --git a/drivers/input/touchscreen/da9052_tsi_filter.c b/drivers/input/touchscreen/da9052_tsi_filter.c 5058diff --git a/drivers/input/touchscreen/da9052_tsi_filter.c b/drivers/input/touchscreen/da9052_tsi_filter.c
5076old mode 100755 5059old mode 100755
5077new mode 100644 5060new mode 100644
5078diff --git a/drivers/input/touchscreen/egalax_ts.c b/drivers/input/touchscreen/egalax_ts.c
5079index fff8afe..0b6cde7 100644
5080--- a/drivers/input/touchscreen/egalax_ts.c
5081+++ b/drivers/input/touchscreen/egalax_ts.c
5082@@ -139,7 +139,7 @@ retry:
5083 events[id].x = x;
5084 events[id].y = y;
5085
5086-#ifdef FORCE_SINGLE_POINTER_SUPPORT
5087+#ifdef CONFIG_TOUCHSCREEN_EGALAX_SINGLE_TOUCH
5088 input_report_abs(input_dev, ABS_X, x);
5089 input_report_abs(input_dev, ABS_Y, y);
5090 input_event(data->input_dev, EV_KEY, BTN_TOUCH, 1);
5091@@ -166,7 +166,7 @@ retry:
5092 dev_dbg(&client->dev, "release id:%d\n", id);
5093 events[id].valid = 0;
5094 events[id].status = 0;
5095-#ifdef FORCE_SINGLE_POINTER_SUPPORT
5096+#ifdef CONFIG_TOUCHSCREEN_EGALAX_SINGLE_TOUCH
5097 input_report_key(input_dev, BTN_TOUCH, 0);
5098 input_report_abs(input_dev, ABS_PRESSURE, 0);
5099 #else
5100@@ -256,8 +256,9 @@ static int __devinit egalax_ts_probe(struct i2c_client *client,
5101 __set_bit(ABS_PRESSURE, input_dev->absbit);
5102 input_set_abs_params(input_dev, ABS_X, 0, 32767, 0, 0);
5103 input_set_abs_params(input_dev, ABS_Y, 0, 32767, 0, 0);
5104+ input_set_abs_params(input_dev, ABS_PRESSURE, 0, 1, 0, 0);
5105
5106-#ifndef FORCE_SINGLE_POINTER_SUPPORT
5107+#ifndef CONFIG_TOUCHSCREEN_EGALAX_SINGLE_TOUCH
5108 input_set_abs_params(input_dev, ABS_MT_POSITION_X, 0, 32767, 0, 0);
5109 input_set_abs_params(input_dev, ABS_MT_POSITION_Y, 0, 32767, 0, 0);
5110 input_set_abs_params(input_dev, ABS_MT_TOUCH_MAJOR, 0, 255, 0, 0);
5111diff --git a/drivers/input/touchscreen/ft5x06_ts.c b/drivers/input/touchscreen/ft5x06_ts.c 5061diff --git a/drivers/input/touchscreen/ft5x06_ts.c b/drivers/input/touchscreen/ft5x06_ts.c
5112new file mode 100644 5062new file mode 100644
5113index 0000000..89b5726 5063index 0000000..89b5726
diff --git a/recipes-kernel/linux/linux-imx_3.0.35.bb b/recipes-kernel/linux/linux-imx_3.0.35.bb
index 9c4b0be..149366b 100644
--- a/recipes-kernel/linux/linux-imx_3.0.35.bb
+++ b/recipes-kernel/linux/linux-imx_3.0.35.bb
@@ -3,7 +3,7 @@
3 3
4include linux-imx.inc 4include linux-imx.inc
5 5
6PR = "${INC_PR}.8" 6PR = "${INC_PR}.9"
7 7
8COMPATIBLE_MACHINE = "(mx6)" 8COMPATIBLE_MACHINE = "(mx6)"
9 9