summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2014-09-03 10:49:40 -0700
committerOtavio Salvador <otavio@ossystems.com.br>2014-09-15 11:16:53 -0300
commit8e3ae73f28540dac18d855728f7ae46d729885a6 (patch)
tree315451aeba9a7f2a8187741f650f76d99b440e33
parent6b6960132a7181a99931b7c4bb754e3f2d977e03 (diff)
downloadmeta-fsl-arm-8e3ae73f28540dac18d855728f7ae46d729885a6.tar.gz
imx-{lib,vpu}: obey CFLAGS, LDFLAGS
This quiets GNU_HASH warnings when building with an external toolchain. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/imx-lib/imx-lib-11.09.02/obey-variables.patch209
-rw-r--r--recipes-bsp/imx-lib/imx-lib-3.10.17-1.0.0/obey-variables.patch209
-rw-r--r--recipes-bsp/imx-lib/imx-lib_11.09.02.bb3
-rw-r--r--recipes-bsp/imx-lib/imx-lib_3.10.17-1.0.0.bb1
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch27
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu-3.10.17-1.0.0/obey-variables.patch27
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb1
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu_3.10.17-1.0.0.bb5
8 files changed, 480 insertions, 2 deletions
diff --git a/recipes-bsp/imx-lib/imx-lib-11.09.02/obey-variables.patch b/recipes-bsp/imx-lib/imx-lib-11.09.02/obey-variables.patch
new file mode 100644
index 0000000..901345a
--- /dev/null
+++ b/recipes-bsp/imx-lib/imx-lib-11.09.02/obey-variables.patch
@@ -0,0 +1,209 @@
1Obey CFLAGS, LDFLAGS
2
3Signed-off-by: Christopher Larson <chris_larson@mentor.com>
4Upstream-status: Pending
5
6--- imx-lib-11.09.02.orig/hdmi-cec/Makefile 2014-09-02 13:04:37.114250749 -0700
7+++ imx-lib-11.09.02/hdmi-cec/Makefile 2014-09-02 13:04:37.086250568 -0700
8@@ -1,5 +1,6 @@
9 CC ?=$(CROSS_COMPILE)gcc
10 AR ?=$(CROSS_COMPILE)ar
11+CFLAGS ?=-O2
12
13 # list of platforms which want this test case
14 INCLUDE_LIST:= IMX6Q
15@@ -32,10 +33,10 @@
16 endif
17
18 %.o: %.c
19- $(CC) -D$(PLATFORM) -Wall -O2 -fPIC -c $^ -o $@
20+ $(CC) -D$(PLATFORM) -Wall -fPIC $(CFLAGS) -c $^ -o $@
21
22 $(LIBNAME).so.$(SONAMEVERSION): $(OBJ)
23- $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@
24+ $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ $(LDFLAGS)
25
26 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
27 ln -s $< $@
28--- imx-lib-11.09.02.orig/ipu/Makefile 2014-09-02 13:04:37.114250749 -0700
29+++ imx-lib-11.09.02/ipu/Makefile 2014-09-02 13:05:11.062458117 -0700
30@@ -1,5 +1,6 @@
31 CC ?=$(CROSS_COMPILE)gcc
32 AR ?=$(CROSS_COMPILE)ar
33+CFLAGS ?=-O2
34
35 ifeq ($(PLATFORM), IMX6Q)
36 OBJS = mxc_ipu_hl_lib_dummy.o
37@@ -28,7 +29,7 @@
38 endif
39
40 $(LIBNAME).so.$(SONAMEVERSION): $(OBJS)
41- $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ -lpthread
42+ $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ -lpthread $(LDFLAGS)
43
44 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
45 ln -s $< $@
46@@ -37,7 +38,7 @@
47 ifeq "$(PLATFORM)" ""
48 $(error "Unspecified PLATFORM variable")
49 endif
50- $(CC) -D$(PLATFORM) $(INCLUDE) -Wall -O2 -fPIC -c $^ -o $@
51+ $(CC) -D$(PLATFORM) $(INCLUDE) -Wall -fPIC $(CFLAGS) -c $^ -o $@
52
53 .PHONY: clean
54 clean:
55--- imx-lib-11.09.02.orig/pxp/Makefile 2014-09-02 13:04:37.114250749 -0700
56+++ imx-lib-11.09.02/pxp/Makefile 2014-09-02 13:05:53.354716651 -0700
57@@ -1,5 +1,6 @@
58 CC ?=$(CROSS_COMPILE)gcc
59 AR ?=$(CROSS_COMPILE)ar
60+CFLAGS ?=-O2
61
62 # list of platforms which want this test case
63 INCLUDE_LIST:=IMX50 IMX51 IMX5 IMX6Q IMX6S
64@@ -25,10 +26,10 @@
65 endif
66
67 %.o: %.c
68- $(CC) -D$(PLATFORM) $(INCLUDE) -Wall -O2 -fPIC -c $^ -o $@
69+ $(CC) -D$(PLATFORM) $(INCLUDE) -Wall -fPIC $(CFLAGS) -c $^ -o $@
70
71 $(LIBNAME).so.$(SONAMEVERSION): $(OBJ)
72- $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@
73+ $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ $(LDFLAGS)
74
75 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
76 ln -s $< $@
77--- imx-lib-11.09.02.orig/rng/Makefile 2014-09-02 13:04:37.114250749 -0700
78+++ imx-lib-11.09.02/rng/Makefile 2014-09-02 13:04:37.086250568 -0700
79@@ -4,16 +4,17 @@
80 AR = ar -crv
81 RM = rm -f
82 CC ?=$(CROSS_COMPILE)gcc
83-LD=$(CROSS_COMPILE)ld
84+LD ?=$(CROSS_COMPILE)ld
85+CFLAGS ?=-g
86
87 INC := $(INCLUDE)
88
89 # Add compilation checks
90-CFLAGS += -g -Wall -W -Wmissing-prototypes -Wstrict-prototypes -Wdeclaration-after-statement -fPIC
91+override CFLAGS += -Wall -W -Wmissing-prototypes -Wstrict-prototypes -Wdeclaration-after-statement -fPIC
92
93 # In absence of kernel CONFIG flags, set API library to build on
94 # 'unknown' platform.
95-CFLAGS += -DFSL_PLATFORM_OTHER -DFSL_HAVE_RNGC $(INC)
96+override CFLAGS += -DFSL_PLATFORM_OTHER -DFSL_HAVE_RNGC $(INC)
97
98 OBJS= fsl_shw_rand.o fsl_shw_hash.o fsl_shw_sym.o fsl_shw_user.o \
99 fsl_shw_keystore.o fsl_shw_auth.o fsl_shw_hmac.o fsl_shw_wrap.o
100@@ -34,7 +35,7 @@
101 $(AR) $@ $^
102
103 $(LIBNAME).so.$(SONAMEVERSION): $(OBJS)
104- $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^
105+ $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ $(LDFLAGS)
106
107 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
108 ln -s $< $@
109--- imx-lib-11.09.02.orig/sahara2/Makefile 2014-09-02 13:04:37.114250749 -0700
110+++ imx-lib-11.09.02/sahara2/Makefile 2014-09-02 13:04:37.086250568 -0700
111@@ -4,7 +4,8 @@
112 AR = ar -crv
113 RM = rm -f
114 CC ?=$(CROSS_COMPILE)gcc
115-LD=$(CROSS_COMPILE)ld
116+LD ?=$(CROSS_COMPILE)ld
117+CFLAGS ?=-g
118
119 INC := $(INCLUDE)
120
121@@ -18,19 +19,19 @@
122 endif
123
124 # Add compilation checks
125-CFLAGS += -g -Wall -W -Wmissing-prototypes -Wstrict-prototypes -Wdeclaration-after-statement -fPIC
126+override CFLAGS += -Wall -W -Wmissing-prototypes -Wstrict-prototypes -Wdeclaration-after-statement -fPIC
127
128 OBJS= fsl_shw_rand.o fsl_shw_hash.o fsl_shw_sym.o fsl_shw_user.o \
129 fsl_shw_auth.o fsl_shw_hmac.o fsl_shw_wrap.o fsl_shw_keystore.o um_adaptor.o sf_util.o
130
131
132 #CFLAGS += -DSAHARA -DLINUX -I$(APIINCDIR)
133-CFLAGS += -DSAHARA -DLINUX $(INC)
134-CFLAGS += $(TARGET_ARCH)
135+override CFLAGS += -DSAHARA -DLINUX $(INC)
136+override CFLAGS += $(TARGET_ARCH)
137 # Uncomment to debug Library's creation of structures for driver
138-#CFLAGS += -DDIAG_SECURITY_FUNC
139+#override CFLAGS += -DDIAG_SECURITY_FUNC
140 # Uncomment to simulate memory allocation errors
141-#CFLAGS += -DDIAG_MEM_ERRORS -DDIAG_MEM_CONST=5
142+#override CFLAGS += -DDIAG_MEM_ERRORS -DDIAG_MEM_CONST=5
143
144 LIBNAME=libsahara
145 SONAMEVERSION=0
146@@ -53,7 +54,7 @@
147 $(AR) $@ $^
148
149 $(LIBNAME).so.$(SONAMEVERSION): $(OBJS)
150- $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^
151+ $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ $(LDFLAGS)
152
153 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
154 ln -s $< $@
155--- imx-lib-11.09.02.orig/screenlayer/Makefile 2014-09-02 13:04:37.114250749 -0700
156+++ imx-lib-11.09.02/screenlayer/Makefile 2014-09-02 13:04:37.086250568 -0700
157@@ -1,5 +1,6 @@
158 CC ?=$(CROSS_COMPILE)gcc
159 AR ?=$(CROSS_COMPILE)ar
160+CFLAGS ?=-O2
161 INC = $(INCLUDE) -I../ipu
162
163 OBJS = ScreenLayer.o
164@@ -24,13 +25,13 @@
165 endif
166
167 $(LIBNAME).so.$(SONAMEVERSION): $(OBJS)
168- $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ -L../ipu -lipu
169+ $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ -L../ipu -lipu $(LDFLAGS)
170
171 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
172 ln -s $< $@
173
174 %.o: %.c
175- $(CC) $(INC) -Wall -O2 -fPIC -c $^ -o $@
176+ $(CC) $(INC) -Wall -fPIC $(CFLAGS) -c $^ -o $@
177
178 .PHONY: clean
179 clean:
180--- imx-lib-11.09.02.orig/sim/Makefile 2014-09-02 13:04:37.114250749 -0700
181+++ imx-lib-11.09.02/sim/Makefile 2014-09-02 13:04:37.086250568 -0700
182@@ -1,9 +1,10 @@
183 CC ?=$(CROSS_COMPILE)gcc
184 AR ?=$(CROSS_COMPILE)ar
185+CFLAGS ?=-O2
186
187 OBJS = iso7816-3.o
188
189-CFLAGS += $(INCLUDE)
190+override CFLAGS += $(INCLUDE)
191
192 LIBNAME=libsim
193 SONAMEVERSION=0
194@@ -21,13 +22,13 @@
195 cp iso7816-3.h $(DEST_DIR)/usr/include
196
197 $(LIBNAME).so.$(SONAMEVERSION): $(OBJS)
198- $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ -lpthread
199+ $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ -lpthread $(LDFLAGS)
200
201 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
202 ln -s $< $@
203
204 %.o: %.c
205- $(CC) -D$(PLATFORM) $(INCLUDE) -Wall -O2 -fPIC -c $^ -o $@
206+ $(CC) -D$(PLATFORM) $(INCLUDE) -Wall -fPIC $(CFLAGS) -c $^ -o $@
207
208 else
209 all install :
diff --git a/recipes-bsp/imx-lib/imx-lib-3.10.17-1.0.0/obey-variables.patch b/recipes-bsp/imx-lib/imx-lib-3.10.17-1.0.0/obey-variables.patch
new file mode 100644
index 0000000..cc6319f
--- /dev/null
+++ b/recipes-bsp/imx-lib/imx-lib-3.10.17-1.0.0/obey-variables.patch
@@ -0,0 +1,209 @@
1Obey CFLAGS, LDFLAGS
2
3Signed-off-by: Christopher Larson <chris_larson@mentor.com>
4Upstream-status: Pending
5
6--- imx-lib-3.10.17-1.0.0_beta.orig/hdmi-cec/Makefile
7+++ imx-lib-3.10.17-1.0.0_beta/hdmi-cec/Makefile
8@@ -1,5 +1,6 @@
9 CC ?=$(CROSS_COMPILE)gcc
10 AR ?=$(CROSS_COMPILE)ar
11+CFLAGS ?=-O2
12
13 # list of platforms which want this test case
14 INCLUDE_LIST:= IMX6Q
15@@ -32,10 +33,10 @@ all install :
16 endif
17
18 %.o: %.c
19- $(CC) -D$(PLATFORM) -Wall -O2 -fPIC -c $^ -o $@
20+ $(CC) -D$(PLATFORM) -Wall -fPIC $(CFLAGS) -c $^ -o $@
21
22 $(LIBNAME).so.$(SONAMEVERSION): $(OBJ)
23- $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@
24+ $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ $(LDFLAGS)
25
26 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
27 ln -s $< $@
28--- imx-lib-3.10.17-1.0.0_beta.orig/ipu/Makefile
29+++ imx-lib-3.10.17-1.0.0_beta/ipu/Makefile
30@@ -1,5 +1,6 @@
31 CC ?=$(CROSS_COMPILE)gcc
32 AR ?=$(CROSS_COMPILE)ar
33+CFLAGS ?=-O2
34
35 ifeq ($(PLATFORM), IMX6Q)
36 OBJS = mxc_ipu_hl_lib_dummy.o
37@@ -28,7 +29,7 @@ all install:
38 endif
39
40 $(LIBNAME).so.$(SONAMEVERSION): $(OBJS)
41- $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^
42+ $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ $(LDFLAGS)
43
44 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
45 ln -s $< $@
46@@ -37,7 +38,7 @@ $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVER
47 ifeq "$(PLATFORM)" ""
48 $(error "Unspecified PLATFORM variable")
49 endif
50- $(CC) -D$(PLATFORM) $(INCLUDE) -Wall -O2 -fPIC -c $^ -o $@
51+ $(CC) -D$(PLATFORM) $(INCLUDE) -Wall -fPIC $(CFLAGS) -c $^ -o $@
52
53 .PHONY: clean
54 clean:
55--- imx-lib-3.10.17-1.0.0_beta.orig/pxp/Makefile
56+++ imx-lib-3.10.17-1.0.0_beta/pxp/Makefile
57@@ -1,5 +1,6 @@
58 CC ?=$(CROSS_COMPILE)gcc
59 AR ?=$(CROSS_COMPILE)ar
60+CFLAGS ?=-O2
61
62 # list of platforms which want this test case
63 INCLUDE_LIST:=IMX50 IMX51 IMX5 IMX6Q IMX6S
64@@ -26,10 +27,10 @@ all install :
65 endif
66
67 %.o: %.c
68- $(CC) -D$(PLATFORM) $(INCLUDE) -Wall -O2 -fPIC -c $^ -o $@
69+ $(CC) -D$(PLATFORM) $(INCLUDE) -Wall -fPIC $(CFLAGS) -c $^ -o $@
70
71 $(LIBNAME).so.$(SONAMEVERSION): $(OBJ)
72- $(CC) -shared -nostartfiles -Wl,-soname,$@ $(LFLAGS) $^ -o $@
73+ $(CC) -shared -nostartfiles -Wl,-soname,$@ $(LFLAGS) $^ -o $@ $(LDFLAGS)
74
75 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
76 ln -s $< $@
77--- imx-lib-3.10.17-1.0.0_beta.orig/rng/Makefile
78+++ imx-lib-3.10.17-1.0.0_beta/rng/Makefile
79@@ -4,16 +4,17 @@ ifeq (,$(findstring $(PLATFORM), $(EXCLU
80 AR = ar -crv
81 RM = rm -f
82 CC ?=$(CROSS_COMPILE)gcc
83-LD=$(CROSS_COMPILE)ld
84+LD ?=$(CROSS_COMPILE)ld
85+CFLAGS ?=-g
86
87 INC := $(INCLUDE)
88
89 # Add compilation checks
90-CFLAGS += -g -Wall -W -Wmissing-prototypes -Wstrict-prototypes -Wdeclaration-after-statement -fPIC
91+override CFLAGS += -Wall -W -Wmissing-prototypes -Wstrict-prototypes -Wdeclaration-after-statement -fPIC
92
93 # In absence of kernel CONFIG flags, set API library to build on
94 # 'unknown' platform.
95-CFLAGS += -DFSL_PLATFORM_OTHER -DFSL_HAVE_RNGC $(INC)
96+override CFLAGS += -DFSL_PLATFORM_OTHER -DFSL_HAVE_RNGC $(INC)
97
98 OBJS= fsl_shw_rand.o fsl_shw_hash.o fsl_shw_sym.o fsl_shw_user.o \
99 fsl_shw_keystore.o fsl_shw_auth.o fsl_shw_hmac.o fsl_shw_wrap.o
100@@ -34,7 +35,7 @@ $(LIBNAME).a: $(OBJS)
101 $(AR) $@ $^
102
103 $(LIBNAME).so.$(SONAMEVERSION): $(OBJS)
104- $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^
105+ $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ $(LDFLAGS)
106
107 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
108 ln -s $< $@
109--- imx-lib-3.10.17-1.0.0_beta.orig/sahara2/Makefile
110+++ imx-lib-3.10.17-1.0.0_beta/sahara2/Makefile
111@@ -4,7 +4,8 @@ ifeq (,$(findstring $(PLATFORM), $(EXCLU
112 AR = ar -crv
113 RM = rm -f
114 CC ?=$(CROSS_COMPILE)gcc
115-LD=$(CROSS_COMPILE)ld
116+LD ?=$(CROSS_COMPILE)ld
117+CFLAGS ?=-g
118
119 INC := $(INCLUDE)
120
121@@ -18,19 +19,19 @@ TARGET_ARCH=-DCONFIG_ARCH_MX5
122 endif
123
124 # Add compilation checks
125-CFLAGS += -g -Wall -W -Wmissing-prototypes -Wstrict-prototypes -Wdeclaration-after-statement -fPIC
126+override CFLAGS += -Wall -W -Wmissing-prototypes -Wstrict-prototypes -Wdeclaration-after-statement -fPIC
127
128 OBJS= fsl_shw_rand.o fsl_shw_hash.o fsl_shw_sym.o fsl_shw_user.o \
129 fsl_shw_auth.o fsl_shw_hmac.o fsl_shw_wrap.o fsl_shw_keystore.o um_adaptor.o sf_util.o
130
131
132 #CFLAGS += -DSAHARA -DLINUX -I$(APIINCDIR)
133-CFLAGS += -DSAHARA -DLINUX $(INC)
134-CFLAGS += $(TARGET_ARCH)
135+override CFLAGS += -DSAHARA -DLINUX $(INC)
136+override CFLAGS += $(TARGET_ARCH)
137 # Uncomment to debug Library's creation of structures for driver
138-#CFLAGS += -DDIAG_SECURITY_FUNC
139+#override CFLAGS += -DDIAG_SECURITY_FUNC
140 # Uncomment to simulate memory allocation errors
141-#CFLAGS += -DDIAG_MEM_ERRORS -DDIAG_MEM_CONST=5
142+#override CFLAGS += -DDIAG_MEM_ERRORS -DDIAG_MEM_CONST=5
143
144 LIBNAME=libsahara
145 SONAMEVERSION=0
146@@ -53,7 +54,7 @@ $(LIBNAME).a: $(OBJS)
147 $(AR) $@ $^
148
149 $(LIBNAME).so.$(SONAMEVERSION): $(OBJS)
150- $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^
151+ $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ $(LDFLAGS)
152
153 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
154 ln -s $< $@
155--- imx-lib-3.10.17-1.0.0_beta.orig/screenlayer/Makefile
156+++ imx-lib-3.10.17-1.0.0_beta/screenlayer/Makefile
157@@ -1,5 +1,6 @@
158 CC ?=$(CROSS_COMPILE)gcc
159 AR ?=$(CROSS_COMPILE)ar
160+CFLAGS ?=-O2
161 INC = $(INCLUDE) -I../ipu
162
163 OBJS = ScreenLayer.o
164@@ -24,13 +25,13 @@ all install:
165 endif
166
167 $(LIBNAME).so.$(SONAMEVERSION): $(OBJS)
168- $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ -L../ipu -lipu
169+ $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ -L../ipu -lipu $(LDFLAGS)
170
171 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
172 ln -s $< $@
173
174 %.o: %.c
175- $(CC) $(INC) -Wall -O2 -fPIC -c $^ -o $@
176+ $(CC) $(INC) -Wall -fPIC $(CFLAGS) -c $^ -o $@
177
178 .PHONY: clean
179 clean:
180--- imx-lib-3.10.17-1.0.0_beta.orig/sim/Makefile
181+++ imx-lib-3.10.17-1.0.0_beta/sim/Makefile
182@@ -1,9 +1,10 @@
183 CC ?=$(CROSS_COMPILE)gcc
184 AR ?=$(CROSS_COMPILE)ar
185+CFLAGS ?=-O2
186
187 OBJS = iso7816-3.o
188
189-CFLAGS += $(INCLUDE)
190+override CFLAGS += $(INCLUDE)
191
192 LIBNAME=libsim
193 SONAMEVERSION=0
194@@ -21,13 +22,13 @@ install:
195 cp iso7816-3.h $(DEST_DIR)/usr/include
196
197 $(LIBNAME).so.$(SONAMEVERSION): $(OBJS)
198- $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ -lpthread
199+ $(CC) -shared -nostartfiles -Wl,-soname,$@ -o $@ $^ -lpthread $(LDFLAGS)
200
201 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
202 ln -s $< $@
203
204 %.o: %.c
205- $(CC) -D$(PLATFORM) $(INCLUDE) -Wall -O2 -fPIC -c $^ -o $@
206+ $(CC) -D$(PLATFORM) $(INCLUDE) -Wall -fPIC $(CFLAGS) -c $^ -o $@
207
208 else
209 all install :
diff --git a/recipes-bsp/imx-lib/imx-lib_11.09.02.bb b/recipes-bsp/imx-lib/imx-lib_11.09.02.bb
index 07c6e35..16ca1df 100644
--- a/recipes-bsp/imx-lib/imx-lib_11.09.02.bb
+++ b/recipes-bsp/imx-lib/imx-lib_11.09.02.bb
@@ -1,7 +1,8 @@
1# Copyright (C) 2013 Freescale Semiconductor 1# Copyright (C) 2013 Freescale Semiconductor
2require imx-lib.inc 2require imx-lib.inc
3 3
4SRC_URI = "${FSL_MIRROR}/imx-lib-${PV}.tar.gz" 4SRC_URI = "${FSL_MIRROR}/imx-lib-${PV}.tar.gz \
5 file://obey-variables.patch"
5SRC_URI[md5sum] = "a4e7447e35cfac0b966a51f001390d6e" 6SRC_URI[md5sum] = "a4e7447e35cfac0b966a51f001390d6e"
6SRC_URI[sha256sum] = "3ed082005789db0c9c41e14073417319f4e23f5646a7d21f34840470f4328bd5" 7SRC_URI[sha256sum] = "3ed082005789db0c9c41e14073417319f4e23f5646a7d21f34840470f4328bd5"
7 8
diff --git a/recipes-bsp/imx-lib/imx-lib_3.10.17-1.0.0.bb b/recipes-bsp/imx-lib/imx-lib_3.10.17-1.0.0.bb
index 93f5482..212ec3f 100644
--- a/recipes-bsp/imx-lib/imx-lib_3.10.17-1.0.0.bb
+++ b/recipes-bsp/imx-lib/imx-lib_3.10.17-1.0.0.bb
@@ -4,6 +4,7 @@ include imx-lib.inc
4 4
5PE = "1" 5PE = "1"
6 6
7SRC_URI += "file://obey-variables.patch"
7SRC_URI[md5sum] = "8e3346d5f33b5aa5f915a0dd8aa99cc9" 8SRC_URI[md5sum] = "8e3346d5f33b5aa5f915a0dd8aa99cc9"
8SRC_URI[sha256sum] = "f42605971977e5fe1ed9e7ce17ea3f97586a23fbc60fa0f679940d379c72303e" 9SRC_URI[sha256sum] = "f42605971977e5fe1ed9e7ce17ea3f97586a23fbc60fa0f679940d379c72303e"
9 10
diff --git a/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch b/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch
new file mode 100644
index 0000000..13f61b2
--- /dev/null
+++ b/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch
@@ -0,0 +1,27 @@
1Obey CFLAGS, LDFLAGS
2
3Signed-off-by: Christopher Larson <chris_larson@mentor.com>
4Upstream-status: Pending
5
6--- imx-vpu-11.09.02.orig/vpu/Makefile 2014-09-02 13:14:50.862005896 -0700
7+++ imx-vpu-11.09.02/vpu/Makefile 2014-09-02 13:15:15.018153222 -0700
8@@ -1,5 +1,6 @@
9 CC ?=$(CROSS_COMPILE)gcc
10 AR ?=$(CROSS_COMPILE)ar
11+CFLAGS ?= -O2
12
13 # list of platforms which want this test case
14 INCLUDE_LIST:= IMX27ADS IMX51 IMX53 IMX6Q
15@@ -33,10 +34,10 @@
16 endif
17
18 %.o: %.c
19- $(CC) -D$(PLATFORM) -Wall -O2 -fPIC -c $^ -o $@
20+ $(CC) -D$(PLATFORM) -Wall -fPIC $(CFLAGS) -c $^ -o $@
21
22 $(LIBNAME).so.$(SONAMEVERSION): $(OBJ)
23- $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@
24+ $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ $(LDFLAGS)
25
26 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
27 ln -s $< $@
diff --git a/recipes-bsp/imx-vpu/imx-vpu-3.10.17-1.0.0/obey-variables.patch b/recipes-bsp/imx-vpu/imx-vpu-3.10.17-1.0.0/obey-variables.patch
new file mode 100644
index 0000000..7071e9e
--- /dev/null
+++ b/recipes-bsp/imx-vpu/imx-vpu-3.10.17-1.0.0/obey-variables.patch
@@ -0,0 +1,27 @@
1Obey CFLAGS, LDFLAGS
2
3Signed-off-by: Christopher Larson <chris_larson@mentor.com>
4Upstream-status: Pending
5
6--- imx-vpu-3.10.17-1.0.0_beta.orig/vpu/Makefile
7+++ imx-vpu-3.10.17-1.0.0_beta/vpu/Makefile
8@@ -1,5 +1,6 @@
9 CC ?=$(CROSS_COMPILE)gcc
10 AR ?=$(CROSS_COMPILE)ar
11+CFLAGS ?= -O2
12
13 # list of platforms which want this test case
14 INCLUDE_LIST:= IMX27ADS IMX51 IMX53 IMX6Q
15@@ -33,10 +34,10 @@ all install :
16 endif
17
18 %.o: %.c
19- $(CC) -D$(PLATFORM) -Wall -O2 -fPIC -c $^ -o $@
20+ $(CC) -D$(PLATFORM) -Wall -fPIC $(CFLAGS) -c $^ -o $@
21
22 $(LIBNAME).so.$(SONAMEVERSION): $(OBJ)
23- $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ -lpthread
24+ $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ $(LDFLAGS) -lpthread
25
26 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
27 ln -s $< $@
diff --git a/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb b/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb
index c40c703..c5dd9bd 100644
--- a/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb
+++ b/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb
@@ -1,6 +1,7 @@
1# Copyright (C) 2013 Freescale Semiconductor 1# Copyright (C) 2013 Freescale Semiconductor
2require imx-vpu.inc 2require imx-vpu.inc
3 3
4SRC_URI += "file://obey-variables.patch"
4SRC_URI[md5sum] = "1988a08687a09ef8590e66ff17ac6ed3" 5SRC_URI[md5sum] = "1988a08687a09ef8590e66ff17ac6ed3"
5SRC_URI[sha256sum] = "783f136aa9b9257d4bffbdaf05bdcb85d177c544c3f8a4674421ba7b065ed5c0" 6SRC_URI[sha256sum] = "783f136aa9b9257d4bffbdaf05bdcb85d177c544c3f8a4674421ba7b065ed5c0"
6 7
diff --git a/recipes-bsp/imx-vpu/imx-vpu_3.10.17-1.0.0.bb b/recipes-bsp/imx-vpu/imx-vpu_3.10.17-1.0.0.bb
index 7ed9590..6ef79e5 100644
--- a/recipes-bsp/imx-vpu/imx-vpu_3.10.17-1.0.0.bb
+++ b/recipes-bsp/imx-vpu/imx-vpu_3.10.17-1.0.0.bb
@@ -4,9 +4,12 @@ require imx-vpu.inc
4 4
5PE = "1" 5PE = "1"
6 6
7SRC_URI += "\
8 file://0001-IOGetVirtMem-returns-1-MAP_FAILED-on-failure.patch \
9 file://obey-variables.patch \
10"
7SRC_URI[md5sum] = "71ea1b803864101ebf88a1bab45514d2" 11SRC_URI[md5sum] = "71ea1b803864101ebf88a1bab45514d2"
8SRC_URI[sha256sum] = "cd8a7bd50ff3274db76a331cc6622d3ba4bb7c790ce778f303e49187df2dfd72" 12SRC_URI[sha256sum] = "cd8a7bd50ff3274db76a331cc6622d3ba4bb7c790ce778f303e49187df2dfd72"
9 13
10SRC_URI_append = " file://0001-IOGetVirtMem-returns-1-MAP_FAILED-on-failure.patch"
11 14
12COMPATIBLE_MACHINE = "(mx6)" 15COMPATIBLE_MACHINE = "(mx6)"