summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Zidan <b50113@freescale.com>2014-08-08 09:54:19 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2014-08-22 10:19:14 -0300
commit4ffc6ac2dc2f3390a95d125403b249f674d13c9d (patch)
tree7b04c91f391822da4561c4fc3f06aefcb89b940d
parentdf38c6233e631efd30de0547cb2795cd373c4326 (diff)
downloadmeta-fsl-arm-4ffc6ac2dc2f3390a95d125403b249f674d13c9d.tar.gz
alsa-lib: add conf for multichannel support in mx6
Signed-off-by: Wang Zidan <b50113@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch221
-rw-r--r--recipes-multimedia/alsa/alsa-lib_%.bbappend7
2 files changed, 228 insertions, 0 deletions
diff --git a/recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch b/recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch
new file mode 100644
index 0000000..32b3195
--- /dev/null
+++ b/recipes-multimedia/alsa/alsa-lib/0001-add-conf-for-multichannel-support-in-imx.patch
@@ -0,0 +1,221 @@
1From e99c36dfdce3e0f393eeaca6c2790b566f72d6a8 Mon Sep 17 00:00:00 2001
2From: Shengjiu Wang <b02247@freescale.com>
3Date: Thu, 5 Jun 2014 17:37:47 +0800
4Subject: [PATCH] add conf for multichannel support in imx
5
6Upstream Status: Inappropriate [platform specific]
7
8Signed-off-by: Shengjiu Wang <b02247@freescale.com>
9---
10 src/conf/cards/CS42888.conf | 94 ++++++++++++++++++++++++++++++++++++++++++++
11 src/conf/cards/IMX-HDMI.conf | 67 +++++++++++++++++++++++++++++++
12 src/conf/cards/Makefile.am | 4 +-
13 src/conf/cards/aliases.conf | 2 +
14 4 files changed, 166 insertions(+), 1 deletion(-)
15 create mode 100644 src/conf/cards/CS42888.conf
16 create mode 100644 src/conf/cards/IMX-HDMI.conf
17
18diff --git a/src/conf/cards/CS42888.conf b/src/conf/cards/CS42888.conf
19new file mode 100644
20index 0000000..671a284
21--- /dev/null
22+++ b/src/conf/cards/CS42888.conf
23@@ -0,0 +1,94 @@
24+#
25+# Configuration for the CS42888 chip
26+#
27+
28+# default with dmix & dsnoop
29+CS42888.pcm.default {
30+ @args [ CARD ]
31+ @args.CARD {
32+ type string
33+ }
34+ type asym
35+ playback.pcm {
36+ type plug
37+ slave.pcm {
38+ @func concat
39+ strings [ "dmix:" $CARD ",FORMAT=S32_LE" ]
40+ }
41+ }
42+ capture.pcm {
43+ type plug
44+ slave.pcm {
45+ @func concat
46+ strings [ "dsnoop:" $CARD ",FORMAT=S32_LE" ]
47+ }
48+ }
49+}
50+
51+<confdir:pcm/surround40.conf>
52+
53+CS42888.pcm.surround40.0 {
54+ @args [ CARD ]
55+ @args.CARD {
56+ type string
57+ }
58+ type plug
59+ slave.pcm {
60+ type hw
61+ card $CARD
62+ }
63+ slave.channels 4
64+ ttable.0.0 1
65+ ttable.1.2 1
66+ ttable.2.1 1
67+ ttable.3.3 1
68+}
69+
70+
71+<confdir:pcm/surround41.conf>
72+<confdir:pcm/surround50.conf>
73+<confdir:pcm/surround51.conf>
74+
75+CS42888.pcm.surround51.0 {
76+ @args [ CARD ]
77+ @args.CARD {
78+ type string
79+ }
80+ type plug
81+ slave.pcm {
82+ type hw
83+ card $CARD
84+ }
85+ slave.channels 6
86+ ttable.0.0 1
87+ ttable.1.3 1
88+ ttable.2.1 1
89+ ttable.3.4 1
90+ ttable.4.2 1
91+ ttable.5.5 1
92+}
93+
94+<confdir:pcm/surround71.conf>
95+
96+CS42888.pcm.surround71.0 {
97+ @args [ CARD ]
98+ @args.CARD {
99+ type string
100+ }
101+ type plug
102+ slave.pcm {
103+ type hw
104+ card $CARD
105+ }
106+ slave.channels 8
107+ ttable.0.0 1
108+ ttable.1.4 1
109+ ttable.2.1 1
110+ ttable.3.5 1
111+ ttable.4.2 1
112+ ttable.5.6 1
113+ ttable.6.3 1
114+ ttable.7.7 1
115+}
116+
117+# vim: ft=alsaconf
118diff --git a/src/conf/cards/IMX-HDMI.conf b/src/conf/cards/IMX-HDMI.conf
119new file mode 100644
120index 0000000..a51509e
121--- /dev/null
122+++ b/src/conf/cards/IMX-HDMI.conf
123@@ -0,0 +1,67 @@
124+#
125+# Configuration for the CS42888 chip
126+#
127+
128+# default with dmix & dsnoop
129+IMX-HDMI.pcm.default {
130+ @args [ CARD ]
131+ @args.CARD {
132+ type string
133+ }
134+ type asym
135+ playback.pcm {
136+ type plug
137+ slave.pcm {
138+ @func concat
139+ strings [ "dmix:" $CARD ",FORMAT=S32_LE" ]
140+ }
141+ }
142+ capture.pcm {
143+ type plug
144+ slave.pcm {
145+ @func concat
146+ strings [ "dsnoop:" $CARD ",FORMAT=S32_LE" ]
147+ }
148+ }
149+}
150+
151+<confdir:pcm/surround40.conf>
152+
153+IMX-HDMI.pcm.surround40.0 {
154+ @args [ CARD ]
155+ @args.CARD {
156+ type string
157+ }
158+ type hw
159+ card $CARD
160+ channels 4
161+}
162+
163+
164+<confdir:pcm/surround41.conf>
165+<confdir:pcm/surround50.conf>
166+<confdir:pcm/surround51.conf>
167+
168+IMX-HDMI.pcm.surround51.0 {
169+ @args [ CARD ]
170+ @args.CARD {
171+ type string
172+ }
173+ type hw
174+ card $CARD
175+ channels 6
176+}
177+
178+<confdir:pcm/surround71.conf>
179+
180+IMX-HDMI.pcm.surround71.0 {
181+ @args [ CARD ]
182+ @args.CARD {
183+ type string
184+ }
185+ type hw
186+ card $CARD
187+ channels 8
188+}
189+
190+# vim: ft=alsaconf
191diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am
192index ee7991b..b08acae 100644
193--- a/src/conf/cards/Makefile.am
194+++ b/src/conf/cards/Makefile.am
195@@ -54,7 +54,9 @@ cfg_files = aliases.conf \
196 VIA8237.conf \
197 VX222.conf \
198 VXPocket.conf \
199- VXPocket440.conf
200+ VXPocket440.conf \
201+ CS42888.conf \
202+ IMX-HDMI.conf
203
204 if BUILD_ALISP
205 cfg_files += aliases.alisp
206diff --git a/src/conf/cards/aliases.conf b/src/conf/cards/aliases.conf
207index 4a92fb2..46430c2 100644
208--- a/src/conf/cards/aliases.conf
209+++ b/src/conf/cards/aliases.conf
210@@ -55,6 +55,8 @@ AV100 cards.CMI8788
211 AV200 cards.CMI8788
212 CMI8786 cards.CMI8788
213 CMI8787 cards.CMI8788
214+cs42888-audio cards.CS42888
215+imx-hdmi-soc cards.IMX-HDMI
216
217 <confdir:pcm/default.conf>
218 <confdir:pcm/dmix.conf>
219--
2201.8.0
221
diff --git a/recipes-multimedia/alsa/alsa-lib_%.bbappend b/recipes-multimedia/alsa/alsa-lib_%.bbappend
new file mode 100644
index 0000000..9d95e68
--- /dev/null
+++ b/recipes-multimedia/alsa/alsa-lib_%.bbappend
@@ -0,0 +1,7 @@
1
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4SRC_URI_append_mx6 = " file://0001-add-conf-for-multichannel-support-in-imx.patch \
5"
6PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}"
7