summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-09-02 15:54:45 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2014-10-02 20:21:42 -0300
commit4e694e727aa8babfd0ba06c5e98bab3753b39a8b (patch)
treec7bf107480e71cd6e4bca072279869b05fe1a2c3
parent5dbda0c03427c05e1da1ac4399a4dc26488102ec (diff)
downloadmeta-fsl-arm-4e694e727aa8babfd0ba06c5e98bab3753b39a8b.tar.gz
linux-mfgtool.inc: Fix dynamic packages handling
In case we have kernel modules, a runtime dependency or recommendation can break the dependency resolution algorithm of BitBake resulting on a conflict like: ,----[ Provider conflict error ] | ERROR: Trying to resolve runtime dependency kernel-module-nfs resulted | in conflicting PREFERRED_PROVIDER entries being found. | The providers found were: | ['.../meta-customer/recipes-kernel/linux/linux-customer-mfgtool_3.10.17.bb', | '.../meta-customer/recipes-kernel/linux/linux-customer_3.10.17.bb'] | The PREFERRED_PROVIDER entries resulting in this conflict were: | ['PREFERRED_PROVIDER_linux-mfgtool = mfgtool-linux-customer', | 'PREFERRED_PROVIDER_virtual/kernel = linux-customer'] `---- To fix this, we need to rename the dynamic packages and hence change the built binaries, solving the conflict. Change-Id: I8becb8a4a839494720711f60f51515aba0140c68 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-kernel/linux/linux-mfgtool.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-mfgtool.inc b/recipes-kernel/linux/linux-mfgtool.inc
index 5c042ee..106a7d9 100644
--- a/recipes-kernel/linux/linux-mfgtool.inc
+++ b/recipes-kernel/linux/linux-mfgtool.inc
@@ -59,6 +59,7 @@ python () {
59 clsextend.rename_package_variables((d.getVar("PACKAGEVARS", True) or "").split()) 59 clsextend.rename_package_variables((d.getVar("PACKAGEVARS", True) or "").split())
60 60
61 clsextend.map_packagevars() 61 clsextend.map_packagevars()
62 clsextend.map_regexp_variable("PACKAGES_DYNAMIC")
62} 63}
63 64
64addhandler mfgtool_recipe_handler 65addhandler mfgtool_recipe_handler