summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-10-08 03:00:45 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2012-10-19 15:38:40 -0300
commit3d3e77f3c3e76ca5b43afbcbbe8d98c4365e03ab (patch)
tree239023a8da35aaecc73bcdd3c0008ea2244a9aeb
parent8231eb4adf1296b1b9632c6f3562abc11f857fdc (diff)
downloadmeta-fsl-arm-3d3e77f3c3e76ca5b43afbcbbe8d98c4365e03ab.tar.gz
linux-libc-headers-imx (2.6.35.3): Update version to use for headers
This updates the recipe to use a more recent version for headers and drop merged patch. Change-Id: I6a67fabdcaf6ec11c5c7cc038b61be842962df64 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-kernel/linux-libc-headers/linux-libc-headers-imx-2.6.35.3/wire-up-sys_accept4-on-ARM.patch53
-rw-r--r--recipes-kernel/linux-libc-headers/linux-libc-headers-imx_2.6.35.3.bb7
2 files changed, 4 insertions, 56 deletions
diff --git a/recipes-kernel/linux-libc-headers/linux-libc-headers-imx-2.6.35.3/wire-up-sys_accept4-on-ARM.patch b/recipes-kernel/linux-libc-headers/linux-libc-headers-imx-2.6.35.3/wire-up-sys_accept4-on-ARM.patch
deleted file mode 100644
index 7182e80..0000000
--- a/recipes-kernel/linux-libc-headers/linux-libc-headers-imx-2.6.35.3/wire-up-sys_accept4-on-ARM.patch
+++ /dev/null
@@ -1,53 +0,0 @@
1From 1415ec63689ef39bcb24b5095941ec4cc884035c Mon Sep 17 00:00:00 2001
2From: Mikael Pettersson <mikpe@it.uu.se>
3Date: Sun, 15 Aug 2010 10:47:23 +0100
4Subject: [PATCH 1/2] ARM: 6329/1: wire up sys_accept4() on ARM
5
6sys_accept4() was added in kernel 2.6.28, but ARM was not updated
7to include it. The number and types of parameters is such that
8no ARM-specific processing is needed, so wiring up sys_accept4()
9just requires defining __NR_accept4 and adding a direct call in
10the syscall entry table.
11
12Tested with an EABI 2.6.35 kernel and Ulrich Drepper's original
13accept4() test program, modified to define __NR_accept4 for ARM.
14
15Using the updated unistd.h also eliminates a warning then building
16glibc (2.10.2 and newer) about accept4() being unimplemented.
17
18Upstream-Status: Backport [2.6.36]
19
20Signed-off-by: Mikael Pettersson <mikpe@it.uu.se>
21Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
22---
23 arch/arm/include/asm/unistd.h | 1 +
24 arch/arm/kernel/calls.S | 1 +
25 2 files changed, 2 insertions(+), 0 deletions(-)
26
27diff --git a/arch/arm/include/asm/unistd.h b/arch/arm/include/asm/unistd.h
28index dd2bf53..d02cfb6 100644
29--- a/arch/arm/include/asm/unistd.h
30+++ b/arch/arm/include/asm/unistd.h
31@@ -392,6 +392,7 @@
32 #define __NR_rt_tgsigqueueinfo (__NR_SYSCALL_BASE+363)
33 #define __NR_perf_event_open (__NR_SYSCALL_BASE+364)
34 #define __NR_recvmmsg (__NR_SYSCALL_BASE+365)
35+#define __NR_accept4 (__NR_SYSCALL_BASE+366)
36
37 /*
38 * The following SWIs are ARM private.
39diff --git a/arch/arm/kernel/calls.S b/arch/arm/kernel/calls.S
40index 37ae301..afeb71f 100644
41--- a/arch/arm/kernel/calls.S
42+++ b/arch/arm/kernel/calls.S
43@@ -375,6 +375,7 @@
44 CALL(sys_rt_tgsigqueueinfo)
45 CALL(sys_perf_event_open)
46 /* 365 */ CALL(sys_recvmmsg)
47+ CALL(sys_accept4)
48 #ifndef syscalls_counted
49 .equ syscalls_padding, ((NR_syscalls + 3) & ~3) - NR_syscalls
50 #define syscalls_counted
51--
521.6.6.1
53
diff --git a/recipes-kernel/linux-libc-headers/linux-libc-headers-imx_2.6.35.3.bb b/recipes-kernel/linux-libc-headers/linux-libc-headers-imx_2.6.35.3.bb
index f2274e3..154c4c3 100644
--- a/recipes-kernel/linux-libc-headers/linux-libc-headers-imx_2.6.35.3.bb
+++ b/recipes-kernel/linux-libc-headers/linux-libc-headers-imx_2.6.35.3.bb
@@ -4,8 +4,9 @@ PROVIDES = "linux-libc-headers"
4RPROVIDES_${PN}-dev = "linux-libc-headers-dev" 4RPROVIDES_${PN}-dev = "linux-libc-headers-dev"
5RPROVIDES_${PN}-dbg = "linux-libc-headers-dbg" 5RPROVIDES_${PN}-dbg = "linux-libc-headers-dbg"
6 6
7SRC_URI = "git://git.freescale.com/imx/linux-2.6-imx.git;tag=rel_imx_2.6.35_11.09.01 \ 7SRCREV = "012a4b8a404f5c89c31e2d428d5e4c9eb3a70ec7"
8 file://wire-up-sys_accept4-on-ARM.patch" 8SRC_URI = "git://git.freescale.com/imx/linux-2.6-imx.git"
9
9S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
10 11
11PR = "r3" 12PR = "r4"