summaryrefslogtreecommitdiffstats
path: root/recipes-support/opencv/opencv_4.5.2.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/opencv/opencv_4.5.2.imx.bb')
-rw-r--r--recipes-support/opencv/opencv_4.5.2.imx.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/recipes-support/opencv/opencv_4.5.2.imx.bb b/recipes-support/opencv/opencv_4.5.2.imx.bb
index 8e76783a..79b87bef 100644
--- a/recipes-support/opencv/opencv_4.5.2.imx.bb
+++ b/recipes-support/opencv/opencv_4.5.2.imx.bb
@@ -58,6 +58,7 @@ SRC_URI = "git://github.com/opencv/opencv.git;name=opencv \
58 file://download.patch \ 58 file://download.patch \
59 file://0001-Make-ts-module-external.patch \ 59 file://0001-Make-ts-module-external.patch \
60 file://0001-sfm-link-with-Glog_LIBS.patch;patchdir=../contrib \ 60 file://0001-sfm-link-with-Glog_LIBS.patch;patchdir=../contrib \
61 file://0001-Use-the-one-argument-version-of-SetTotalBytesLimit.patch \
61 " 62 "
62SRC_URI:append:riscv64 = " file://0001-Use-Os-to-compile-tinyxml2.cpp.patch;patchdir=../contrib" 63SRC_URI:append:riscv64 = " file://0001-Use-Os-to-compile-tinyxml2.cpp.patch;patchdir=../contrib"
63 64
@@ -112,6 +113,12 @@ PACKAGECONFIG ??= "gapi python3 eigen jpeg png tiff v4l libv4l gstreamer samples
112 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk", "", d)} \ 113 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk", "", d)} \
113 ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "libav", "", d)}" 114 ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "libav", "", d)}"
114 115
116# TBB does not build for powerpc so disable that package config
117PACKAGECONFIG:remove:powerpc = "tbb"
118# tbb now needs getcontect/setcontext which is not there for all arches on musl
119PACKAGECONFIG:remove:libc-musl:riscv64 = "tbb"
120PACKAGECONFIG:remove:libc-musl:riscv32 = "tbb"
121
115PACKAGECONFIG[gapi] = "-DWITH_ADE=ON -Dade_DIR=${STAGING_LIBDIR},-DWITH_ADE=OFF,ade" 122PACKAGECONFIG[gapi] = "-DWITH_ADE=ON -Dade_DIR=${STAGING_LIBDIR},-DWITH_ADE=OFF,ade"
116PACKAGECONFIG[amdblas] = "-DWITH_OPENCLAMDBLAS=ON,-DWITH_OPENCLAMDBLAS=OFF,libclamdblas," 123PACKAGECONFIG[amdblas] = "-DWITH_OPENCLAMDBLAS=ON,-DWITH_OPENCLAMDBLAS=OFF,libclamdblas,"
117PACKAGECONFIG[amdfft] = "-DWITH_OPENCLAMDFFT=ON,-DWITH_OPENCLAMDFFT=OFF,libclamdfft," 124PACKAGECONFIG[amdfft] = "-DWITH_OPENCLAMDFFT=ON,-DWITH_OPENCLAMDFFT=OFF,libclamdfft,"
@@ -229,10 +236,12 @@ do_install:append() {
229 sed -e 's@${STAGING_DIR_HOST}@@g' \ 236 sed -e 's@${STAGING_DIR_HOST}@@g' \
230 -i ${D}${libdir}/cmake/opencv4/OpenCVModules.cmake 237 -i ${D}${libdir}/cmake/opencv4/OpenCVModules.cmake
231 fi 238 fi
239 # remove setup_vars_opencv4.sh as its content is confusing and useless
240 if [ -f ${D}${bindir}/setup_vars_opencv4.sh ]; then
241 rm -rf ${D}${bindir}/setup_vars_opencv4.sh
242 fi
232} 243}
233 244
234TOOLCHAIN = "gcc"
235
236########## End of meta-openembedded copy ########## 245########## End of meta-openembedded copy ##########
237 246
238########## i.MX overrides ########## 247########## i.MX overrides ##########