summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch34
-rw-r--r--recipes-security/optee-imx/optee-client_3.2.0.imx.bb4
2 files changed, 37 insertions, 1 deletions
diff --git a/recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch b/recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch
new file mode 100644
index 00000000..3bbf898b
--- /dev/null
+++ b/recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch
@@ -0,0 +1,34 @@
1From ea7e0fba6da734e5f99f84d10d456ceaaed05883 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.z@gmail.com>
3Date: Sun, 31 May 2020 20:40:25 +0000
4Subject: [PATCH] flags: do not override CFLAGS from host
5
6Some build systems set CFLAGS in environment before the build, but they
7got overridden by CFLAGS immediate assignment operator.
8
9Replace immediate assignment with append directive, so the former
10definition of CFLAGS gets properly expanded.
11
12Upstream-Status: Submitted [https://github.com/OP-TEE/optee_client/pull/211]
13
14Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
15---
16 flags.mk | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/flags.mk b/flags.mk
20index 71f3d18..af13495 100644
21--- a/flags.mk
22+++ b/flags.mk
23@@ -6,7 +6,7 @@ CROSS_COMPILE ?= arm-linux-gnueabihf-
24 CC ?= $(CROSS_COMPILE)gcc
25 AR ?= $(CROSS_COMPILE)ar
26
27-CFLAGS := -Wall -Wbad-function-cast -Wcast-align \
28+CFLAGS += -Wall -Wbad-function-cast -Wcast-align \
29 -Werror-implicit-function-declaration -Wextra \
30 -Wfloat-equal -Wformat-nonliteral -Wformat-security \
31 -Wformat=2 -Winit-self -Wmissing-declarations \
32--
332.17.1
34
diff --git a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
index d3607ed4..19770849 100644
--- a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
@@ -13,7 +13,9 @@ SRC_URI = "${OPTEE_CLIENT_SRC};branch=${SRCBRANCH}"
13 13
14SRCREV = "71a9bef78fff2d5d4db8a2307d3b91e2aa671dc9" 14SRCREV = "71a9bef78fff2d5d4db8a2307d3b91e2aa671dc9"
15 15
16SRC_URI_append = " file://tee-supplicant.service" 16SRC_URI += "file://tee-supplicant.service \
17 file://0001-flags-do-not-override-CFLAGS-from-host.patch \
18"
17 19
18S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
19SYSTEMD_SERVICE_${PN} = "tee-supplicant.service" 21SYSTEMD_SERVICE_${PN} = "tee-supplicant.service"