diff options
Diffstat (limited to 'recipes-security')
-rw-r--r-- | recipes-security/optee/optee-client.bb | 26 | ||||
-rw-r--r-- | recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch | 67 |
2 files changed, 93 insertions, 0 deletions
diff --git a/recipes-security/optee/optee-client.bb b/recipes-security/optee/optee-client.bb new file mode 100644 index 00000000..b811e600 --- /dev/null +++ b/recipes-security/optee/optee-client.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | SUMMARY = "OPTEE Client" | ||
2 | HOMEPAGE = "https://github.com/qoriq-open-source/optee_client" | ||
3 | |||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b" | ||
6 | |||
7 | inherit pythonnative systemd | ||
8 | |||
9 | SRC_URI = "git://github.com/qoriq-open-source/optee_client.git;nobranch=1 \ | ||
10 | file://0001-Respect-LDFLAGS-set-from-OE-build.patch \ | ||
11 | " | ||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | SRCREV = "73b4e490a8ed0b4a7714818e80998b9d8a7da958" | ||
15 | |||
16 | do_install() { | ||
17 | oe_runmake install | ||
18 | |||
19 | install -D -p -m0755 ${S}/out/export/bin/tee-supplicant ${D}${bindir}/tee-supplicant | ||
20 | |||
21 | install -D -p -m0644 ${S}/out/export/lib/libteec.so.1.0 ${D}${libdir}/libteec.so.1.0 | ||
22 | ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so | ||
23 | ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so.1 | ||
24 | |||
25 | cp -a ${S}/out/export/include ${D}/usr/ | ||
26 | } | ||
diff --git a/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch b/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch new file mode 100644 index 00000000..8dd6c7a9 --- /dev/null +++ b/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch | |||
@@ -0,0 +1,67 @@ | |||
1 | From 73cb675c16bd63ee0e760a4067ffda4b050d19fa Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Thu, 15 Jun 2017 17:20:35 -0700 | ||
4 | Subject: [PATCH] Respect LDFLAGS set from OE build | ||
5 | |||
6 | * Unify LFLAGS/LDFLAGS variable names (only tee-supplicant was using LDFLAGS). | ||
7 | * Fixes: | ||
8 | ERROR: optee-client-2.4.0+gitAUTOINC+1df4046bd7-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: 'optee-client/2.4.0+gitAUTOINC+1df4046bd7-r0/packages-split/optee-client/usr/bin/tee-supplicant' | ||
9 | No GNU_HASH in the elf binary: 'optee-client/2.4.0+gitAUTOINC+1df4046bd7-r0/packages-split/optee-client/usr/lib/libteec.so.1.0' [ldflags] | ||
10 | ERROR: optee-client-2.4.0+gitAUTOINC+1df4046bd7-r0 do_package_qa: QA run found fatal errors. Please consider fixing them. | ||
11 | ERROR: optee-client-2.4.0+gitAUTOINC+1df4046bd7-r0 do_package_qa: Function failed: do_package_qa | ||
12 | ERROR: Logfile of failure stored in: optee-client/2.4.0+gitAUTOINC+1df4046bd7-r0/temp/log.do_package_qa.31246 | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
16 | |||
17 | --- | ||
18 | libteec/Makefile | 2 +- | ||
19 | tee-supplicant/Makefile | 8 ++++---- | ||
20 | 2 files changed, 5 insertions(+), 5 deletions(-) | ||
21 | |||
22 | diff --git a/libteec/Makefile b/libteec/Makefile | ||
23 | index 568a2cd..a406237 100644 | ||
24 | --- a/libteec/Makefile | ||
25 | +++ b/libteec/Makefile | ||
26 | @@ -36,7 +36,7 @@ ifeq ($(CFG_TEE_BENCHMARK),y) | ||
27 | TEEC_CFLAGS += -DCFG_TEE_BENCHMARK | ||
28 | endif | ||
29 | |||
30 | -TEEC_LFLAGS := -lpthread | ||
31 | +TEEC_LFLAGS := $(LDFLAGS) -lpthread | ||
32 | TEEC_LIBRARY := $(OUT_DIR)/$(LIB_MAJ_MIN) | ||
33 | |||
34 | libteec: $(TEEC_LIBRARY) | ||
35 | diff --git a/tee-supplicant/Makefile b/tee-supplicant/Makefile | ||
36 | index 737d39a..4b423fb 100644 | ||
37 | --- a/tee-supplicant/Makefile | ||
38 | +++ b/tee-supplicant/Makefile | ||
39 | @@ -55,21 +55,21 @@ ifeq ($(CFG_TA_TEST_PATH),y) | ||
40 | TEES_CFLAGS += -DCFG_TA_TEST_PATH=1 | ||
41 | endif | ||
42 | TEES_FILE := $(OUT_DIR)/$(PACKAGE_NAME) | ||
43 | -TEES_LDFLAGS := -L$(OUT_DIR)/../libteec -lteec | ||
44 | +TEES_LFLAGS := $(LDFLAGS) -L$(OUT_DIR)/../libteec -lteec | ||
45 | |||
46 | ifeq ($(CFG_TA_GPROF_SUPPORT),y) | ||
47 | TEES_CFLAGS += -DCFG_TA_GPROF_SUPPORT | ||
48 | endif | ||
49 | |||
50 | -TEES_LDFLAGS += -lpthread | ||
51 | +TEES_LFLAGS += -lpthread | ||
52 | # Needed to get clock_gettime() for for glibc versions before 2.17 | ||
53 | -TEES_LDFLAGS += -lrt | ||
54 | +TEES_LFLAGS += -lrt | ||
55 | |||
56 | tee-supplicant: $(TEES_FILE) | ||
57 | |||
58 | $(TEES_FILE): $(TEES_OBJS) | ||
59 | @echo " LINK $@" | ||
60 | - $(VPREFIX)$(CC) -o $@ $+ $(TEES_LDFLAGS) | ||
61 | + $(VPREFIX)$(CC) -o $@ $+ $(TEES_LFLAGS) | ||
62 | @echo "" | ||
63 | |||
64 | $(TEES_OBJ_DIR)/%.o: $(TEES_SRC_DIR)/%.c | ||
65 | -- | ||
66 | 2.15.0.rc2 | ||
67 | |||