summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee/optee-test_git.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-security/optee/optee-test_git.bb b/recipes-security/optee/optee-test_git.bb
new file mode 100644
index 00000000..8c38d726
--- /dev/null
+++ b/recipes-security/optee/optee-test_git.bb
@@ -0,0 +1,47 @@
1SUMMARY = "OP-TEE sanity testsuite"
2HOMEPAGE = "https://github.com/qoriq-open-source/optee_test"
3
4LICENSE = "BSD & GPLv2"
5LIC_FILES_CHKSUM = "file://${S}/LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
6
7DEPENDS = "optee-client optee-os python-pycrypto-native"
8
9inherit pythonnative
10
11SRC_URI = "git://github.com/qoriq-open-source/optee_test.git;nobranch=1 \
12 "
13S = "${WORKDIR}/git"
14
15SRCREV = "a54952babb83d801148867bd639a24ff6cd36f00"
16
17OPTEE_CLIENT_EXPORT = "${STAGING_DIR_HOST}${prefix}"
18TEEC_EXPORT = "${STAGING_DIR_HOST}${prefix}"
19TA_DEV_KIT_DIR = "${STAGING_INCDIR}/optee/export-user_ta"
20
21EXTRA_OEMAKE = " TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \
22 OPTEE_CLIENT_EXPORT=${OPTEE_CLIENT_EXPORT} \
23 TEEC_EXPORT=${TEEC_EXPORT} \
24 CROSS_COMPILE_HOST=${TARGET_PREFIX} \
25 CROSS_COMPILE_TA=${TARGET_PREFIX} \
26 V=1 \
27 "
28
29do_compile() {
30 # Top level makefile doesn't seem to handle parallel make gracefully
31 oe_runmake xtest
32 oe_runmake ta
33}
34
35do_install () {
36 install -D -p -m0755 ${S}/out/xtest/xtest ${D}${bindir}/xtest
37
38 # install path should match the value set in optee-client/tee-supplicant
39 # default TEEC_LOAD_PATH is /lib
40 mkdir -p ${D}/lib/optee_armtz/
41 install -D -p -m0444 ${S}/out/ta/*/*.ta ${D}/lib/optee_armtz/
42}
43
44FILES_${PN} += "/lib/optee_armtz/"
45
46# Imports machine specific configs from staging to build
47PACKAGE_ARCH = "${MACHINE_ARCH}"