summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-test_3.2.0.imx.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
index dc92511a..c78f9816 100644
--- a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
@@ -26,14 +26,14 @@ S = "${WORKDIR}/git"
26 26
27SRCREV = "b7114b828b82f2c0eec124ed424eff1230cc5319" 27SRCREV = "b7114b828b82f2c0eec124ed424eff1230cc5319"
28 28
29OPTEE_ARCH ?= "arm32"
30OPTEE_ARCH_armv7a = "arm32"
31OPTEE_ARCH_aarch64 = "arm64"
32
29do_compile () { 33do_compile () {
30 if [ ${DEFAULTTUNE} = "aarch64" ];then 34 export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_${OPTEE_ARCH}/
31 export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_arm64/ 35 export ARCH=${OPTEE_ARCH}
32 export ARCH=arm64 36
33 else
34 export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_arm32/
35 export ARCH=arm
36 fi
37 export OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}/usr 37 export OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}/usr
38 export CROSS_COMPILE_HOST=${HOST_PREFIX} 38 export CROSS_COMPILE_HOST=${HOST_PREFIX}
39 export CROSS_COMPILE_TA=${HOST_PREFIX} 39 export CROSS_COMPILE_TA=${HOST_PREFIX}