summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee/optee-test-qoriq_3.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/optee/optee-test-qoriq_3.8.0.bb')
-rw-r--r--recipes-security/optee/optee-test-qoriq_3.8.0.bb47
1 files changed, 0 insertions, 47 deletions
diff --git a/recipes-security/optee/optee-test-qoriq_3.8.0.bb b/recipes-security/optee/optee-test-qoriq_3.8.0.bb
deleted file mode 100644
index 52cb1bbf..00000000
--- a/recipes-security/optee/optee-test-qoriq_3.8.0.bb
+++ /dev/null
@@ -1,47 +0,0 @@
1SUMMARY = "OP-TEE sanity testsuite"
2HOMEPAGE = "https://github.com/OP-TEE/optee_test"
3
4LICENSE = "BSD & GPLv2"
5LIC_FILES_CHKSUM = "file://${S}/LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
6
7DEPENDS = "optee-client-qoriq optee-os-qoriq python3-pycryptodome-native python3-pycryptodomex-native"
8
9inherit python3native
10
11SRC_URI = "git://github.com/OP-TEE/optee_test;nobranch=1"
12SRCREV = "30481e381cb4285706e7516853495a7699c93b2c"
13
14S = "${WORKDIR}/git"
15
16OPTEE_CLIENT_EXPORT = "${STAGING_DIR_HOST}${prefix}"
17TEEC_EXPORT = "${STAGING_DIR_HOST}${prefix}"
18TA_DEV_KIT_DIR = "${STAGING_INCDIR}/optee/export-user_ta"
19
20EXTRA_OEMAKE = " TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \
21 OPTEE_CLIENT_EXPORT=${OPTEE_CLIENT_EXPORT} \
22 CFG_ARM64=y \
23 CROSS_COMPILE_HOST=${TARGET_PREFIX} \
24 CROSS_COMPILE_TA=${TARGET_PREFIX} \
25 V=1 \
26 "
27
28do_compile() {
29 # Top level makefile doesn't seem to handle parallel make gracefully
30 oe_runmake xtest
31 oe_runmake ta
32}
33
34do_install () {
35 install -D -p -m0755 ${S}/out/xtest/xtest ${D}${bindir}/xtest
36
37 # install path should match the value set in optee-client/tee-supplicant
38 # default TEEC_LOAD_PATH is /lib
39 mkdir -p ${D}/lib/optee_armtz/
40 install -D -p -m0444 ${S}/out/ta/*/*.ta ${D}/lib/optee_armtz/
41}
42
43FILES:${PN} += "/lib/optee_armtz/"
44
45# Imports machine specific configs from staging to build
46PACKAGE_ARCH = "${MACHINE_ARCH}"
47COMPATIBLE_MACHINE = "(qoriq-arm64)"