summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee/optee-client-qoriq.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/optee/optee-client-qoriq.bb')
-rw-r--r--recipes-security/optee/optee-client-qoriq.bb29
1 files changed, 0 insertions, 29 deletions
diff --git a/recipes-security/optee/optee-client-qoriq.bb b/recipes-security/optee/optee-client-qoriq.bb
deleted file mode 100644
index af5fc095..00000000
--- a/recipes-security/optee/optee-client-qoriq.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1SUMMARY = "OPTEE Client"
2HOMEPAGE = "https://github.com/qoriq-open-source/optee_client"
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
6
7inherit python3native systemd
8
9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_client;nobranch=1 \
10"
11S = "${WORKDIR}/git"
12
13SRCREV = "08428734c67fb559e420d87fa52fd74a955ea1bd"
14
15EXTRA_OEMAKE = "ARCH=arm64"
16
17do_install() {
18 oe_runmake install
19
20 install -D -p -m0755 ${S}/out/export/bin/tee-supplicant ${D}${bindir}/tee-supplicant
21
22 install -D -p -m0644 ${S}/out/export/lib/libteec.so.1.0 ${D}${libdir}/libteec.so.1.0
23 ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so
24 ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so.1
25
26 cp -a ${S}/out/export/include ${D}/usr/
27}
28
29COMPATIBLE_MACHINE = "(qoriq)"