summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/optee-imx/optee-test_3.2.0.imx.bb')
-rw-r--r--recipes-security/optee-imx/optee-test_3.2.0.imx.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
deleted file mode 100644
index c78f9816..00000000
--- a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
+++ /dev/null
@@ -1,58 +0,0 @@
1# Copyright (C) 2017-2018 NXP
2
3SUMMARY = "OPTEE test"
4HOMEPAGE = "http://www.optee.org/"
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
8
9DEPENDS = "optee-os optee-client python3-pycrypto-native openssl"
10inherit python3native
11
12FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
13
14SRCBRANCH = "lf-5.4.y"
15OPTEE_TEST_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https"
16
17SRC_URI = "${OPTEE_TEST_SRC};branch=${SRCBRANCH} \
18 file://0003-sock_server-fix-compilation-against-musl-sys-errno.h.patch \
19 file://0004-build-ignore-declaration-after-statement-warnings.patch \
20 file://0005-benchmark_1000-fix-compilation-against-musl-uint.patch \
21 file://0006-regression_8100-use-null-terminated-strings-with-fil.patch \
22 file://0001-use-python3-instead-of-python.patch \
23"
24
25S = "${WORKDIR}/git"
26
27SRCREV = "b7114b828b82f2c0eec124ed424eff1230cc5319"
28
29OPTEE_ARCH ?= "arm32"
30OPTEE_ARCH_armv7a = "arm32"
31OPTEE_ARCH_aarch64 = "arm64"
32
33do_compile () {
34 export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_${OPTEE_ARCH}/
35 export ARCH=${OPTEE_ARCH}
36
37 export OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}/usr
38 export CROSS_COMPILE_HOST=${HOST_PREFIX}
39 export CROSS_COMPILE_TA=${HOST_PREFIX}
40 export CROSS_COMPILE=${HOST_PREFIX}
41 export OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}/
42 oe_runmake V=1 --warn-undefined-variables
43}
44
45do_install () {
46 install -d ${D}/usr/bin
47 install ${S}/out/xtest/xtest ${D}/usr/bin/
48
49 install -d ${D}/lib/optee_armtz
50 find ${S}/out/ta -name '*.ta' | while read name; do
51 install -m 444 $name ${D}/lib/optee_armtz/
52 done
53
54}
55
56FILES_${PN} = "/usr/bin/ /lib*/optee_armtz/"
57
58COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"