summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-test_3.19.0.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/optee-imx/optee-test_3.19.0.imx.bb')
-rw-r--r--recipes-security/optee-imx/optee-test_3.19.0.imx.bb58
1 files changed, 2 insertions, 56 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.19.0.imx.bb b/recipes-security/optee-imx/optee-test_3.19.0.imx.bb
index a75b577c..9cc21efa 100644
--- a/recipes-security/optee-imx/optee-test_3.19.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.19.0.imx.bb
@@ -1,64 +1,10 @@
1# Copyright (C) 2017-2021 NXP 1# Copyright (C) 2017-2021 NXP
2 2
3SUMMARY = "OPTEE test" 3require optee-test-fslc.inc
4HOMEPAGE = "http://www.optee.org/"
5
6LICENSE = "BSD-2-Clause & GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
8
9DEPENDS = "python3-cryptography-native optee-os optee-client openssl"
10 4
11SRC_URI = "git://github.com/nxp-imx/imx-optee-test.git;protocol=https;branch=${SRCBRANCH}" 5SRC_URI = "git://github.com/nxp-imx/imx-optee-test.git;protocol=https;branch=${SRCBRANCH}"
6
12SRCBRANCH = "lf-5.15.71_2.2.0" 7SRCBRANCH = "lf-5.15.71_2.2.0"
13SRCREV = "5c1dbb531b304f7ae100958f6261b6cefea49b62" 8SRCREV = "5c1dbb531b304f7ae100958f6261b6cefea49b62"
14 9
15S = "${WORKDIR}/git"
16B = "${WORKDIR}/build"
17
18inherit python3native features_check
19
20REQUIRED_MACHINE_FEATURES = "optee"
21
22OPTEE_ARCH:arm = "arm32"
23OPTEE_ARCH:aarch64 = "arm64"
24
25COMPILER ?= "gcc"
26COMPILER:toolchain-clang = "clang"
27
28CFLAGS += "--sysroot=${STAGING_DIR_HOST}"
29CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}"
30
31EXTRA_OEMAKE = " \
32 TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_${OPTEE_ARCH}/ \
33 OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}${exec_prefix} \
34 CROSS_COMPILE_HOST=${HOST_PREFIX} \
35 CROSS_COMPILE_TA=${HOST_PREFIX} \
36 CROSS_COMPILE=${HOST_PREFIX} \
37 OPENSSL_MODULES=${STAGING_LIBDIR_NATIVE}/ossl-modules \
38 COMPILER=${COMPILER} \
39 -C ${S} O=${B} \
40"
41
42do_compile() {
43 oe_runmake all
44}
45do_compile[cleandirs] = "${B}"
46
47do_install () {
48 install -d ${D}${bindir}
49 install ${B}/xtest/xtest ${D}${bindir}
50
51 install -d ${D}${nonarch_base_libdir}/optee_armtz
52 find ${B}/ta -name '*.ta' | while read name; do
53 install -m 444 $name ${D}${nonarch_base_libdir}/optee_armtz/
54 done
55
56 install -d ${D}${libdir}/tee-supplicant/plugins/
57 install ${B}/supp_plugin/*plugin ${D}${libdir}/tee-supplicant/plugins/
58}
59
60FILES:${PN} += "${nonarch_base_libdir}/optee_armtz/ ${libdir}/tee-supplicant/plugins/"
61
62RDEPENDS:${PN} = "optee-os"
63
64COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 10COMPATIBLE_MACHINE = "(imx-nxp-bsp)"