summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-test/0004-build-ignore-declaration-after-statement-warnings.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/optee-imx/optee-test/0004-build-ignore-declaration-after-statement-warnings.patch')
-rw-r--r--recipes-security/optee-imx/optee-test/0004-build-ignore-declaration-after-statement-warnings.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-test/0004-build-ignore-declaration-after-statement-warnings.patch b/recipes-security/optee-imx/optee-test/0004-build-ignore-declaration-after-statement-warnings.patch
new file mode 100644
index 00000000..ed45df60
--- /dev/null
+++ b/recipes-security/optee-imx/optee-test/0004-build-ignore-declaration-after-statement-warnings.patch
@@ -0,0 +1,62 @@
1From 1401b89684ee81bf0b3d3dea06e2926b24ba3f97 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andr=C3=A9=20Draszik?= <andre.draszik@jci.com>
3Date: Thu, 7 Feb 2019 01:29:08 +0000
4Subject: [PATCH 2/3] build: ignore declaration-after-statement warnings
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9| Makefile:37: recipe for target 'xtest' failed
10| make: *** [xtest] Error 2
11| make: *** Waiting for unfinished jobs....
12| arith_taf.c: In function 'get_handle':
13| arith_taf.c:56:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement]
14| int h = handle_get(&hdb, ptr);
15| ^~~
16| arith_taf.c: In function 'ta_entry_arith_new_var':
17| arith_taf.c:82:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement]
18| size_t len = TEE_BigIntSizeInU32(params[0].value.a);
19| ^~~~~~
20| arith_taf.c: In function 'ta_entry_arith_new_fmm_var':
21| arith_taf.c:129:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement]
22| size_t len = TEE_BigIntFMMSizeInU32(params[0].value.a);
23| ^~~~~~
24| arith_taf.c: In function 'ta_entry_arith_free_handle':
25| arith_taf.c:150:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement]
26| void *ptr = put_handle(params[0].value.a & ~HT_MASK);
27| ^~~~
28| arith_taf.c: In function 'ta_entry_arith_from_octet_string':
29| arith_taf.c:165:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement]
30| TEE_BigInt *big_int = lookup_handle(HT_BIGINT, params[0].value.a);
31| ^~~~~~~~~~
32| arith_taf.c: In function 'ta_entry_arith_from_s32':
33| arith_taf.c:181:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement]
34| TEE_BigInt *big_int = lookup_handle(HT_BIGINT, params[0].value.a);
35| ^~~~~~~~~~
36
37etc.
38
39Signed-off-by: André Draszik <andre.draszik@jci.com>
40Acked-by: Jens Wiklander <jens.wiklander@linaro.org>
41Reviewed-by: Jerome Forissier <jerome.forissier@linaro.org>
42---
43Signed-off-by: André Draszik <andre.draszik@jci.com>
44Upstream-Status: Backport [3.5.0]
45 host/xtest/Makefile | 1 +
46 1 file changed, 1 insertion(+)
47
48diff --git a/host/xtest/Makefile b/host/xtest/Makefile
49index f4291e0..e97e555 100644
50--- a/host/xtest/Makefile
51+++ b/host/xtest/Makefile
52@@ -154,6 +154,7 @@ CFLAGS += -Wall -Wcast-align -Werror \
53 -Wmissing-prototypes -Wnested-externs -Wpointer-arith \
54 -Wshadow -Wstrict-prototypes -Wswitch-default \
55 -Wwrite-strings \
56+ -Wno-declaration-after-statement \
57 -Wno-missing-field-initializers -Wno-format-zero-length
58 endif
59
60--
612.23.0.rc1
62