summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/optee-imx/optee-os_3.2.0.imx.bb')
-rw-r--r--recipes-security/optee-imx/optee-os_3.2.0.imx.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
index be07f0ef..ba903519 100644
--- a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
@@ -9,14 +9,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b"
9inherit deploy python3native autotools 9inherit deploy python3native autotools
10DEPENDS = "python3-pycrypto-native u-boot-mkimage-native" 10DEPENDS = "python3-pycrypto-native u-boot-mkimage-native"
11 11
12SRCBRANCH = "imx_4.19.35_1.1.0" 12SRCBRANCH = "lf-5.4.y"
13OPTEE_OS_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https" 13OPTEE_OS_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https"
14SRC_URI = "\ 14SRC_URI = "\
15 ${OPTEE_OS_SRC};branch=${SRCBRANCH} \ 15 ${OPTEE_OS_SRC};branch=${SRCBRANCH} \
16 file://0001-scripts-update-scripts-to-use-python3.patch \ 16 file://0001-scripts-update-scripts-to-use-python3.patch \
17" 17"
18 18
19SRCREV = "6a22e6e8a2840b245808527679f3397b7e620b3c" 19SRCREV = "6d99b525af752ecdaabdca6098b2564b2665f2b2"
20 20
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22B = "${WORKDIR}/build.${PLATFORM_FLAVOR}" 22B = "${WORKDIR}/build.${PLATFORM_FLAVOR}"
@@ -30,6 +30,7 @@ PLATFORM_FLAVOR_imx6ull9x9evk = "mx6ullevk"
30PLATFORM_FLAVOR_imx6ulz14x14evk = "mx6ulzevk" 30PLATFORM_FLAVOR_imx6ulz14x14evk = "mx6ulzevk"
31PLATFORM_FLAVOR_mx8mm = "mx8mmevk" 31PLATFORM_FLAVOR_mx8mm = "mx8mmevk"
32PLATFORM_FLAVOR_mx8mn = "mx8mnevk" 32PLATFORM_FLAVOR_mx8mn = "mx8mnevk"
33PLATFORM_FLAVOR_mx8qxp = "mx8qxpmek"
33 34
34OPTEE_ARCH ?= "arm32" 35OPTEE_ARCH ?= "arm32"
35OPTEE_ARCH_armv7a = "arm32" 36OPTEE_ARCH_armv7a = "arm32"
@@ -46,10 +47,6 @@ EXTRA_OEMAKE = "PLATFORM=imx PLATFORM_FLAVOR=${PLATFORM_FLAVOR} \
46 NOWERROR=1 \ 47 NOWERROR=1 \
47 LDFLAGS= \ 48 LDFLAGS= \
48 O=${B} \ 49 O=${B} \
49 CFG_SECURE_DATA_PATH=y \
50 CFG_TEE_SDP_MEM_BASE=0xCC000000 \
51 CFG_TEE_SDP_MEM_SIZE=0x02000000 \
52 CFG_TEE_SDP_NONCACHE=y \
53 " 50 "
54 51
55 52