diff options
Diffstat (limited to 'recipes-security/optee-imx/optee-os')
-rw-r--r-- | recipes-security/optee-imx/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch | 33 | ||||
-rw-r--r-- | recipes-security/optee-imx/optee-os/0007-allow-setting-sysroot-for-clang.patch | 28 |
2 files changed, 0 insertions, 61 deletions
diff --git a/recipes-security/optee-imx/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch b/recipes-security/optee-imx/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch deleted file mode 100644 index c07d0482..00000000 --- a/recipes-security/optee-imx/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | From 528aeb42652a3159c1bfd51d6c1442c3ff27b84c Mon Sep 17 00:00:00 2001 | ||
2 | From: Ross Burton <ross.burton@arm.com> | ||
3 | Date: Tue, 26 May 2020 14:38:02 -0500 | ||
4 | Subject: [PATCH] allow setting sysroot for libgcc lookup | ||
5 | |||
6 | Explicitly pass the new variable LIBGCC_LOCATE_CFLAGS variable when searching | ||
7 | for the compiler libraries as there's no easy way to reliably pass --sysroot | ||
8 | otherwise. | ||
9 | |||
10 | Upstream-Status: Pending [https://github.com/OP-TEE/optee_os/issues/4188] | ||
11 | Signed-off-by: Ross Burton <ross.burton@arm.com> | ||
12 | |||
13 | --- | ||
14 | mk/gcc.mk | 6 +++--- | ||
15 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
16 | |||
17 | --- a/mk/gcc.mk | ||
18 | +++ b/mk/gcc.mk | ||
19 | @@ -13,11 +13,11 @@ nostdinc$(sm) := -nostdinc -isystem $(sh | ||
20 | -print-file-name=include 2> /dev/null) | ||
21 | |||
22 | # Get location of libgcc from gcc | ||
23 | -libgcc$(sm) := $(shell $(CC$(sm)) $(CFLAGS$(arch-bits-$(sm))) \ | ||
24 | +libgcc$(sm) := $(shell $(CC$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CFLAGS$(arch-bits-$(sm))) \ | ||
25 | -print-libgcc-file-name 2> /dev/null) | ||
26 | -libstdc++$(sm) := $(shell $(CXX$(sm)) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \ | ||
27 | +libstdc++$(sm) := $(shell $(CXX$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \ | ||
28 | -print-file-name=libstdc++.a 2> /dev/null) | ||
29 | -libgcc_eh$(sm) := $(shell $(CXX$(sm)) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \ | ||
30 | +libgcc_eh$(sm) := $(shell $(CXX$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \ | ||
31 | -print-file-name=libgcc_eh.a 2> /dev/null) | ||
32 | |||
33 | # Define these to something to discover accidental use | ||
diff --git a/recipes-security/optee-imx/optee-os/0007-allow-setting-sysroot-for-clang.patch b/recipes-security/optee-imx/optee-os/0007-allow-setting-sysroot-for-clang.patch deleted file mode 100644 index dc6d5517..00000000 --- a/recipes-security/optee-imx/optee-os/0007-allow-setting-sysroot-for-clang.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From db9e44af75c7cfd3316cab15aaa387383df3e57e Mon Sep 17 00:00:00 2001 | ||
2 | From: Brett Warren <brett.warren@arm.com> | ||
3 | Date: Wed, 23 Sep 2020 09:27:34 +0100 | ||
4 | Subject: [PATCH] optee: enable clang support | ||
5 | |||
6 | When compiling with clang, the LIBGCC_LOCATE_CFLAG variable used | ||
7 | to provide a sysroot wasn't included, which results in not locating | ||
8 | compiler-rt. This is mitigated by including the variable as ammended. | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | ChangeId: 8ba69a4b2eb8ebaa047cb266c9aa6c2c3da45701 | ||
12 | Signed-off-by: Brett Warren <brett.warren@arm.com> | ||
13 | |||
14 | --- | ||
15 | mk/clang.mk | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | --- a/mk/clang.mk | ||
19 | +++ b/mk/clang.mk | ||
20 | @@ -30,7 +30,7 @@ comp-cflags-warns-clang := -Wno-language | ||
21 | |||
22 | # Note, use the compiler runtime library (libclang_rt.builtins.*.a) instead of | ||
23 | # libgcc for clang | ||
24 | -libgcc$(sm) := $(shell $(CC$(sm)) $(CFLAGS$(arch-bits-$(sm))) \ | ||
25 | +libgcc$(sm) := $(shell $(CC$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CFLAGS$(arch-bits-$(sm))) \ | ||
26 | -rtlib=compiler-rt -print-libgcc-file-name 2> /dev/null) | ||
27 | |||
28 | # Core ASLR relies on the executable being ready to run from its preferred load | ||