summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-client_3.10.0.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/optee-imx/optee-client_3.10.0.imx.bb')
-rw-r--r--recipes-security/optee-imx/optee-client_3.10.0.imx.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-client_3.10.0.imx.bb b/recipes-security/optee-imx/optee-client_3.10.0.imx.bb
new file mode 100644
index 00000000..58b6b8a4
--- /dev/null
+++ b/recipes-security/optee-imx/optee-client_3.10.0.imx.bb
@@ -0,0 +1,52 @@
1# Copyright (C) 2017-2020 NXP
2
3SUMMARY = "OPTEE Client libs"
4HOMEPAGE = "http://www.optee.org/"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b"
7
8SRCBRANCH = "imx_5.4.70_2.3.0"
9SRC_URI = " \
10 git://source.codeaurora.org/external/imx/imx-optee-client.git;protocol=https;branch=${SRCBRANCH} \
11 file://tee-supplicant.service \
12"
13
14SRCREV = "2a77cf88d956c34cb4a1c191bea6113e327f5fe0"
15
16S = "${WORKDIR}/git"
17B = "${WORKDIR}/build"
18
19inherit python3native systemd
20
21SYSTEMD_SERVICE_${PN} = "tee-supplicant.service"
22
23OPTEE_ARCH ?= "arm32"
24OPTEE_ARCH_armv7a = "arm32"
25OPTEE_ARCH_aarch64 = "arm64"
26
27EXTRA_OEMAKE = "ARCH=${OPTEE_ARCH} O=${B}"
28
29do_install () {
30 oe_runmake -C ${S} install
31
32 install -D -p -m0644 ${B}/export/usr/lib/libteec.so.1.0 ${D}${libdir}/libteec.so.1.0
33 ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so
34 ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so.1
35
36 install -D -p -m0755 ${B}/export/usr/sbin/tee-supplicant ${D}${bindir}/tee-supplicant
37
38 cp -a ${B}/export/usr/include ${D}/usr/
39
40 sed -i -e s:/etc:${sysconfdir}:g -e s:/usr/bin:${bindir}:g ${WORKDIR}/tee-supplicant.service
41 install -D -p -m0644 ${WORKDIR}/tee-supplicant.service ${D}${systemd_system_unitdir}/tee-supplicant.service
42}
43
44PACKAGES += "tee-supplicant"
45FILES_${PN} += "${libdir}/* ${includedir}/*"
46FILES_tee-supplicant += "${bindir}/tee-supplicant"
47
48INSANE_SKIP_${PN} = "ldflags dev-elf"
49INSANE_SKIP_${PN}-dev = "ldflags dev-elf"
50INSANE_SKIP_tee-supplicant = "ldflags"
51
52COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"