diff options
Diffstat (limited to 'recipes-multimedia')
3 files changed, 35 insertions, 44 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.3.x.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.3.x.patch new file mode 100644 index 00000000..a9e1bd00 --- /dev/null +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.3.x.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From cfb196925312b3c3d7a19dbb9a3ce64d20d66409 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrey Zhizhikin <andrey.z@gmail.com> | ||
3 | Date: Sat, 9 May 2020 19:56:51 +0000 | ||
4 | Subject: [PATCH] opencv: allow compilation against 4.3.x | ||
5 | |||
6 | Backport upstream commit 4cf362e2df0fb809ea0f21dd4a6fbb8b46ca54ef to NXP | ||
7 | fork of gstreamer1.0-plugins-bad. | ||
8 | |||
9 | Original commit link: | ||
10 | https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/commit/4cf362e2df0fb809ea0f21dd4a6fbb8b46ca54ef | ||
11 | |||
12 | Upstream-Status: Backport [4cf362e2df0fb809ea0f21dd4a6fbb8b46ca54ef] | ||
13 | |||
14 | Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> | ||
15 | --- | ||
16 | ext/opencv/meson.build | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build | ||
20 | index d0ce1d3ee..05b142edc 100644 | ||
21 | --- a/ext/opencv/meson.build | ||
22 | +++ b/ext/opencv/meson.build | ||
23 | @@ -65,7 +65,7 @@ if opencv_found | ||
24 | endif | ||
25 | endforeach | ||
26 | else | ||
27 | - opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.1.0'], required : false) | ||
28 | + opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.4.0'], required : false) | ||
29 | opencv_found = opencv_dep.found() | ||
30 | if opencv_found | ||
31 | foreach h : libopencv4_headers | ||
32 | -- | ||
33 | 2.17.1 | ||
34 | |||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch deleted file mode 100644 index 62705dd4..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | From eb404fd917fa3ab7ffa9433c9975ee49cfc9c41f Mon Sep 17 00:00:00 2001 | ||
2 | From: Nicola Murino <nicola.murino@gmail.com> | ||
3 | Date: Tue, 23 Apr 2019 09:06:13 +0200 | ||
4 | Subject: [PATCH 1/2] opencv: allow compilation against 4.1.x | ||
5 | |||
6 | Upstream-Status: Backport [https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/commit/49a2baebf58d9288f75964fc40a547fde510a840] | ||
7 | |||
8 | (cherry picked from commit 49a2baebf58d9288f75964fc40a547fde510a840) | ||
9 | Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | ||
10 | --- | ||
11 | configure.ac | 2 +- | ||
12 | ext/opencv/meson.build | 2 +- | ||
13 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/configure.ac b/configure.ac | ||
16 | index 26f72eb0d..9e12d39a0 100644 | ||
17 | --- a/configure.ac | ||
18 | +++ b/configure.ac | ||
19 | @@ -1852,7 +1852,7 @@ AG_GST_CHECK_FEATURE(OPENCV, [opencv plugins], opencv, [ | ||
20 | HAVE_OPENCV="yes" | ||
21 | fi | ||
22 | ], [ | ||
23 | - PKG_CHECK_MODULES([OPENCV], [opencv4 >= 4.0.0 opencv4 < 4.1.0] , [ | ||
24 | + PKG_CHECK_MODULES([OPENCV], [opencv4 >= 4.0.0 opencv4 < 4.2.0] , [ | ||
25 | AC_PROG_CXX | ||
26 | AC_LANG([C++]) | ||
27 | OLD_CPPFLAGS=$CPPFLAGS | ||
28 | diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build | ||
29 | index d0ce1d3ee..f38b55dfe 100644 | ||
30 | --- a/ext/opencv/meson.build | ||
31 | +++ b/ext/opencv/meson.build | ||
32 | @@ -65,7 +65,7 @@ if opencv_found | ||
33 | endif | ||
34 | endforeach | ||
35 | else | ||
36 | - opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.1.0'], required : false) | ||
37 | + opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.2.0'], required : false) | ||
38 | opencv_found = opencv_dep.found() | ||
39 | if opencv_found | ||
40 | foreach h : libopencv4_headers | ||
41 | -- | ||
42 | 2.17.1 | ||
43 | |||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb index e64d29fa..59aeca11 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb | |||
@@ -20,7 +20,7 @@ SRC_URI = " \ | |||
20 | file://0001-ext-wayland-fix-meson-build-in-nxp-fork.patch \ | 20 | file://0001-ext-wayland-fix-meson-build-in-nxp-fork.patch \ |
21 | file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \ | 21 | file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \ |
22 | file://0001-meson-fix-build-with-opencv-enabled-and-opencv4.-Fix.patch \ | 22 | file://0001-meson-fix-build-with-opencv-enabled-and-opencv4.-Fix.patch \ |
23 | file://0002-opencv-allow-compilation-against-4.1.x.patch \ | 23 | file://0001-opencv-allow-compilation-against-4.3.x.patch \ |
24 | file://opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \ | 24 | file://opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \ |
25 | file://fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch \ | 25 | file://fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch \ |
26 | file://avoid-including-sys-poll.h-directly.patch \ | 26 | file://avoid-including-sys-poll.h-directly.patch \ |