diff options
Diffstat (limited to 'recipes-multimedia')
3 files changed, 270 insertions, 0 deletions
diff --git a/recipes-multimedia/pulseaudio/pulseaudio/imx/daemon.conf b/recipes-multimedia/pulseaudio/pulseaudio/imx/daemon.conf new file mode 100644 index 00000000..54854eb8 --- /dev/null +++ b/recipes-multimedia/pulseaudio/pulseaudio/imx/daemon.conf | |||
@@ -0,0 +1,87 @@ | |||
1 | # This file is part of PulseAudio. | ||
2 | # | ||
3 | # PulseAudio is free software; you can redistribute it and/or modify | ||
4 | # it under the terms of the GNU Lesser General Public License as published by | ||
5 | # the Free Software Foundation; either version 2 of the License, or | ||
6 | # (at your option) any later version. | ||
7 | # | ||
8 | # PulseAudio is distributed in the hope that it will be useful, but | ||
9 | # WITHOUT ANY WARRANTY; without even the implied warranty of | ||
10 | # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU | ||
11 | # General Public License for more details. | ||
12 | # | ||
13 | # You should have received a copy of the GNU Lesser General Public License | ||
14 | # along with PulseAudio; if not, write to the Free Software | ||
15 | # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 | ||
16 | # USA. | ||
17 | |||
18 | ## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for | ||
19 | ## more information. Default values are commented out. Use either ; or # for | ||
20 | ## commenting. | ||
21 | |||
22 | ; daemonize = no | ||
23 | ; fail = yes | ||
24 | ; allow-module-loading = yes | ||
25 | ; allow-exit = yes | ||
26 | ; use-pid-file = yes | ||
27 | ; system-instance = no | ||
28 | ; local-server-type = user | ||
29 | ; enable-shm = yes | ||
30 | ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB | ||
31 | ; lock-memory = no | ||
32 | ; cpu-limit = no | ||
33 | |||
34 | ; high-priority = yes | ||
35 | ; nice-level = -11 | ||
36 | |||
37 | ; realtime-scheduling = yes | ||
38 | ; realtime-priority = 5 | ||
39 | |||
40 | exit-idle-time = -1 | ||
41 | ; scache-idle-time = 20 | ||
42 | |||
43 | ; dl-search-path = (depends on architecture) | ||
44 | |||
45 | ; load-default-script-file = yes | ||
46 | ; default-script-file = /etc/pulse/default.pa | ||
47 | |||
48 | ; log-target = auto | ||
49 | ; log-level = notice | ||
50 | ; log-meta = no | ||
51 | ; log-time = no | ||
52 | ; log-backtrace = 0 | ||
53 | |||
54 | resample-method = ffmpeg | ||
55 | ; enable-remixing = yes | ||
56 | ; enable-lfe-remixing = no | ||
57 | |||
58 | flat-volumes = no | ||
59 | |||
60 | ; rlimit-fsize = -1 | ||
61 | ; rlimit-data = -1 | ||
62 | ; rlimit-stack = -1 | ||
63 | ; rlimit-core = -1 | ||
64 | ; rlimit-as = -1 | ||
65 | ; rlimit-rss = -1 | ||
66 | ; rlimit-nproc = -1 | ||
67 | ; rlimit-nofile = 256 | ||
68 | ; rlimit-memlock = -1 | ||
69 | ; rlimit-locks = -1 | ||
70 | ; rlimit-sigpending = -1 | ||
71 | ; rlimit-msgqueue = -1 | ||
72 | ; rlimit-nice = 31 | ||
73 | ; rlimit-rtprio = 9 | ||
74 | ; rlimit-rttime = 1000000 | ||
75 | |||
76 | ; default-sample-format = s16le | ||
77 | ; default-sample-rate = 44100 | ||
78 | ; alternate-sample-rate = 48000 | ||
79 | ; default-sample-channels = 2 | ||
80 | ; default-channel-map = front-left,front-right | ||
81 | |||
82 | ; default-fragments = 4 | ||
83 | ; default-fragment-size-msec = 25 | ||
84 | |||
85 | ; enable-deferred-volume = yes | ||
86 | ; deferred-volume-safety-margin-usec = 8000 | ||
87 | ; deferred-volume-extra-delay-usec = 0 | ||
diff --git a/recipes-multimedia/pulseaudio/pulseaudio/imx/default.pa b/recipes-multimedia/pulseaudio/pulseaudio/imx/default.pa new file mode 100644 index 00000000..83a6ba8d --- /dev/null +++ b/recipes-multimedia/pulseaudio/pulseaudio/imx/default.pa | |||
@@ -0,0 +1,170 @@ | |||
1 | #!/usr/bin/pulseaudio -nF | ||
2 | # | ||
3 | # This file is part of PulseAudio. | ||
4 | # | ||
5 | # PulseAudio is free software; you can redistribute it and/or modify it | ||
6 | # under the terms of the GNU Lesser General Public License as published by | ||
7 | # the Free Software Foundation; either version 2 of the License, or | ||
8 | # (at your option) any later version. | ||
9 | # | ||
10 | # PulseAudio is distributed in the hope that it will be useful, but | ||
11 | # WITHOUT ANY WARRANTY; without even the implied warranty of | ||
12 | # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU | ||
13 | # General Public License for more details. | ||
14 | # | ||
15 | # You should have received a copy of the GNU Lesser General Public License | ||
16 | # along with PulseAudio; if not, write to the Free Software Foundation, | ||
17 | # Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA. | ||
18 | |||
19 | # This startup script is used only if PulseAudio is started per-user | ||
20 | # (i.e. not in system mode) | ||
21 | |||
22 | .nofail | ||
23 | |||
24 | ### Load something into the sample cache | ||
25 | #load-sample-lazy x11-bell /usr/share/sounds/gtk-events/activate.wav | ||
26 | #load-sample-lazy pulse-hotplug /usr/share/sounds/startup3.wav | ||
27 | #load-sample-lazy pulse-coldplug /usr/share/sounds/startup3.wav | ||
28 | #load-sample-lazy pulse-access /usr/share/sounds/generic.wav | ||
29 | |||
30 | .fail | ||
31 | |||
32 | ### Automatically restore the volume of streams and devices | ||
33 | load-module module-device-restore | ||
34 | load-module module-stream-restore | ||
35 | load-module module-card-restore | ||
36 | |||
37 | ### Automatically augment property information from .desktop files | ||
38 | ### stored in /usr/share/application | ||
39 | load-module module-augment-properties | ||
40 | |||
41 | ### Should be after module-*-restore but before module-*-detect | ||
42 | load-module module-switch-on-port-available | ||
43 | |||
44 | ### Load audio drivers statically | ||
45 | ### (it's probably better to not load these drivers manually, but instead | ||
46 | ### use module-udev-detect -- see below -- for doing this automatically) | ||
47 | #load-module module-alsa-sink | ||
48 | #load-module module-alsa-source device=hw:1,0 | ||
49 | #load-module module-oss device="/dev/dsp" sink_name=output source_name=input | ||
50 | #load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input | ||
51 | #load-module module-null-sink | ||
52 | #load-module module-pipe-sink | ||
53 | |||
54 | ### Automatically load driver modules depending on the hardware available | ||
55 | .ifexists module-udev-detect.so | ||
56 | load-module module-udev-detect tsched=0 | ||
57 | .else | ||
58 | ### Use the static hardware detection module (for systems that lack udev support) | ||
59 | load-module module-detect | ||
60 | .endif | ||
61 | |||
62 | ### Automatically connect sink and source if JACK server is present | ||
63 | .ifexists module-jackdbus-detect.so | ||
64 | .nofail | ||
65 | load-module module-jackdbus-detect channels=2 | ||
66 | .fail | ||
67 | .endif | ||
68 | |||
69 | ### Automatically load driver modules for Bluetooth hardware | ||
70 | .ifexists module-bluetooth-policy.so | ||
71 | load-module module-bluetooth-policy | ||
72 | .endif | ||
73 | |||
74 | .ifexists module-bluetooth-discover.so | ||
75 | load-module module-bluetooth-discover | ||
76 | .endif | ||
77 | |||
78 | ### Load several protocols | ||
79 | .ifexists module-esound-protocol-unix.so | ||
80 | load-module module-esound-protocol-unix | ||
81 | .endif | ||
82 | load-module module-native-protocol-unix | ||
83 | |||
84 | ### Network access (may be configured with paprefs, so leave this commented | ||
85 | ### here if you plan to use paprefs) | ||
86 | #load-module module-esound-protocol-tcp | ||
87 | #load-module module-native-protocol-tcp | ||
88 | #load-module module-zeroconf-publish | ||
89 | |||
90 | ### Load the RTP receiver module (also configured via paprefs, see above) | ||
91 | #load-module module-rtp-recv | ||
92 | |||
93 | ### Load the RTP sender module (also configured via paprefs, see above) | ||
94 | #load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'" | ||
95 | #load-module module-rtp-send source=rtp.monitor | ||
96 | |||
97 | ### Load additional modules from GConf settings. This can be configured with the paprefs tool. | ||
98 | ### Please keep in mind that the modules configured by paprefs might conflict with manually | ||
99 | ### loaded modules. | ||
100 | .ifexists module-gconf.so | ||
101 | .nofail | ||
102 | load-module module-gconf | ||
103 | .fail | ||
104 | .endif | ||
105 | |||
106 | ### Automatically restore the default sink/source when changed by the user | ||
107 | ### during runtime | ||
108 | ### NOTE: This should be loaded as early as possible so that subsequent modules | ||
109 | ### that look up the default sink/source get the right value | ||
110 | load-module module-default-device-restore | ||
111 | |||
112 | ### Automatically move streams to the default sink if the sink they are | ||
113 | ### connected to dies, similar for sources | ||
114 | load-module module-rescue-streams | ||
115 | |||
116 | ### Make sure we always have a sink around, even if it is a null sink. | ||
117 | load-module module-always-sink | ||
118 | |||
119 | ### Honour intended role device property | ||
120 | load-module module-intended-roles | ||
121 | |||
122 | ### Automatically suspend sinks/sources that become idle for too long | ||
123 | load-module module-suspend-on-idle | ||
124 | |||
125 | ### If autoexit on idle is enabled we want to make sure we only quit | ||
126 | ### when no local session needs us anymore. | ||
127 | .ifexists module-console-kit.so | ||
128 | load-module module-console-kit | ||
129 | .endif | ||
130 | .ifexists module-systemd-login.so | ||
131 | load-module module-systemd-login | ||
132 | .endif | ||
133 | |||
134 | ### Enable positioned event sounds | ||
135 | load-module module-position-event-sounds | ||
136 | |||
137 | ### Cork music/video streams when a phone stream is active | ||
138 | load-module module-role-cork | ||
139 | |||
140 | ### Modules to allow autoloading of filters (such as echo cancellation) | ||
141 | ### on demand. module-filter-heuristics tries to determine what filters | ||
142 | ### make sense, and module-filter-apply does the heavy-lifting of | ||
143 | ### loading modules and rerouting streams. | ||
144 | load-module module-filter-heuristics | ||
145 | load-module module-filter-apply | ||
146 | |||
147 | ### Load DBus protocol | ||
148 | .ifexists module-dbus-protocol.so | ||
149 | load-module module-dbus-protocol | ||
150 | .endif | ||
151 | |||
152 | # X11 modules should not be started from default.pa so that one daemon | ||
153 | # can be shared by multiple sessions. | ||
154 | |||
155 | ### Load X11 bell module | ||
156 | #load-module module-x11-bell sample=bell-windowing-system | ||
157 | |||
158 | ### Register ourselves in the X11 session manager | ||
159 | #load-module module-x11-xsmp | ||
160 | |||
161 | ### Publish connection data in the X11 root window | ||
162 | #.ifexists module-x11-publish.so | ||
163 | #.nofail | ||
164 | #load-module module-x11-publish | ||
165 | #.fail | ||
166 | #.endif | ||
167 | |||
168 | ### Make some devices default | ||
169 | #set-default-sink output | ||
170 | #set-default-source input | ||
diff --git a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend index b9acb361..db4f749d 100644 --- a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend +++ b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend | |||
@@ -1,4 +1,17 @@ | |||
1 | 1 | ||
2 | CACHED_CONFIGUREVARS_append_mx6 = " ax_cv_PTHREAD_PRIO_INHERIT=no" | 2 | CACHED_CONFIGUREVARS_append_mx6 = " ax_cv_PTHREAD_PRIO_INHERIT=no" |
3 | 3 | ||
4 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/imx:" | ||
5 | |||
6 | SRC_URI_append_mx6 = " file://daemon.conf file://default.pa" | ||
7 | SRC_URI_append_mx7 = " file://daemon.conf file://default.pa" | ||
8 | |||
9 | do_install_append() { | ||
10 | if [ -e "${WORKDIR}/daemon.conf" ] && [ -e "${WORKDIR}/default.pa" ]; then | ||
11 | install -m 0644 ${WORKDIR}/daemon.conf ${D}${sysconfdir}/pulse/daemon.conf | ||
12 | install -m 0644 ${WORKDIR}/default.pa ${D}${sysconfdir}/pulse/default.pa | ||
13 | fi | ||
14 | } | ||
15 | |||
4 | PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}" | 16 | PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}" |
17 | PACKAGE_ARCH_mx7 = "${MACHINE_SOCARCH}" | ||