summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb')
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
new file mode 100644
index 00000000..240eab49
--- /dev/null
+++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
@@ -0,0 +1,28 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright (C) 2017-2021 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "Freescale Multimedia VPU wrapper"
6LICENSE = "Proprietary"
7SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d3c315c6eaa43e07d8c130dc3a04a011"
9
10DEPENDS = "virtual/imxvpu"
11DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc"
12
13SRC_URI = "git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH}"
14SRCBRANCH = "MM_04.07.00_2205_L5.15.y"
15SRCREV = "0e417b0ade3e55b5fb639d20c419b05aa31ab329"
16
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig
20
21do_install:append() {
22 # FIXME: Drop examples for now
23 rm -r ${D}${datadir}
24}
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28COMPATIBLE_MACHINE = "(imxvpu)"