summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-parser/imx-parser_4.5.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/imx-parser/imx-parser_4.5.5.bb')
-rw-r--r--recipes-multimedia/imx-parser/imx-parser_4.5.5.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.5.5.bb b/recipes-multimedia/imx-parser/imx-parser_4.5.5.bb
new file mode 100644
index 00000000..ddc83aa2
--- /dev/null
+++ b/recipes-multimedia/imx-parser/imx-parser_4.5.5.bb
@@ -0,0 +1,46 @@
1# Copyright (C) 2012-2018 O.S. Systems Software LTDA.
2# Copyright (C) 2012-2016 Freescale Semiconductor
3# Copyright (C) 2017, 2019 NXP
4# Released under the MIT license (see COPYING.MIT for the terms)
5DESCRIPTION = "Freescale Multimedia parser libs"
6LICENSE = "Proprietary"
7SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=228c72f2a91452b8a03c4cab30f30ef9"
9
10# For backwards compatibility
11PROVIDES += "libfslparser"
12RREPLACES_${PN} = "libfslparser"
13RPROVIDES_${PN} = "libfslparser"
14RCONFLICTS_${PN} = "libfslparser"
15
16SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
17SRC_URI[md5sum] = "0845c64d2b64c2822328e8bc8442f5b8"
18SRC_URI[sha256sum] = "33b8377a663b2ca749f40ef1164918335913e4de02a3857f2892707647d243de"
19
20inherit fsl-eula-unpack autotools pkgconfig
21
22# Choose between 32-bit and 64-bit binaries and between Soft Float-Point and Hard Float-Point
23EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', \
24 bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '--enable-fsw', d), d)}"
25
26INHIBIT_PACKAGE_STRIP = "1"
27INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
28
29python __set_insane_skip() {
30 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have
31 # the source we cannot fix it. Disable the insane check for now.
32 # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
33 for p in d.getVar('PACKAGES').split():
34 d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so textrel")
35}
36
37do_package_qa[prefuncs] += "__set_insane_skip"
38
39# FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
40FILES_${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}"
41
42PACKAGE_ARCH = "${MACHINE_ARCH}"
43
44INHIBIT_SYSROOT_STRIP = "1"
45
46COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"