summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-dsp/imx-dsp_2.1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/imx-dsp/imx-dsp_2.1.7.bb')
-rw-r--r--recipes-multimedia/imx-dsp/imx-dsp_2.1.7.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-dsp/imx-dsp_2.1.7.bb b/recipes-multimedia/imx-dsp/imx-dsp_2.1.7.bb
new file mode 100644
index 00000000..60761e6e
--- /dev/null
+++ b/recipes-multimedia/imx-dsp/imx-dsp_2.1.7.bb
@@ -0,0 +1,57 @@
1# Copyright 2017-2023 NXP
2
3DESCRIPTION = "i.MX DSP Wrapper, Firmware Binary, Codec Libraries"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=44a8052c384584ba09077e85a3d1654f"
6
7
8inherit fsl-eula-unpack autotools pkgconfig
9
10SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
11
12SRC_URI[md5sum] = "199f88716f289e93e0954fa6475a3cbc"
13SRC_URI[sha256sum] = "83eaef592de33b4d5e8fae63d798cc955bf3c414911c87afeb65a20af01fb0b6"
14
15EXTRA_OECONF = " \
16 -datadir=${base_libdir}/firmware \
17 --bindir=/unit_tests \
18 ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', '', d)} \
19"
20
21HIFI4_PLATFORM ?= "HIFI4_PLATFORM_IS_UNDEFINED"
22HIFI4_PLATFORM:mx8qm-nxp-bsp = "imx8qmqxp"
23HIFI4_PLATFORM:mx8qxp-nxp-bsp = "imx8qmqxp"
24HIFI4_PLATFORM:mx8dx-nxp-bsp = "imx8qmqxp"
25HIFI4_PLATFORM:mx8mp-nxp-bsp = "imx8mp"
26HIFI4_PLATFORM:mx8ulp-nxp-bsp = "imx8ulp"
27
28UNSUPPORTED_TESTS = "dsp_tflm"
29UNSUPPORTED_TESTS:mx8ulp-nxp-bsp = ""
30
31do_install:append () {
32 # Remove firmware not for this platform
33 find ${D}/${base_libdir}/firmware/imx/dsp -name hifi4_*.bin -not -name *${HIFI4_PLATFORM}* -exec rm {} \;
34 # Set the expected generic name for the firmware
35 mv ${D}/${base_libdir}/firmware/imx/dsp/hifi4_${HIFI4_PLATFORM}.bin ${D}/${base_libdir}/firmware/imx/dsp/hifi4.bin
36 # Remove unit tests not for this platform
37 for unsupported_test in ${UNSUPPORTED_TESTS}; do
38 find ${D}/unit_tests/DSP -name $unsupported_test* -exec rm {} \;
39 done
40}
41
42FILES:${PN} = "${libdir}/imx-mm/audio-codec/dsp \
43 ${libdir}/imx-mm/audio-codec/wrap \
44 ${base_libdir}/firmware/imx/dsp \
45 /unit_tests \
46"
47RDEPENDS:${PN} += "imx-dsp-codec-ext"
48
49INSANE_SKIP:${PN} = "already-stripped arch ldflags dev-so"
50
51# Fix strip command failed: 'Unable to recognise the format of the input file'
52INHIBIT_PACKAGE_STRIP = "1"
53INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
54INHIBIT_SYSROOT_STRIP = "1"
55
56PACKAGE_ARCH = "${MACHINE_ARCH}"
57COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8dx-nxp-bsp|mx8mp-nxp-bsp|mx8ulp-nxp-bsp)"