summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-dsp/imx-dsp_2.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/imx-dsp/imx-dsp_2.0.1.bb')
-rw-r--r--recipes-multimedia/imx-dsp/imx-dsp_2.0.1.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-dsp/imx-dsp_2.0.1.bb b/recipes-multimedia/imx-dsp/imx-dsp_2.0.1.bb
new file mode 100644
index 00000000..9e634b60
--- /dev/null
+++ b/recipes-multimedia/imx-dsp/imx-dsp_2.0.1.bb
@@ -0,0 +1,57 @@
1# Copyright 2017-2022 NXP
2
3DESCRIPTION = "i.MX DSP Wrapper, Firmware Binary, Codec Libraries"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe"
6
7inherit fsl-eula-unpack autotools pkgconfig
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10
11SRC_URI[md5sum] = "71e18d4518551f665fa0258ccf6605b0"
12SRC_URI[sha256sum] = "7441cf3cbdc12058f2841a708b1374c637d2a171cca17a348338ebf4580a417e"
13
14EXTRA_OECONF = " \
15 -datadir=${base_libdir}/firmware \
16 --bindir=/unit_tests \
17 ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', '', d)} \
18"
19
20RDEPENDS:${PN} += " imx-dsp-codec-ext"
21
22HIFI4_PLATFORM ?= "HIFI4_PLATFORM_IS_UNDEFINED"
23HIFI4_PLATFORM:mx8qm-nxp-bsp = "imx8qmqxp"
24HIFI4_PLATFORM:mx8qxp-nxp-bsp = "imx8qmqxp"
25HIFI4_PLATFORM:mx8dx-nxp-bsp = "imx8qmqxp"
26HIFI4_PLATFORM:mx8mp-nxp-bsp = "imx8mp"
27HIFI4_PLATFORM:mx8ulp-nxp-bsp = "imx8ulp"
28
29UNSUPPORTED_TESTS = "dsp_tflm"
30UNSUPPORTED_TESTS:mx8ulp-nxp-bsp = ""
31
32do_install:append () {
33 # Remove firmware not for this platform
34 find ${D}/${base_libdir}/firmware/imx/dsp -name hifi4_*.bin -not -name *${HIFI4_PLATFORM}* -exec rm {} \;
35 # Set the expected generic name for the firmware
36 mv ${D}/${base_libdir}/firmware/imx/dsp/hifi4_${HIFI4_PLATFORM}.bin ${D}/${base_libdir}/firmware/imx/dsp/hifi4.bin
37 # Remove unit tests not for this platform
38 for unsupported_test in ${UNSUPPORTED_TESTS}; do
39 find ${D}/unit_tests/DSP -name $unsupported_test* -exec rm {} \;
40 done
41}
42
43FILES:${PN} = "${libdir}/imx-mm/audio-codec/dsp \
44 ${libdir}/imx-mm/audio-codec/wrap \
45 ${base_libdir}/firmware/imx/dsp \
46 /unit_tests \
47"
48
49INSANE_SKIP:${PN} = "already-stripped arch ldflags dev-so"
50
51# Fix strip command failed: 'Unable to recognise the format of the input file'
52INHIBIT_PACKAGE_STRIP = "1"
53INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
54INHIBIT_SYSROOT_STRIP = "1"
55
56PACKAGE_ARCH = "${MACHINE_ARCH}"
57COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8dx-nxp-bsp|mx8mp-nxp-bsp|mx8ulp-nxp-bsp)"