diff options
Diffstat (limited to 'recipes-multimedia/gstreamer')
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.%.bbappend | 16 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.0.imx.bb | 11 |
2 files changed, 21 insertions, 6 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.%.bbappend new file mode 100644 index 00000000..761189af --- /dev/null +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.%.bbappend | |||
@@ -0,0 +1,16 @@ | |||
1 | PACKAGECONFIG_GL:imxgpu2d = \ | ||
2 | "${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl', '', d)}" | ||
3 | PACKAGECONFIG_GL:imxgpu3d = \ | ||
4 | "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}" | ||
5 | PACKAGECONFIG_GL:use-mainline-bsp = \ | ||
6 | "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl gbm', '', d)}" | ||
7 | |||
8 | # The i.MX8 uses KMS instead of the Vivante specific framebuffer API. | ||
9 | # The i.MX7 does not have a GPU. | ||
10 | # This leaves the i.MX6 - with the vendor BSP - as the remaining use case for viv-fb. | ||
11 | # | ||
12 | # (Note that viv-fb is about the _windowing system_. Vivante direct texture support | ||
13 | # does not depend on the viv-fb feature. It used to, but that was actually a bug | ||
14 | # which was fixed in GStreamer 1.22.5. Since then, the direct texture support is | ||
15 | # detected by Meson by checking for direct texture symbols like "glTexDirectVIV".) | ||
16 | PACKAGECONFIG_GL:append:mx6-nxp-bsp = " viv-fb " | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.0.imx.bb index df0b9912..d8c65287 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.0.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.0.imx.bb | |||
@@ -123,12 +123,11 @@ S = "${WORKDIR}/git" | |||
123 | 123 | ||
124 | inherit use-imx-headers | 124 | inherit use-imx-headers |
125 | 125 | ||
126 | PACKAGECONFIG_GL:imxgpu2d = \ | 126 | # Prior to version 1.22.5, viv-fb is coupled with the Vivante direct texture feature. |
127 | "${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl viv-fb', '', d)}" | 127 | # For this reason, in these older versions, viv-fb must be enabled always, even when |
128 | PACKAGECONFIG_GL:imxgpu3d = \ | 128 | # building for SoCs like the i.MX8 that do not support the viv-fb windowing system. |
129 | "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl viv-fb', '', d)}" | 129 | # TODO: Once this .imx recipe is upgraded to 1.22.5 or newer, drop this line. |
130 | PACKAGECONFIG_GL:use-mainline-bsp = \ | 130 | PACKAGECONFIG_GL:append = " viv-fb " |
131 | "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl gbm', '', d)}" | ||
132 | 131 | ||
133 | PACKAGECONFIG_REMOVE ?= "jpeg" | 132 | PACKAGECONFIG_REMOVE ?= "jpeg" |
134 | PACKAGECONFIG:remove = "${PACKAGECONFIG_REMOVE}" | 133 | PACKAGECONFIG:remove = "${PACKAGECONFIG_REMOVE}" |