summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb')
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb85
1 files changed, 85 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb
new file mode 100644
index 00000000..cdd5d848
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb
@@ -0,0 +1,85 @@
1# Copyright (C) 2014,2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Copyright (C) 2012-2015 O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "Gstreamer freescale plugins"
7LICENSE = "GPL-2.0-only & LGPL-2.0-only & LGPL-2.1-only"
8SECTION = "multimedia"
9
10DEPENDS = "imx-codec imx-parser gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
11DEPENDS:append:mx6-nxp-bsp = " imx-lib"
12DEPENDS:append:mx7-nxp-bsp = " imx-lib"
13DEPENDS:append:mx8ulp-nxp-bsp = " imx-lib"
14DEPENDS:append:mx9-nxp-bsp = " imx-lib"
15DEPENDS:append:imxvpu = " imx-vpuwrap"
16DEPENDS:append:imxfbdev:imxgpu = " libdrm"
17
18# For backwards compatibility
19RREPLACES:${PN} = "gst1.0-fsl-plugin"
20RPROVIDES:${PN} = "gst1.0-fsl-plugin"
21RCONFLICTS:${PN} = "gst1.0-fsl-plugin"
22
23LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
24 file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
25
26PV = "4.7.2+git${SRCPV}"
27
28SRC_URI = "git://github.com/nxp-imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH}"
29SRCBRANCH = "MM_04.07.02_2210_L5.15.y"
30SRCREV = "3a0250b983f2610e6936d10c63b45e2d39eadd7e"
31
32S = "${WORKDIR}/git"
33
34inherit meson pkgconfig use-imx-headers
35
36PLATFORM:mx6-nxp-bsp = "MX6"
37PLATFORM:mx6sl-nxp-bsp = "MX6SL"
38PLATFORM:mx6sx-nxp-bsp = "MX6SX"
39PLATFORM:mx6ul-nxp-bsp = "MX6UL"
40PLATFORM:mx6sll-nxp-bsp = "MX6SLL"
41PLATFORM:mx7-nxp-bsp= "MX7D"
42PLATFORM:mx7ulp-nxp-bsp= "MX7ULP"
43PLATFORM:mx8-nxp-bsp = "MX8"
44PLATFORM:mx9-nxp-bsp = "MX9"
45
46# Todo add a mechanism to map possible build targets
47EXTRA_OEMESON = "-Dplatform=${PLATFORM} \
48 -Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}" \
49"
50
51PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine ${PN}-libplayengine"
52
53# Add codec list that the beep plugin run-time depended
54BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis"
55RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
56RDEPENDS:${PN}:append:mx8qm-nxp-bsp = " imx-dsp"
57RDEPENDS:${PN}:append:mx8qxp-nxp-bsp = " imx-dsp"
58RDEPENDS:${PN}:append:mx8dx-nxp-bsp = " imx-dsp"
59RDEPENDS:${PN}:append:mx8mp-nxp-bsp = " imx-dsp"
60RDEPENDS:${PN}:append:mx8ulp-nxp-bsp = " imx-dsp"
61
62PACKAGECONFIG ?= ""
63
64# FIXME: Add all features
65# feature from excluded mm packages
66PACKAGECONFIG[ac3] = ",,imx-ac3codec,imx-ac3codec"
67# feature from special mm packages
68PACKAGECONFIG[aacp] = ",,imx-aacpcodec,imx-aacpcodec"
69MSDEPENDS = "imx-msparser imx-mscodec"
70PACKAGECONFIG[wma10dec] = ",,${MSDEPENDS},${MSDEPENDS}"
71PACKAGECONFIG[wma8enc] = ",,${MSDEPENDS},${MSDEPENDS}"
72
73FILES:${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}"
74
75FILES:${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
76FILES:${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc"
77FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
78FILES:${PN}-gplay = "${bindir}/gplay-1.0"
79FILES:${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}"
80FILES:${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}"
81FILES:${PN}-grecorder = "${bindir}/grecorder-1.0"
82FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}"
83FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}"
84
85COMPATIBLE_MACHINE = "(imx-nxp-bsp)"