summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.7.1.bb')
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.7.1.bb81
1 files changed, 81 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.7.1.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.7.1.bb
new file mode 100644
index 00000000..d174b70c
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.7.1.bb
@@ -0,0 +1,81 @@
1# Copyright (C) 2014,2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Copyright (C) 2012-2015 O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "Gstreamer freescale plugins"
7LICENSE = "GPL-2.0-only & LGPL-2.0-only & LGPL-2.1-only"
8SECTION = "multimedia"
9
10DEPENDS = "imx-codec imx-parser gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
11DEPENDS:append:mx6-nxp-bsp = " imx-lib"
12DEPENDS:append:mx7-nxp-bsp = " imx-lib"
13DEPENDS:append:mx8ulp-nxp-bsp = " imx-lib"
14DEPENDS:append:imxvpu = " imx-vpuwrap"
15DEPENDS:append:imxfbdev:imxgpu = " libdrm"
16
17# For backwards compatibility
18RREPLACES:${PN} = "gst1.0-fsl-plugin"
19RPROVIDES:${PN} = "gst1.0-fsl-plugin"
20RCONFLICTS:${PN} = "gst1.0-fsl-plugin"
21
22LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
23 file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
24
25SRC_URI = "git://github.com/nxp-imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH}"
26SRCBRANCH = "MM_04.07.01_2208_L5.15.y"
27SRCREV = "f4410b70e8cb49ec0d522bb0681c5d9178cfc216"
28
29S = "${WORKDIR}/git"
30
31inherit meson pkgconfig use-imx-headers
32
33PLATFORM:mx6-nxp-bsp = "MX6"
34PLATFORM:mx6sl-nxp-bsp = "MX6SL"
35PLATFORM:mx6sx-nxp-bsp = "MX6SX"
36PLATFORM:mx6ul-nxp-bsp = "MX6UL"
37PLATFORM:mx6sll-nxp-bsp = "MX6SLL"
38PLATFORM:mx7-nxp-bsp= "MX7D"
39PLATFORM:mx7ulp-nxp-bsp= "MX7ULP"
40PLATFORM:mx8-nxp-bsp = "MX8"
41
42# Todo add a mechanism to map possible build targets
43EXTRA_OEMESON = "-Dplatform=${PLATFORM} \
44 -Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}" \
45"
46
47PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine ${PN}-libplayengine"
48
49# Add codec list that the beep plugin run-time depended
50BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis"
51RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
52RDEPENDS:${PN}:append:mx8qm-nxp-bsp = " imx-dsp"
53RDEPENDS:${PN}:append:mx8qxp-nxp-bsp = " imx-dsp"
54RDEPENDS:${PN}:append:mx8dx-nxp-bsp = " imx-dsp"
55RDEPENDS:${PN}:append:mx8mp-nxp-bsp = " imx-dsp"
56RDEPENDS:${PN}:append:mx8ulp-nxp-bsp = " imx-dsp"
57
58PACKAGECONFIG ?= ""
59
60# FIXME: Add all features
61# feature from excluded mm packages
62PACKAGECONFIG[ac3] = ",,imx-ac3codec,imx-ac3codec"
63# feature from special mm packages
64PACKAGECONFIG[aacp] = ",,imx-aacpcodec,imx-aacpcodec"
65MSDEPENDS = "imx-msparser imx-mscodec"
66PACKAGECONFIG[wma10dec] = ",,${MSDEPENDS},${MSDEPENDS}"
67PACKAGECONFIG[wma8enc] = ",,${MSDEPENDS},${MSDEPENDS}"
68
69FILES:${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}"
70
71FILES:${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
72FILES:${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc"
73FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
74FILES:${PN}-gplay = "${bindir}/gplay-1.0"
75FILES:${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}"
76FILES:${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}"
77FILES:${PN}-grecorder = "${bindir}/grecorder-1.0"
78FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}"
79FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}"
80
81COMPATIBLE_MACHINE = "(imx-nxp-bsp)"