diff options
Diffstat (limited to 'recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.7.0.bb')
-rw-r--r-- | recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.7.0.bb | 81 |
1 files changed, 81 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.7.0.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.7.0.bb new file mode 100644 index 00000000..585113a4 --- /dev/null +++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.7.0.bb | |||
@@ -0,0 +1,81 @@ | |||
1 | # Copyright (C) 2014,2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2021 NXP | ||
3 | # Copyright (C) 2012-2015 O.S. Systems Software LTDA. | ||
4 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
5 | |||
6 | DESCRIPTION = "Gstreamer freescale plugins" | ||
7 | LICENSE = "GPL-2.0-only & LGPL-2.0-only & LGPL-2.1-only" | ||
8 | SECTION = "multimedia" | ||
9 | |||
10 | DEPENDS = "imx-codec imx-parser gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" | ||
11 | DEPENDS:append:mx6-nxp-bsp = " imx-lib" | ||
12 | DEPENDS:append:mx7-nxp-bsp = " imx-lib" | ||
13 | DEPENDS:append:mx8ulp-nxp-bsp = " imx-lib" | ||
14 | DEPENDS:append:imxvpu = " imx-vpuwrap" | ||
15 | DEPENDS:append:imxfbdev:imxgpu = " libdrm" | ||
16 | |||
17 | # For backwards compatibility | ||
18 | RREPLACES:${PN} = "gst1.0-fsl-plugin" | ||
19 | RPROVIDES:${PN} = "gst1.0-fsl-plugin" | ||
20 | RCONFLICTS:${PN} = "gst1.0-fsl-plugin" | ||
21 | |||
22 | LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | ||
23 | file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" | ||
24 | |||
25 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH}" | ||
26 | SRCBRANCH = "MM_04.07.00_2205_L5.15.y" | ||
27 | SRCREV = "d0b26997556983c99d7b3e7663577f090df36240" | ||
28 | |||
29 | S = "${WORKDIR}/git" | ||
30 | |||
31 | inherit meson pkgconfig use-imx-headers | ||
32 | |||
33 | PLATFORM:mx6-nxp-bsp = "MX6" | ||
34 | PLATFORM:mx6sl-nxp-bsp = "MX6SL" | ||
35 | PLATFORM:mx6sx-nxp-bsp = "MX6SX" | ||
36 | PLATFORM:mx6ul-nxp-bsp = "MX6UL" | ||
37 | PLATFORM:mx6sll-nxp-bsp = "MX6SLL" | ||
38 | PLATFORM:mx7-nxp-bsp= "MX7D" | ||
39 | PLATFORM:mx7ulp-nxp-bsp= "MX7ULP" | ||
40 | PLATFORM:mx8-nxp-bsp = "MX8" | ||
41 | |||
42 | # Todo add a mechanism to map possible build targets | ||
43 | EXTRA_OEMESON = "-Dplatform=${PLATFORM} \ | ||
44 | -Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}" \ | ||
45 | " | ||
46 | |||
47 | PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine ${PN}-libplayengine" | ||
48 | |||
49 | # Add codec list that the beep plugin run-time depended | ||
50 | BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis" | ||
51 | RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " | ||
52 | RDEPENDS:${PN}:append:mx8qm-nxp-bsp = " imx-dsp" | ||
53 | RDEPENDS:${PN}:append:mx8qxp-nxp-bsp = " imx-dsp" | ||
54 | RDEPENDS:${PN}:append:mx8dx-nxp-bsp = " imx-dsp" | ||
55 | RDEPENDS:${PN}:append:mx8mp-nxp-bsp = " imx-dsp" | ||
56 | RDEPENDS:${PN}:append:mx8ulp-nxp-bsp = " imx-dsp" | ||
57 | |||
58 | PACKAGECONFIG ?= "" | ||
59 | |||
60 | # FIXME: Add all features | ||
61 | # feature from excluded mm packages | ||
62 | PACKAGECONFIG[ac3] = ",,imx-ac3codec,imx-ac3codec" | ||
63 | # feature from special mm packages | ||
64 | PACKAGECONFIG[aacp] = ",,imx-aacpcodec,imx-aacpcodec" | ||
65 | MSDEPENDS = "imx-msparser imx-mscodec" | ||
66 | PACKAGECONFIG[wma10dec] = ",,${MSDEPENDS},${MSDEPENDS}" | ||
67 | PACKAGECONFIG[wma8enc] = ",,${MSDEPENDS},${MSDEPENDS}" | ||
68 | |||
69 | FILES:${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}" | ||
70 | |||
71 | FILES:${PN}-dbg += "${libdir}/gstreamer-1.0/.debug" | ||
72 | FILES:${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc" | ||
73 | FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a" | ||
74 | FILES:${PN}-gplay = "${bindir}/gplay-1.0" | ||
75 | FILES:${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}" | ||
76 | FILES:${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}" | ||
77 | FILES:${PN}-grecorder = "${bindir}/grecorder-1.0" | ||
78 | FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" | ||
79 | FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}" | ||
80 | |||
81 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" | ||