summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.4.bb')
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.4.bb83
1 files changed, 83 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.4.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.4.bb
new file mode 100644
index 00000000..42bde58c
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.4.bb
@@ -0,0 +1,83 @@
1# Copyright (C) 2014,2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Copyright (C) 2012-2015 O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "Gstreamer freescale plugins"
7LICENSE = "GPL-2.0-only & LGPL-2.0-only & LGPL-2.1-only"
8SECTION = "multimedia"
9
10DEPENDS = "imx-codec imx-parser gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
11DEPENDS:append:mx6-nxp-bsp = " imx-lib"
12DEPENDS:append:mx7-nxp-bsp = " imx-lib"
13DEPENDS:append:mx8ulp-nxp-bsp = " imx-lib"
14DEPENDS:append:imxvpu = " imx-vpuwrap libdrm"
15
16# For backwards compatibility
17RREPLACES:${PN} = "gst1.0-fsl-plugin"
18RPROVIDES:${PN} = "gst1.0-fsl-plugin"
19RCONFLICTS:${PN} = "gst1.0-fsl-plugin"
20
21LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
22 file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
23
24SRCBRANCH = "MM_04.06.04_2112_L5.15.y"
25
26
27
28SRC_URI = "git://source.codeaurora.org/external/imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH}"
29SRCREV = "f4b3105ab33e608c717855cdd1a520b60f377bf3"
30
31S = "${WORKDIR}/git"
32
33inherit meson pkgconfig use-imx-headers
34
35PLATFORM:mx6-nxp-bsp = "MX6"
36PLATFORM:mx6sl-nxp-bsp = "MX6SL"
37PLATFORM:mx6sx-nxp-bsp = "MX6SX"
38PLATFORM:mx6ul-nxp-bsp = "MX6UL"
39PLATFORM:mx6sll-nxp-bsp = "MX6SLL"
40PLATFORM:mx7-nxp-bsp= "MX7D"
41PLATFORM:mx7ulp-nxp-bsp= "MX7ULP"
42PLATFORM:mx8-nxp-bsp = "MX8"
43
44# Todo add a mechanism to map possible build targets
45EXTRA_OEMESON = "-Dplatform=${PLATFORM} \
46 -Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}" \
47"
48
49PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine ${PN}-libplayengine"
50
51# Add codec list that the beep plugin run-time depended
52BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis"
53RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
54RDEPENDS:${PN}:append:mx8qm-nxp-bsp = " imx-dsp"
55RDEPENDS:${PN}:append:mx8qxp-nxp-bsp = " imx-dsp"
56RDEPENDS:${PN}:append:mx8dx-nxp-bsp = " imx-dsp"
57RDEPENDS:${PN}:append:mx8mp-nxp-bsp = " imx-dsp"
58RDEPENDS:${PN}:append:mx8ulp-nxp-bsp = " imx-dsp"
59
60PACKAGECONFIG ?= ""
61
62# FIXME: Add all features
63# feature from excluded mm packages
64PACKAGECONFIG[ac3] = ",,imx-ac3codec,imx-ac3codec"
65# feature from special mm packages
66PACKAGECONFIG[aacp] = ",,imx-aacpcodec,imx-aacpcodec"
67MSDEPENDS = "imx-msparser imx-mscodec"
68PACKAGECONFIG[wma10dec] = ",,${MSDEPENDS},${MSDEPENDS}"
69PACKAGECONFIG[wma8enc] = ",,${MSDEPENDS},${MSDEPENDS}"
70
71FILES:${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}"
72
73FILES:${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
74FILES:${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc"
75FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
76FILES:${PN}-gplay = "${bindir}/gplay-1.0"
77FILES:${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}"
78FILES:${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}"
79FILES:${PN}-grecorder = "${bindir}/grecorder-1.0"
80FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}"
81FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}"
82
83COMPATIBLE_MACHINE = "(imx-nxp-bsp)"