summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb')
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb30
1 files changed, 15 insertions, 15 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
index b5fb8890..2de5df53 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
@@ -8,8 +8,8 @@ LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
8SECTION = "multimedia" 8SECTION = "multimedia"
9 9
10DEPENDS = "imx-codec imx-parser gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" 10DEPENDS = "imx-codec imx-parser gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
11DEPENDS:append:mx6 = " imx-lib" 11DEPENDS:append:mx6-nxp-bsp = " imx-lib"
12DEPENDS:append:mx7 = " imx-lib" 12DEPENDS:append:mx7-nxp-bsp = " imx-lib"
13DEPENDS:append:imxvpu = " imx-vpuwrap libdrm" 13DEPENDS:append:imxvpu = " imx-vpuwrap libdrm"
14 14
15# For backwards compatibility 15# For backwards compatibility
@@ -30,14 +30,14 @@ S = "${WORKDIR}/git"
30 30
31inherit meson pkgconfig use-imx-headers 31inherit meson pkgconfig use-imx-headers
32 32
33PLATFORM:mx6 = "MX6" 33PLATFORM:mx6-nxp-bsp = "MX6"
34PLATFORM:mx6sl = "MX6SL" 34PLATFORM:mx6sl-nxp-bsp = "MX6SL"
35PLATFORM:mx6sx = "MX6SX" 35PLATFORM:mx6sx-nxp-bsp = "MX6SX"
36PLATFORM:mx6ul = "MX6UL" 36PLATFORM:mx6ul-nxp-bsp = "MX6UL"
37PLATFORM:mx6sll = "MX6SLL" 37PLATFORM:mx6sll-nxp-bsp = "MX6SLL"
38PLATFORM:mx7= "MX7D" 38PLATFORM:mx7-nxp-bsp= "MX7D"
39PLATFORM:mx7ulp= "MX7ULP" 39PLATFORM:mx7ulp-nxp-bsp= "MX7ULP"
40PLATFORM:mx8 = "MX8" 40PLATFORM:mx8-nxp-bsp = "MX8"
41 41
42# Todo add a mechanism to map possible build targets 42# Todo add a mechanism to map possible build targets
43EXTRA_OEMESON = "-Dplatform=${PLATFORM} \ 43EXTRA_OEMESON = "-Dplatform=${PLATFORM} \
@@ -49,10 +49,10 @@ PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN
49# Add codec list that the beep plugin run-time depended 49# Add codec list that the beep plugin run-time depended
50BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis" 50BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis"
51RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " 51RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
52RDEPENDS:${PN}:append:mx8qm = " imx-dsp" 52RDEPENDS:${PN}:append:mx8qm-nxp-bsp = " imx-dsp"
53RDEPENDS:${PN}:append:mx8qxp = " imx-dsp" 53RDEPENDS:${PN}:append:mx8qxp-nxp-bsp = " imx-dsp"
54RDEPENDS:${PN}:append:mx8mp = " imx-dsp" 54RDEPENDS:${PN}:append:mx8mp-nxp-bsp = " imx-dsp"
55RDEPENDS:${PN}:append:mx8ulp = " imx-dsp" 55RDEPENDS:${PN}:append:mx8ulp-nxp-bsp = " imx-dsp"
56 56
57# overlaysink rely on G2D, 57# overlaysink rely on G2D,
58# cannot be supported on i.MX6SLL & i.MX6UL & i.MX6ULL & i.MX7D 58# cannot be supported on i.MX6SLL & i.MX6UL & i.MX6ULL & i.MX7D
@@ -82,4 +82,4 @@ FILES:${PN}-grecorder = "${bindir}/grecorder-1.0"
82FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" 82FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}"
83FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}" 83FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}"
84 84
85COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 85COMPATIBLE_MACHINE = "(imx-nxp-bsp)"