summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb')
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb81
1 files changed, 81 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
new file mode 100644
index 00000000..9d43a175
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
@@ -0,0 +1,81 @@
1# Copyright (C) 2014,2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Copyright (C) 2012-2015 O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "Gstreamer freescale plugins"
7LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
8SECTION = "multimedia"
9
10DEPENDS = "imx-codec imx-parser gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
11DEPENDS:append:mx6 = " imx-lib"
12DEPENDS:append:mx7 = " imx-lib"
13DEPENDS:append:imxvpu = " imx-vpuwrap libdrm"
14
15# For backwards compatibility
16RREPLACES:${PN} = "gst1.0-fsl-plugin"
17RPROVIDES:${PN} = "gst1.0-fsl-plugin"
18RCONFLICTS:${PN} = "gst1.0-fsl-plugin"
19
20LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
21 file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
22
23SRCBRANCH = "MM_04.06.01_2105_L5.10.y"
24
25
26SRC_URI = "git://source.codeaurora.org/external/imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH}"
27SRCREV = "057e6bfbc208ce31e8ed0af0264dd1e86de05808"
28
29S = "${WORKDIR}/git"
30
31inherit meson pkgconfig use-imx-headers
32
33PLATFORM:mx6 = "MX6"
34PLATFORM:mx6sl = "MX6SL"
35PLATFORM:mx6sx = "MX6SX"
36PLATFORM:mx6ul = "MX6UL"
37PLATFORM:mx6sll = "MX6SLL"
38PLATFORM:mx7= "MX7D"
39PLATFORM:mx7ulp= "MX7ULP"
40PLATFORM:mx8 = "MX8"
41
42# Todo add a mechanism to map possible build targets
43EXTRA_OEMESON = "-Dplatform=${PLATFORM} \
44 -Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}" \
45"
46
47PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine ${PN}-libplayengine"
48
49# Add codec list that the beep plugin run-time depended
50BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis"
51RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
52
53# overlaysink rely on G2D,
54# cannot be supported on i.MX6SLL & i.MX6UL & i.MX6ULL & i.MX7D
55PACKAGECONFIG ?= ""
56PACKAGECONFIG:imxgpu2d = "overlaysink"
57
58
59# FIXME: Add all features
60# feature from excluded mm packages
61PACKAGECONFIG[ac3] = ",,imx-ac3codec,imx-ac3codec"
62# feature from special mm packages
63PACKAGECONFIG[aacp] = ",,imx-aacpcodec,imx-aacpcodec"
64MSDEPENDS = "imx-msparser imx-mscodec"
65PACKAGECONFIG[wma10dec] = ",,${MSDEPENDS},${MSDEPENDS}"
66PACKAGECONFIG[wma8enc] = ",,${MSDEPENDS},${MSDEPENDS}"
67PACKAGECONFIG[overlaysink] += ",,virtual/libg2d"
68
69FILES:${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}"
70
71FILES:${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
72FILES:${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc"
73FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
74FILES:${PN}-gplay = "${bindir}/gplay-1.0"
75FILES:${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}"
76FILES:${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}"
77FILES:${PN}-grecorder = "${bindir}/grecorder-1.0"
78FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}"
79FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}"
80
81COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"