summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.5.1.bb')
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.5.1.bb83
1 files changed, 83 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.5.1.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.5.1.bb
new file mode 100644
index 00000000..e7ecef74
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.5.1.bb
@@ -0,0 +1,83 @@
1# Copyright (C) 2014,2016 Freescale Semiconductor
2# Copyright 2017-2018 NXP
3# Copyright (C) 2012-2015 O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "Gstreamer freescale plugins"
7LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
8SECTION = "multimedia"
9
10DEPENDS = "imx-codec imx-parser gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
11DEPENDS_append_mx6 = " imx-lib"
12DEPENDS_append_mx7 = " imx-lib"
13DEPENDS_append_imxvpu = " imx-vpuwrap libdrm"
14
15# For backwards compatibility
16RREPLACES_${PN} = "gst1.0-fsl-plugin"
17RPROVIDES_${PN} = "gst1.0-fsl-plugin"
18RCONFLICTS_${PN} = "gst1.0-fsl-plugin"
19
20LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
21 file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
22
23IMXGST_SRC ?= "git://source.codeaurora.org/external/imx/imx-gst1.0-plugin.git;protocol=https"
24SRCBRANCH = "MM_04.05.01_1909_L4.19.35"
25
26SRC_URI = "${IMXGST_SRC};branch=${SRCBRANCH}"
27SRCREV = "3330461b906153a180ef9bda58368ed6782e2c28"
28
29S = "${WORKDIR}/git"
30
31inherit autotools pkgconfig use-imx-headers
32
33PLATFORM_mx6 = "MX6"
34PLATFORM_mx6sl = "MX6SL"
35PLATFORM_mx6sx = "MX6SX"
36PLATFORM_mx6ul = "MX6UL"
37PLATFORM_mx6sll = "MX6SLL"
38PLATFORM_mx7= "MX7D"
39PLATFORM_mx7ulp= "MX7ULP"
40PLATFORM_mx8 = "MX8"
41
42# Todo add a mechanism to map possible build targets
43EXTRA_OECONF = "PLATFORM=${PLATFORM} \
44 CPPFLAGS="-I${STAGING_INCDIR_IMX}" \
45 CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \
46 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', bb.utils.contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}"
47
48PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine ${PN}-libplayengine"
49
50# Add codec list that the beep plugin run-time depended
51BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis"
52RDEPENDS_${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
53
54# overlaysink rely on G2D,
55# cannot be supported on i.MX6SLL & i.MX6UL & i.MX6ULL & i.MX7D
56PACKAGECONFIG ?= ""
57PACKAGECONFIG_imxgpu2d = "overlaysink"
58
59
60# FIXME: Add all features
61# feature from excluded mm packages
62PACKAGECONFIG[ac3] += ",,imx-ac3codec,imx-ac3codec"
63# feature from special mm packages
64PACKAGECONFIG[aacp] += ",,imx-aacpcodec,imx-aacpcodec"
65MSDEPENDS = "imx-msparser imx-mscodec"
66PACKAGECONFIG[wma10dec] += ",,${MSDEPENDS},${MSDEPENDS}"
67PACKAGECONFIG[wma8enc] += "--enable-wma8enc,--disable-wma8enc,${MSDEPENDS},${MSDEPENDS}"
68OVDEPENDS = "virtual/libg2d"
69PACKAGECONFIG[overlaysink] += "--enable-overlaysink,--disable-overlaysink, ${OVDEPENDS}"
70
71FILES_${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}"
72
73FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
74FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc"
75FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
76FILES_${PN}-gplay = "${bindir}/gplay-1.0"
77FILES_${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}"
78FILES_${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}"
79FILES_${PN}-grecorder = "${bindir}/grecorder-1.0"
80FILES_${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}"
81FILES_${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}"
82
83COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"