diff options
Diffstat (limited to 'recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.0.bb')
-rw-r--r-- | recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.0.bb | 86 |
1 files changed, 86 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.0.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.0.bb new file mode 100644 index 00000000..00182bbd --- /dev/null +++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.0.bb | |||
@@ -0,0 +1,86 @@ | |||
1 | # Copyright (C) 2014,2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2018 NXP | ||
3 | # Copyright (C) 2012-2015 O.S. Systems Software LTDA. | ||
4 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
5 | |||
6 | DESCRIPTION = "Gstreamer freescale plugins" | ||
7 | LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1" | ||
8 | SECTION = "multimedia" | ||
9 | |||
10 | DEPENDS = "imx-codec imx-parser virtual/kernel gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" | ||
11 | DEPENDS_append_mx6 = " imx-lib" | ||
12 | DEPENDS_append_mx7 = " imx-lib" | ||
13 | DEPENDS_append_imxvpu = " imx-vpuwrap libdrm" | ||
14 | |||
15 | # For backwards compatibility | ||
16 | RREPLACES_${PN} = "gst1.0-fsl-plugin" | ||
17 | RPROVIDES_${PN} = "gst1.0-fsl-plugin" | ||
18 | RCONFLICTS_${PN} = "gst1.0-fsl-plugin" | ||
19 | |||
20 | LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | ||
21 | file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" | ||
22 | |||
23 | IMXGST_SRC ?= "git://source.codeaurora.org/external/imx/imx-gst1.0-plugin.git;protocol=https" | ||
24 | SRCBRANCH = "MM_04.04.00_1805_L4.9.88_MX8QXP_BETA2" | ||
25 | |||
26 | SRC_URI = "${IMXGST_SRC};branch=${SRCBRANCH}" | ||
27 | SRCREV = "ded3b04018ca71306da9bc38b0037b9ea99abd29" | ||
28 | |||
29 | S = "${WORKDIR}/git" | ||
30 | |||
31 | inherit autotools pkgconfig | ||
32 | |||
33 | # Make sure kernel sources are available | ||
34 | do_configure[depends] += "virtual/kernel:do_shared_workdir" | ||
35 | |||
36 | PLATFORM_mx6 = "MX6" | ||
37 | PLATFORM_mx6sl = "MX6SL" | ||
38 | PLATFORM_mx6sx = "MX6SX" | ||
39 | PLATFORM_mx6ul = "MX6UL" | ||
40 | PLATFORM_mx6sll = "MX6SLL" | ||
41 | PLATFORM_mx7= "MX7D" | ||
42 | PLATFORM_mx7ulp= "MX7ULP" | ||
43 | PLATFORM_mx8 = "MX8" | ||
44 | |||
45 | # Todo add a mechanism to map possible build targets | ||
46 | EXTRA_OECONF = "PLATFORM=${PLATFORM} \ | ||
47 | CPPFLAGS="-I${STAGING_KERNEL_BUILDDIR}/include/generated/uapi -I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" \ | ||
48 | CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \ | ||
49 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', bb.utils.contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}" | ||
50 | |||
51 | PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine ${PN}-libplayengine" | ||
52 | |||
53 | # Add codec list that the beep plugin run-time depended | ||
54 | BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis" | ||
55 | RDEPENDS_${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " | ||
56 | |||
57 | # overlaysink rely on G2D, | ||
58 | # cannot be supported on i.MX6SLL & i.MX6UL & i.MX6ULL & i.MX7D | ||
59 | PACKAGECONFIG ?= "" | ||
60 | PACKAGECONFIG_imxgpu2d = "overlaysink" | ||
61 | |||
62 | |||
63 | # FIXME: Add all features | ||
64 | # feature from excluded mm packages | ||
65 | PACKAGECONFIG[ac3] += ",,imx-ac3codec,imx-ac3codec" | ||
66 | # feature from special mm packages | ||
67 | PACKAGECONFIG[aacp] += ",,imx-aacpcodec,imx-aacpcodec" | ||
68 | MSDEPENDS = "imx-msparser imx-mscodec" | ||
69 | PACKAGECONFIG[wma10dec] += ",,${MSDEPENDS},${MSDEPENDS}" | ||
70 | PACKAGECONFIG[wma8enc] += "--enable-wma8enc,--disable-wma8enc,${MSDEPENDS},${MSDEPENDS}" | ||
71 | OVDEPENDS = "virtual/libg2d" | ||
72 | PACKAGECONFIG[overlaysink] += "--enable-overlaysink,--disable-overlaysink, ${OVDEPENDS}" | ||
73 | |||
74 | FILES_${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}" | ||
75 | |||
76 | FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug" | ||
77 | FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc" | ||
78 | FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a" | ||
79 | FILES_${PN}-gplay = "${bindir}/gplay-1.0" | ||
80 | FILES_${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}" | ||
81 | FILES_${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}" | ||
82 | FILES_${PN}-grecorder = "${bindir}/grecorder-1.0" | ||
83 | FILES_${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" | ||
84 | FILES_${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}" | ||
85 | |||
86 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" | ||