summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0_1.20.0.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0_1.20.0.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.20.0.imx.bb99
1 files changed, 99 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.20.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.20.0.imx.bb
new file mode 100644
index 00000000..3c9424e2
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.20.0.imx.bb
@@ -0,0 +1,99 @@
1# This recipe is for the i.MX fork of gstreamer1.0. For ease of
2# maintenance, the top section is a verbatim copy of an OE-core
3# recipe. The second section customizes the recipe for i.MX.
4
5########### OE-core copy ##################
6# Upstream hash: a21649109374fde44cf77de845cfb3cb6cbfb138
7
8SUMMARY = "GStreamer 1.0 multimedia framework"
9DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
10It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
11HOMEPAGE = "http://gstreamer.freedesktop.org/"
12BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
13SECTION = "multimedia"
14LICENSE = "LGPL-2.1-or-later"
15
16DEPENDS = "glib-2.0 glib-2.0-native libxml2 bison-native flex-native"
17
18inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection ptest-gnome
19
20LIC_FILES_CHKSUM = "file://COPYING;md5=69333daa044cb77e486cc36129f7a770 \
21 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
22
23S = "${WORKDIR}/gstreamer-${PV}"
24
25SRC_URI = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
26 file://run-ptest \
27 file://0001-tests-respect-the-idententaion-used-in-meson.patch;striplevel=3 \
28 file://0002-tests-add-support-for-install-the-tests.patch;striplevel=3 \
29 file://0003-tests-use-a-dictionaries-for-environment.patch;striplevel=3 \
30 file://0004-tests-add-helper-script-to-run-the-installed_tests.patch;striplevel=3 \
31 file://0005-tests-remove-gstbin-test_watch_for_state_change-test.patch \
32 "
33SRC_URI[sha256sum] = "de094a404a3ad8f4977829ea87edf695a4da0b5c8f613ebe54ab414bac89f031"
34
35PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
36 check \
37 debug \
38 tools"
39
40PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false"
41PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false"
42PACKAGECONFIG[coretracers] = "-Dcoretracers=enabled,-Dcoretracers=disabled"
43PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled"
44PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled_tests=true,-Dtests=disabled -Dinstalled_tests=false"
45PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
46PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils"
47PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion"
48PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled"
49PACKAGECONFIG[setcap] = "-Dptp-helper-permissions=capabilities,,libcap libcap-native"
50
51# TODO: put this in a gettext.bbclass patch
52def gettext_oemeson(d):
53 if d.getVar('USE_NLS') == 'no':
54 return '-Dnls=disabled'
55 # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
56 if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
57 return '-Dnls=disabled'
58 return '-Dnls=enabled'
59
60EXTRA_OEMESON += " \
61 -Ddoc=disabled \
62 -Dexamples=disabled \
63 -Ddbghelp=disabled \
64 ${@gettext_oemeson(d)} \
65"
66
67GIR_MESON_ENABLE_FLAG = "enabled"
68GIR_MESON_DISABLE_FLAG = "disabled"
69
70PACKAGES += "${PN}-bash-completion"
71
72# Add the core element plugins to the main package
73FILES:${PN} += "${libdir}/gstreamer-1.0/*.so"
74FILES:${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
75FILES:${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
76FILES:${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb"
77
78CVE_PRODUCT = "gstreamer"
79
80PTEST_BUILD_HOST_FILES = ""
81
82########### End of OE-core copy ###########
83
84########### i.MX overrides ################
85
86DEFAULT_PREFERENCE = "-1"
87
88# Use i.MX fork of GST for customizations
89SRC_URI:remove = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz"
90SRC_URI:prepend = "${GST1.0_SRC};branch=${SRCBRANCH} "
91GST1.0_SRC ?= "gitsm://source.codeaurora.org/external/imx/gstreamer.git;protocol=https"
92SRCBRANCH = "MM_04.07.00_2205_L5.15.y"
93SRCREV = "7afc123bc6974d68795f97466eb83ec7a093fb9b"
94
95S = "${WORKDIR}/git"
96
97COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
98
99########### End of i.MX overrides #########