summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb82
1 files changed, 82 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb
new file mode 100644
index 00000000..cbbcf9b4
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb
@@ -0,0 +1,82 @@
1SUMMARY = "GStreamer 1.0 multimedia framework"
2DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
3It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
4HOMEPAGE = "http://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
6SECTION = "multimedia"
7LICENSE = "LGPLv2+"
8
9DEPENDS = "glib-2.0 glib-2.0-native libxml2 bison-native flex-native"
10
11inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection ptest-gnome
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
14 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
15
16S = "${WORKDIR}/git"
17
18# Use i.MX fork of GST for customizations
19GST1.0_SRC ?= "gitsm://source.codeaurora.org/external/imx/gstreamer.git;protocol=https"
20SRCBRANCH = "MM_04.06.01_2105_L5.10.y"
21SRC_URI = "${GST1.0_SRC};branch=${SRCBRANCH} \
22 file://run-ptest \
23 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
24 file://0002-Remove-unused-valgrind-detection.patch \
25 file://0003-tests-seek-Don-t-use-too-strict-timeout-for-validati.patch \
26 file://0004-tests-respect-the-idententaion-used-in-meson.patch \
27 file://0005-tests-add-support-for-install-the-tests.patch \
28 file://0006-tests-use-a-dictionaries-for-environment.patch \
29 file://0007-tests-install-the-environment-for-installed_tests.patch \
30 "
31SRCREV = "2f20fd10eaf8629b3e8c134424c38412c4d3bd86"
32
33DEFAULT_PREFERENCE = "-1"
34
35PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
36 check \
37 debug \
38 tools"
39
40PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false"
41PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false"
42PACKAGECONFIG[coretracers] = "-Dcoretracers=enabled,-Dcoretracers=disabled"
43PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled"
44PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled-tests=true,-Dtests=disabled -Dinstalled-tests=false"
45PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
46PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils"
47PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion"
48PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled"
49PACKAGECONFIG[setcap] = "-Dptp-helper-permissions=capabilities,,libcap libcap-native"
50
51# TODO: put this in a gettext.bbclass patch
52def gettext_oemeson(d):
53 if d.getVar('USE_NLS') == 'no':
54 return '-Dnls=disabled'
55 # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
56 if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
57 return '-Dnls=disabled'
58 return '-Dnls=enabled'
59
60EXTRA_OEMESON += " \
61 -Ddoc=disabled \
62 -Dexamples=disabled \
63 -Ddbghelp=disabled \
64 ${@gettext_oemeson(d)} \
65"
66
67GIR_MESON_ENABLE_FLAG = "enabled"
68GIR_MESON_DISABLE_FLAG = "disabled"
69
70PACKAGES += "${PN}-bash-completion"
71
72# Add the core element plugins to the main package
73FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
74FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
75FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
76FILES_${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb"
77
78CVE_PRODUCT = "gstreamer"
79
80PTEST_BUILD_HOST_FILES = ""
81
82COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"