summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0/0002-Remove-unused-valgrind-detection.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0/0002-Remove-unused-valgrind-detection.patch')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0/0002-Remove-unused-valgrind-detection.patch110
1 files changed, 0 insertions, 110 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0/0002-Remove-unused-valgrind-detection.patch b/recipes-multimedia/gstreamer/gstreamer1.0/0002-Remove-unused-valgrind-detection.patch
deleted file mode 100644
index 5805e8b6..00000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0/0002-Remove-unused-valgrind-detection.patch
+++ /dev/null
@@ -1,110 +0,0 @@
1From d7f05d09c55d35bbe4e0f856759519ef183d9a56 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim@centricular.com>
3Date: Fri, 14 Aug 2020 16:38:26 +0100
4Subject: [PATCH] Remove unused valgrind detection
5
6Having this just to log a debug message in case we're
7running inside valgrind doesn't seem very useful, and
8the code that used to use this no longer exists it seems.
9
10Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/595>
11
12Upstream-Status: Backport [a2cbf75523cdf8a4df1baa7007d86ef455972245]
13
14Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
15
16---
17 gst/gst_private.h | 2 --
18 gst/gstinfo.c | 39 ---------------------------------------
19 meson.build | 1 -
20 3 files changed, 42 deletions(-)
21
22diff --git a/gst/gst_private.h b/gst/gst_private.h
23index eefd044d9..8252ede51 100644
24--- a/gst/gst_private.h
25+++ b/gst/gst_private.h
26@@ -116,8 +116,6 @@ G_GNUC_INTERNAL gboolean _priv_plugin_deps_env_vars_changed (GstPlugin * plugin
27
28 G_GNUC_INTERNAL gboolean _priv_plugin_deps_files_changed (GstPlugin * plugin);
29
30-G_GNUC_INTERNAL gboolean _priv_gst_in_valgrind (void);
31-
32 /* init functions called from gst_init(). */
33 G_GNUC_INTERNAL void _priv_gst_quarks_initialize (void);
34 G_GNUC_INTERNAL void _priv_gst_mini_object_initialize (void);
35diff --git a/gst/gstinfo.c b/gst/gstinfo.c
36index eea1a219d..d3035d6db 100644
37--- a/gst/gstinfo.c
38+++ b/gst/gstinfo.c
39@@ -305,36 +305,6 @@ static gboolean pretty_tags = PRETTY_TAGS_DEFAULT;
40 static gint G_GNUC_MAY_ALIAS __default_level = GST_LEVEL_DEFAULT;
41 static gint G_GNUC_MAY_ALIAS __use_color = GST_DEBUG_COLOR_MODE_ON;
42
43-/* FIXME: export this? */
44-gboolean
45-_priv_gst_in_valgrind (void)
46-{
47- static enum
48- {
49- GST_VG_UNCHECKED,
50- GST_VG_NO_VALGRIND,
51- GST_VG_INSIDE
52- }
53- in_valgrind = GST_VG_UNCHECKED;
54-
55- if (in_valgrind == GST_VG_UNCHECKED) {
56-#ifdef HAVE_VALGRIND_VALGRIND_H
57- if (RUNNING_ON_VALGRIND) {
58- GST_CAT_INFO (GST_CAT_GST_INIT, "we're running inside valgrind");
59- in_valgrind = GST_VG_INSIDE;
60- } else {
61- GST_CAT_LOG (GST_CAT_GST_INIT, "not doing extra valgrind stuff");
62- in_valgrind = GST_VG_NO_VALGRIND;
63- }
64-#else
65- in_valgrind = GST_VG_NO_VALGRIND;
66-#endif
67- g_assert (in_valgrind == GST_VG_NO_VALGRIND ||
68- in_valgrind == GST_VG_INSIDE);
69- }
70- return (in_valgrind == GST_VG_INSIDE);
71-}
72-
73 static gchar *
74 _replace_pattern_in_gst_debug_file_name (gchar * name, const char *token,
75 guint val)
76@@ -463,9 +433,6 @@ _priv_gst_debug_init (void)
77 _priv_GST_CAT_PROTECTION =
78 _gst_debug_category_new ("GST_PROTECTION", 0, "protection");
79
80- /* print out the valgrind message if we're in valgrind */
81- _priv_gst_in_valgrind ();
82-
83 env = g_getenv ("GST_DEBUG_OPTIONS");
84 if (env != NULL) {
85 if (strstr (env, "full_tags") || strstr (env, "full-tags"))
86@@ -2505,12 +2472,6 @@ gst_debug_construct_win_color (guint colorinfo)
87 return 0;
88 }
89
90-gboolean
91-_priv_gst_in_valgrind (void)
92-{
93- return FALSE;
94-}
95-
96 void
97 _gst_debug_dump_mem (GstDebugCategory * cat, const gchar * file,
98 const gchar * func, gint line, GObject * obj, const gchar * msg,
99diff --git a/meson.build b/meson.build
100index 82a17282b..42ae61790 100644
101--- a/meson.build
102+++ b/meson.build
103@@ -200,7 +200,6 @@ check_headers = [
104 'sys/wait.h',
105 'ucontext.h',
106 'unistd.h',
107- 'valgrind/valgrind.h',
108 'sys/resource.h',
109 'sys/uio.h',
110 ]