summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.2.0.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.2.0.bb80
1 files changed, 80 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.2.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.2.0.bb
new file mode 100644
index 00000000..7e2f2573
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.2.0.bb
@@ -0,0 +1,80 @@
1# Copyright (C) 2018 O.S. Systems Software LTDA.
2DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
5SECTION = "multimedia"
6DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base libimxdmabuffer"
7# add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers
8# for the uniaudio decoder, videoparsersbad for the VPU video decoder
9# the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is
10# built (it is not a compile-time dependency however, hence RDEPENDS and not DEPENDS)
11RDEPENDS_gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good gstreamer1.0-plugins-bad"
12RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers"
13RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad"
14
15PV .= "+git${SRCPV}"
16
17SRCBRANCH ?= "master"
18SRCREV = "cb3cd45676e808b222ac573e8a118f44fd70c288"
19SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH};protocol=https"
20
21S = "${WORKDIR}/git"
22
23# Setting DEFAULT_PREFERENCE to -1 since dunfell has had gstreamer-imx version
24# 0.13.1 for a long time already, so silently replacing it with version 2.1.0
25# may break existing BSPs.
26DEFAULT_PREFERENCE = "-1"
27
28inherit pkgconfig meson use-imx-headers
29
30# libg2d on i.MX8 SoCs with a DPU is emulated via the DPU.
31# That particular libg2d .so depends on libdrm, however.
32# Also, due to behavioral differences, an additional flag
33# is needed to improve performance.
34LIBG2D_DPU_OPTION = "-Dg2d-based-on-dpu=false"
35LIBG2D_DEPENDENCIES = "virtual/libg2d"
36LIBG2D_DPU_OPTION_imxdpu = "-Dg2d-based-on-dpu=true"
37LIBG2D_DEPENDENCIES_imxdpu = "virtual/libg2d libdrm"
38
39# OE dunfell's meson version does not have the necessary
40# functionality for build scripts to query the sysroot path,
41# so it must be specified manually via the -Dsysroot option.
42EXTRA_OEMESON += "-Dimx-headers-path=${STAGING_INCDIR_IMX} -Dsysroot=${RECIPE_SYSROOT}"
43
44PACKAGECONFIG ?= "uniaudiodec"
45PACKAGECONFIG_append_imxgpu2d = " g2d"
46PACKAGECONFIG_append_imxvpu = " vpu"
47PACKAGECONFIG_append_imxipu = " ipu"
48PACKAGECONFIG_append_imxpxp = " pxp"
49# The custom imxv4l2 source and sink elements are only
50# available on the i.MX6.
51# The 2D blitter sinks require an MXC framebuffer, which
52# is not available anymore on the i.MX8 (since these SoCs
53# now use KMS instead of the old Linux framebuffer).
54PACKAGECONFIG_append_mx6 = " imx2dvideosink v4l2-mxc-source-sink"
55PACKAGECONFIG_append_mx7 = " imx2dvideosink"
56# The custom Amphion V4L2 mem-2-mem elements are meant for
57# the QuadMax and QuadXPlus SoCs.
58PACKAGECONFIG_append_mx8qm = " v4l2-amphion"
59PACKAGECONFIG_append_mx8qxp = " v4l2-amphion"
60
61PACKAGECONFIG[g2d] = "-Dg2d=enabled ${LIBG2D_DPU_OPTION},-Dg2d=disabled,${LIBG2D_DEPENDENCIES}"
62PACKAGECONFIG[pxp] = "-Dpxp=enabled,-Dpxp=disabled,"
63PACKAGECONFIG[ipu] = "-Dipu=enabled,-Dipu=disabled,"
64PACKAGECONFIG[vpu] = "-Dvpu=enabled,-Dvpu=disabled,libimxvpuapi2"
65PACKAGECONFIG[imx2dvideosink] = "-Dimx2d-videosink=true,-Dimx2d-videosink=false,"
66PACKAGECONFIG[v4l2-mxc-source-sink] = "-Dv4l2-mxc-source-sink=true,-Dv4l2-mxc-source-sink=false,"
67# v4l2-isi is not enabled by default because the ISI devices
68# need to be turned on in the devicetree. See the readme on
69# the gstreamer-imx github site for details.
70PACKAGECONFIG[v4l2-isi] = "-Dv4l2-isi=true,-Dv4l2-isi=false,"
71PACKAGECONFIG[v4l2-amphion] = "-Dv4l2-amphion=enabled,-Dv4l2-amphion=disabled,"
72PACKAGECONFIG[uniaudiodec] = "-Duniaudiodec=enabled,-Duniaudiodec=disabled,imx-codec"
73PACKAGECONFIG[mp3encoder] = "-Dmp3encoder=enabled,-Dmp3encoder=disabled,imx-codec"
74
75require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc
76
77# the following line is required to produce one package for each plugin
78PACKAGES_DYNAMIC = "^${PN}-.*"
79
80COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx8)"