summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.5.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.5.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.5.imx.bb111
1 files changed, 111 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.5.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.5.imx.bb
new file mode 100644
index 00000000..de61be01
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.5.imx.bb
@@ -0,0 +1,111 @@
1# This recipe is for the i.MX fork of gstreamer1.0-plugins-good. For ease of
2# maintenance, the top section is a verbatim copy of an OE-core
3# recipe. The second section customizes the recipe for i.MX.
4
5########### OE-core copy ##################
6# Upstream hash: bb6ddc3691ab04162ec5fd69a2d5e7876713fd15
7
8require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
9
10DESCRIPTION = "'Good' GStreamer plugins"
11HOMEPAGE = "https://gstreamer.freedesktop.org/"
12BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues"
13
14SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \
15 file://0001-qt-include-ext-qt-gstqtgl.h-instead-of-gst-gl-gstglf.patch \
16 file://0002-rtpjitterbuffer-Fix-parsing-of-the-mediaclk-direct-f.patch \
17 file://0003-Remove-volatile-from-static-vars-to-fix-build-with-g.patch \
18 "
19
20SRC_URI[sha256sum] = "b6e50e3a9bbcd56ee6ec71c33aa8332cc9c926b0c1fae995aac8b3040ebe39b0"
21
22S = "${WORKDIR}/gst-plugins-good-${PV}"
23
24LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
25LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
26 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
27
28DEPENDS += "gstreamer1.0-plugins-base libcap zlib"
29RPROVIDES:${PN}-pulseaudio += "${PN}-pulse"
30RPROVIDES:${PN}-soup += "${PN}-souphttpsrc"
31
32PACKAGECONFIG ??= " \
33 ${GSTREAMER_ORC} \
34 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \
35 ${@bb.utils.contains('TUNE_FEATURES', 'm64', 'asm', '', d)} \
36 bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 soup speex taglib v4l2 \
37"
38
39X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
40X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
41X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
42
43QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
44
45PACKAGECONFIG[asm] = "-Dasm=enabled,-Dasm=disabled,nasm-native"
46PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
47PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
48PACKAGECONFIG[dv1394] = "-Ddv1394=enabled,-Ddv1394=disabled,libiec61883 libavc1394 libraw1394"
49PACKAGECONFIG[flac] = "-Dflac=enabled,-Dflac=disabled,flac"
50PACKAGECONFIG[gdk-pixbuf] = "-Dgdk-pixbuf=enabled,-Dgdk-pixbuf=disabled,gdk-pixbuf"
51PACKAGECONFIG[gtk] = "-Dgtk3=enabled,-Dgtk3=disabled,gtk+3"
52PACKAGECONFIG[gudev] = "-Dv4l2-gudev=enabled,-Dv4l2-gudev=disabled,libgudev"
53PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack"
54PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg"
55PACKAGECONFIG[lame] = "-Dlame=enabled,-Dlame=disabled,lame"
56PACKAGECONFIG[libpng] = "-Dpng=enabled,-Dpng=disabled,libpng"
57PACKAGECONFIG[libv4l2] = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
58PACKAGECONFIG[mpg123] = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
59PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
60PACKAGECONFIG[qt5] = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
61PACKAGECONFIG[soup] = "-Dsoup=enabled,-Dsoup=disabled,libsoup-2.4"
62PACKAGECONFIG[speex] = "-Dspeex=enabled,-Dspeex=disabled,speex"
63PACKAGECONFIG[rpi] = "-Drpicamsrc=enabled,-Drpicamsrc=disabled,userland"
64PACKAGECONFIG[taglib] = "-Dtaglib=enabled,-Dtaglib=disabled,taglib"
65PACKAGECONFIG[v4l2] = "-Dv4l2=enabled -Dv4l2-probe=true,-Dv4l2=disabled -Dv4l2-probe=false"
66PACKAGECONFIG[vpx] = "-Dvpx=enabled,-Dvpx=disabled,libvpx"
67PACKAGECONFIG[wavpack] = "-Dwavpack=enabled,-Dwavpack=disabled,wavpack"
68PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
69
70EXTRA_OEMESON += " \
71 -Ddoc=disabled \
72 -Daalib=disabled \
73 -Ddirectsound=disabled \
74 -Ddv=disabled \
75 -Dlibcaca=disabled \
76 -Doss=enabled \
77 -Doss4=disabled \
78 -Dosxaudio=disabled \
79 -Dosxvideo=disabled \
80 -Dshout2=disabled \
81 -Dtwolame=disabled \
82 -Dwaveform=disabled \
83"
84
85FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
86
87########### End of OE-core copy ###########
88
89########### i.MX overrides ################
90
91DEFAULT_PREFERENCE = "-1"
92
93# fb implementation of v4l2 uses libdrm
94DEPENDS_V4L2 = "${@bb.utils.contains_any('DISTRO_FEATURES', 'wayland x11', '', 'libdrm', d)}"
95DEPENDS += "${@bb.utils.contains('PACKAGECONFIG', 'v4l2', '${DEPENDS_V4L2}', '', d)}"
96
97SRC_URI:remove = " \
98 https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \
99 file://0002-rtpjitterbuffer-Fix-parsing-of-the-mediaclk-direct-f.patch \
100 file://0003-Remove-volatile-from-static-vars-to-fix-build-with-g.patch \
101"
102GST1.0-PLUGINS-GOOD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-good.git;protocol=https"
103SRCBRANCH = "MM_04.06.04_2112_L5.15.y"
104SRC_URI:prepend = "${GST1.0-PLUGINS-GOOD_SRC};branch=${SRCBRANCH} "
105SRCREV = "2438ae179ed4245fbeaa2ce36b1918ed7232d442"
106
107S = "${WORKDIR}/git"
108
109COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
110
111########### End of i.MX overrides #########