summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb141
1 files changed, 141 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb
new file mode 100644
index 00000000..3fce3a58
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb
@@ -0,0 +1,141 @@
1# This recipe is for the i.MX fork of gstreamer1.0-plugins-base. For ease of
2# maintenance, the top section is a verbatim copy of an OE-core
3# recipe. The second section customizes the recipe for i.MX.
4
5########### OE-core copy ##################
6# Upstream hash: a21649109374fde44cf77de845cfb3cb6cbfb138
7
8require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
9
10DESCRIPTION = "'Base' GStreamer plugins and helper libraries"
11HOMEPAGE = "https://gstreamer.freedesktop.org/"
12BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues"
13LICENSE = "LGPL-2.1-or-later"
14LIC_FILES_CHKSUM = "file://COPYING;md5=69333daa044cb77e486cc36129f7a770"
15
16SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \
17 file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \
18 file://0003-viv-fb-Make-sure-config.h-is-included.patch \
19 file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \
20 "
21SRC_URI[sha256sum] = "96d8a6413ba9394fbec1217aeef63741a729d476a505a797c1d5337d8fa7c204"
22
23S = "${WORKDIR}/gst-plugins-base-${PV}"
24
25DEPENDS += "iso-codes util-linux zlib"
26
27inherit gobject-introspection
28
29PACKAGES_DYNAMIC =+ "^libgst.*"
30
31# opengl packageconfig factored out to make it easy for distros
32# and BSP layers to choose OpenGL APIs/platforms/window systems
33PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
34
35PACKAGECONFIG ??= " \
36 ${GSTREAMER_ORC} \
37 ${PACKAGECONFIG_GL} \
38 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \
39 jpeg ogg pango png theora vorbis \
40 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \
41"
42
43OPENGL_APIS = 'opengl gles2'
44OPENGL_PLATFORMS = 'egl'
45
46X11DEPENDS = "virtual/libx11 libsm libxrender libxv"
47X11ENABLEOPTS = "-Dx11=enabled -Dxvideo=enabled -Dxshm=enabled"
48X11DISABLEOPTS = "-Dx11=disabled -Dxvideo=disabled -Dxshm=disabled"
49
50PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib"
51PACKAGECONFIG[cdparanoia] = "-Dcdparanoia=enabled,-Dcdparanoia=disabled,cdparanoia"
52PACKAGECONFIG[graphene] = "-Dgl-graphene=enabled,-Dgl-graphene=disabled,graphene"
53PACKAGECONFIG[jpeg] = "-Dgl-jpeg=enabled,-Dgl-jpeg=disabled,jpeg"
54PACKAGECONFIG[ogg] = "-Dogg=enabled,-Dogg=disabled,libogg"
55PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus"
56PACKAGECONFIG[pango] = "-Dpango=enabled,-Dpango=disabled,pango"
57PACKAGECONFIG[png] = "-Dgl-png=enabled,-Dgl-png=disabled,libpng"
58PACKAGECONFIG[qt5] = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native"
59PACKAGECONFIG[theora] = "-Dtheora=enabled,-Dtheora=disabled,libtheora"
60PACKAGECONFIG[tremor] = "-Dtremor=enabled,-Dtremor=disabled,tremor"
61PACKAGECONFIG[visual] = "-Dlibvisual=enabled,-Dlibvisual=disabled,libvisual"
62PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis"
63PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
64
65# OpenGL API packageconfigs
66PACKAGECONFIG[opengl] = ",,virtual/libgl libglu"
67PACKAGECONFIG[gles2] = ",,virtual/libgles2"
68
69# OpenGL platform packageconfigs
70PACKAGECONFIG[egl] = ",,virtual/egl"
71
72# OpenGL window systems (except for X11)
73PACKAGECONFIG[gbm] = ",,virtual/libgbm libgudev libdrm"
74PACKAGECONFIG[wayland] = ",,wayland-native wayland wayland-protocols libdrm"
75PACKAGECONFIG[dispmanx] = ",,virtual/libomxil"
76PACKAGECONFIG[viv-fb] = ",,virtual/libgles2 virtual/libg2d"
77
78OPENGL_WINSYS = "${@bb.utils.filter('PACKAGECONFIG', 'x11 gbm wayland dispmanx egl viv-fb', d)}"
79
80EXTRA_OEMESON += " \
81 -Ddoc=disabled \
82 ${@get_opengl_cmdline_list('gl_api', d.getVar('OPENGL_APIS'), d)} \
83 ${@get_opengl_cmdline_list('gl_platform', d.getVar('OPENGL_PLATFORMS'), d)} \
84 ${@get_opengl_cmdline_list('gl_winsys', d.getVar('OPENGL_WINSYS'), d)} \
85"
86
87FILES:${PN}-dev += "${libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h"
88FILES:${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict"
89
90def get_opengl_cmdline_list(switch_name, options, d):
91 selected_options = []
92 if bb.utils.contains('DISTRO_FEATURES', 'opengl', True, False, d):
93 for option in options.split():
94 if bb.utils.contains('PACKAGECONFIG', option, True, False, d):
95 selected_options += [option]
96 if selected_options:
97 return '-D' + switch_name + '=' + ','.join(selected_options)
98 else:
99 return ''
100
101CVE_PRODUCT += "gst-plugins-base"
102
103########### End of OE-core copy ###########
104
105########### i.MX overrides ################
106
107DEFAULT_PREFERENCE = "-1"
108
109SRC_URI:remove = " \
110 https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \
111 file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \
112 file://0003-viv-fb-Make-sure-config.h-is-included.patch \
113 file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch"
114SRC_URI:prepend = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} "
115GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https"
116SRCBRANCH = "MM_04.07.00_2205_L5.15.y"
117SRCREV = "4b8559690bf7a66745cc65900baccd955b436d3c"
118
119S = "${WORKDIR}/git"
120
121inherit use-imx-headers
122
123PACKAGECONFIG_GL:imxgpu2d = \
124 "${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl viv-fb', '', d)}"
125PACKAGECONFIG_GL:imxgpu3d = \
126 "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl viv-fb', '', d)}"
127PACKAGECONFIG_GL:use-mainline-bsp = \
128 "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl gbm', '', d)}"
129
130PACKAGECONFIG_REMOVE ?= "jpeg"
131PACKAGECONFIG:remove = "${PACKAGECONFIG_REMOVE}"
132PACKAGECONFIG:append:imxgpu2d = " g2d"
133
134PACKAGECONFIG[g2d] = ",,virtual/libg2d"
135PACKAGECONFIG[viv-fb] = ",,virtual/libgles2"
136
137EXTRA_OEMESON += "-Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}""
138
139COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
140
141########### End of i.MX overrides #########